Excel : Décompte sans doublons d'une plage

Résolu/Fermé
Philippe - Modifié par Philippe le 30/05/2011 à 17:00
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
- 30 mai 2011 à 19:24
Bonjour,


j'ai un souci avec une formule permettant de compter les mots sans doublons dans une colonne.
A partir de A3, j'ai une liste de plusieurs milliers de mots.
L'aide m'indique d'utiliser la formule suivante pour compter le nombre de mots ss doublon :
=SOMME(SI(FREQUENCE(EQUIV(A3:A10;A3:A10;0);EQUIV(A3:A10;A3:A10;0))>0;1))


Ma plage varie et la formule suivante me donne une erreur :
=SOMME(SI(FREQUENCE(EQUIV(A:A;A:A;0);EQUIV(A:A;A:A;0))>0;1))


Avez-vous une idée de ce que je dois mettre sans avoir à varier ma plage à chaque fois?

7 réponses

Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 260
30 mai 2011 à 17:19
Bonjour
on peut aussi tenter d'utiliser celle ci:
=SOMME(SI(A1:A1000<>"";1/NB.SI(A1:A1000;A1:A1000)))
pour un champ de A1 à A1000 à adapter.
cette formule est matricielle et doit être entrée avec la touche enter en maintenant ctrl et shift enfoncée pour qu'elle se retrouve entre accolades dans la barre de formule.
(ça doit être le cas aussi, je pense, des propositions précédentes)

maintenant pour ajuster la formule à une plage "variable" il faudrait savoir ce qui varie dans la plage!

crdlmnt
3
Ta formule semble me donner un résultat correcte à l'exception près que je me retrouve avec une décimale.

Merci
0
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 260
30 mai 2011 à 19:24
s'il; y a une décimale, c'est qu'elle n'est pas entrée en matricielle:
soit avec les touches ctrl + shift + enter.
crdlmnt
0