Pokerth sur Debian Squeeze

Résolu/Fermé
Noldhor Messages postés 276 Date d'inscription samedi 19 septembre 2009 Statut Membre Dernière intervention 1 juillet 2011 - 22 mai 2011 à 17:04
mamiemando Messages postés 33199 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 19 juillet 2024 - 25 mai 2011 à 08:46
Bonjour à tous !!

Voilà, sur Debian Squeeze, j'ai installé le jeu pokerth via les dépots, mais il s'agit de la version 0.7.1-2 mais les serveurs sont plutôt vide car tout le monde ont migré vers la version 0.8.3-3
J'ai donc téléchargé la nouvelle version sur le site officiel ainsi que les dépendances.

Cependant, il y a une dépendance qui m'est impossible d'installé et je me demande s'il existe un moyen de contourner.

On me demande d'installer libqtcore4 (4:4.7.3-1) mais lorsque je l'install, j'ai ce message d'erreur:

Erreur : Breaks existing package 'libqt4-dbus' dependency libqtcore4 (= 4:4.6.3-4+squeeze1)

J'ai voulu désinstaller ce libqt4-dbus pour installer une version plus récente mais si je le désinstall, il désinstall automatiquement un tas de logiciel, ce que je ne veux pas...

Alors j'en suis là, si quelqu'un a une idée je suis preneur :)

Merci !




3 réponses

mamiemando Messages postés 33199 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 19 juillet 2024 7 763
22 mai 2011 à 23:58
Personnellement j'ai les deux paquets installés simultanément sous debian wheezy. Je t'invite à passer en testing (wheezy), en plus pokerth est dans la version 0.8.3.3 donc tu n'auras rien à faire. Pour cela il suffit de remplacer stable (squeeze) par testing ou wheezy puis :

aptitude update
aptitude safe-upgrade


Autre solution, tu peux jongler avec aptitude sur les release (via /etc/apt/preferences) et avec l'option -t. Dans le tutoriel suivant j'explique comment jongler sur testing et unstable (sid) mais le principe est le même si tu désire faire la même chose entre stable et testing :
http://www.mistra.fr/tutoriel-linux-apt-configuration.html

Ensuite :
aptitude -t testing install pokerth


Bonne chance
Noldhor Messages postés 276 Date d'inscription samedi 19 septembre 2009 Statut Membre Dernière intervention 1 juillet 2011 71
24 mai 2011 à 21:21
Salut et merci mamiemando, j'ai upgradé en testing :)

mamiemando Messages postés 33199 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 19 juillet 2024 7 763
25 mai 2011 à 08:46
Parfait, bonne continuation !