Sommeprod et le texte

[Résolu/Fermé]
Signaler
Messages postés
16
Date d'inscription
mardi 1 mars 2011
Statut
Membre
Dernière intervention
19 mars 2012
-
Messages postés
16
Date d'inscription
mardi 1 mars 2011
Statut
Membre
Dernière intervention
19 mars 2012
-
Bonjour, j'utilise une fonction sommeprod qui effectue la somme dans une colonne en fonction de 2 critère. Or dans la colonne que je veux additionner il y a du texte (le mot confirmation) et la ma fonction me renvoie une erreur #valeur!.
Existe t-il un moyen d'ignorer le texte dans la colonne que je veux additionner??
Merci pour vos réponses.

2 réponses

Messages postés
16525
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
18 octobre 2021
3 231
Bonjour
Il faut passer par une matricielle; par exemple
=SOMME(SI((A1:A7="zaza1")*(B1:B7="zeze1")*(ESTNUM(C1:C7));(C1:C7)))

Formule à valider par « ctrl+maj+entrée » (et non directement par « entrée »), le curseur clignotant dans la barre de formule
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41713 internautes nous ont dit merci ce mois-ci

Messages postés
16
Date d'inscription
mardi 1 mars 2011
Statut
Membre
Dernière intervention
19 mars 2012

Merci pour la réponse, il me manquait juste le test pour savoir si la valeur est numérique (ESTNUM)
Merci beaucoup!!