Fonction sommeprod avec si texte present

Résolu/Fermé
dancesurfer - Modifié par dancesurfer le 22/06/2011 à 22:48
 iltotore - 6 janv. 2018 à 18:15
Bonjour,

Voici mon probleme, dans la ligne si dessous je voudrait que si les cellules en B contiennent "ISF" la valeur de cette cellule s'additionne, je n'arrive pas a trouver comment inclure la fonction cherche.




ligne excel : =SOMMEPROD(('Physical bad stock situation'!B2:B8699<>"")*('Physical bad stock situation'!B2:B8699=cherche"ISF")*('Physical bad stock situation'!I2:I8699))




Pouvez vous m'aider.

Merci d'avance à tous

1 réponse

pijaku Messages postés 12259 Date d'inscription jeudi 15 mai 2008 Statut Modérateur Dernière intervention 9 août 2022 2 709
Modifié par pijaku le 23/06/2011 à 12:00
Bonjour,
Une solution, pas très "propre", mais qui a l'air de vouloir fonctionner :
=SOMMEPROD(NON(ESTERREUR(TROUVE("ISF";'Physical bad stock situation'!B2:B8699)))*('Physical bad stock situation'!I2:I8699))
A tester...

EDIT : commentaires :
1- TROUVE("ISF",plage) renvoie une erreur #VALEUR lorsque la cellule ne contient pas ISF
2- ESTERREUR(TROUVE("ISF";plage)) renvoie VRAI lorsque la cellule ne contient pas ISF
3- NON(ESTERREUR(TROUVE("ISF";plage))) renvoie donc VRAI lorsque la cellule contient "ISF". Du coup, cette cellule s'inscrit en "VRAI" dans la matrice du SOMMEPROD....
Cordialement,
Franck P
3
super pijaku sa fonctionne je te remercie énormément. Merci beaucoup pour les explications, cela me permet d'apprendre une fonction supplémentaire et sa c'est génial. Saurait tu me dire également comment l'on peut faire sous excel pour trier les données entre tel et tel autre date ( dans un fichier de 1 ans je voudrait rechercher toutes les données inclues entre avril et juin grâce à une fonction s'incluant dans la ligne que tu ma créer et j'ai plusieurs millier de lignes).

Merci d'avance pour les réponse éventuelles.
0
pijaku Messages postés 12259 Date d'inscription jeudi 15 mai 2008 Statut Modérateur Dernière intervention 9 août 2022 2 709
24 juin 2011 à 09:59
Salut,
Par les filtres élaborés peut être...
0
dancesurfer
24 juin 2011 à 19:28
Bonjour Pijaku.

J'ai trouvé la solution avec l'option date.

Merci beaucoup pour ton aide.

Bien à toi Dancesurfer
0
bien joué, bravo, j'étais à 2 doigts de faire ça en vba !
0