Configuration VLAN sur Switch Cisco 2950

Fermé
Linnell - 8 avril 2006 à 11:31
 Ad - 7 juin 2015 à 22:33
Bonjour,
Je suis en BTS IG option ARLE et pendant mon stage j'ai effectuée une configuration de Switch cisco 2950.
Pour mon projet de stage cela n'est pas suffissant alors je voudrait le gonfler en ajoutant une partie VLAN mais je ne sais pas du tout comment se configure les VLAN sur un Cisco.

Si quelques a quelques rensegnements merci de m'aider car je n'ai plus qu'une semaine pour gonfler mon rapport !!!

Merci beaucoup

7 réponses

Introduction et rappels
Cet article a pour but d'expliquer et d'établir une configuration de routage inter-VLAN.


Bref rappel sur les VLANs et le VTP
Un VLAN peut être assimilé à un domaine de broadcast. Typiquement, dans une configuration de VLAN, chaque VLAN comprend son propre sous-réseau. Sans équipement de couche 3, il est donc impossible pour les terminaux d'un VLAN de communiquer avec les terminaux d'un autre VLAN. Le VLAN Trunking Protocol (VTP) est nécessaire si l'on veut étendre une configuration de VLAN sur plusieurs commutateurs. Pour cela, on crée un " trunk " entre les commutateurs. Ce trunk représente un canal par lequel transitent les trames des différents VLANs d'un commutateur à un autre. Pour que les commutateurs "sachent" à quel VLAN appartient une trame, un étiquetage est nécessaire. C'est pourquoi le VTP utilise deux protocoles d'étiquetage : ISL (Cisco) ou 802.1q (IEEE). Nous utiliserons ici le 802.1q qui est le protocole utilisé par défaut.
1. Configuration des VLANs

Pour l'exemple, les VLANs statiques seront utilisés. Chaque port de chaque commutateur va donc être attribué à un VLAN. Pour la description des commandes, les accolades indiquent un paramètre (obligatoire), les crochets une option.


1.1 Création des VLANs
Pour créer un VLAN, il faut se trouver dans le mode de configuration correspondant, accessible par la commande :
Switch_A# vlan database
A partir de ce mode, la création d'un VLAN se fait par la commande :
Switch_A(vlan)# vlan {numéro} [name {nom}]
Switch_A(vlan)# exit
Cette dernière commande permet d'enregistrer la configuration des VLANs, qui se trouve dans le fichier vlan.dat dans la mémoire Flash.
Dans une configuration de VLAN statique, les ports du commutateur doivent être attribués à un VLAN. Ceci se fait dans le mode de configuration de l'interface spécifiée :
Switch_A(config)#interface fastEthernet {numéro_interface}
on passe dans le mode de configuration de l'interface spécifiée
Switch_A(config-if)#switchport mode access
spécification du mode de l'interface
Switch_A(config-if)#switchport access vlan {numéro}
attribution du vlan spécifié à l'interface
La configuration est maintenant faite sur le commutateur Switch_A.




1.2 Configuration d'un domaine VTP




Pour propager cette configuration à un deuxième commutateur, ceux-ci doivent appartenir à un domaine commun : le domaine VTP. Ce domaine est organisé hiérarchiquement : le serveur VTP diffuse ses configurations VLAN, tandis que le client VTP met à jour sa configuration VLAN en fonction des informations reçues du serveur.
Considérons le commutateur Switch_A comme le serveur du domaine VTP, et le commutateur Switch_B comme le client. Les commandes nécessaires sont :

Switch_A# vlan database
Switch_A(vlan)# vtp domain {nom_domaine}
Switch_A(vlan)# vtp server
Switch_A(vlan)# exit
Switch_B# vlan database
Switch_B(vlan)# vtp domain {nom_domaine}
Switch_B(vlan)# vtp client
Switch_B(vlan)# exit

Enfin, un trunk est nécessaire entre ces deux équipements. C'est en effet par celui-ci que les trames étiquetées transitent. Entre deux commutateurs, un câble croisé doit être utilisé.
Un trunk est une connexion physique regroupant plusieurs connexions logiques. Dans le schéma, un câble physique laisse transiter 3 trafics logiques différents. Ceux-ci représentent les trafics propres à chaque VLAN.
L'encapsulation utilisée doit également être spécifiée, à moins que le commutateur utilisé n'accepte qu'un seul protocole. Chaque commutateur doit donc configurer une des ses interfaces pour accueillir un trunk :
Switch_A(config)# interface fastEthernet {numéro_interface}
Switch_A(config-if)# switchport mode trunk
Switch_A(config-if)# switchport trunk encapsulation {dot1q | isl}
Switch_B(config)# interface fastEthernet {numéro_interface}
Switch_B(config-if)# switchport mode trunk
Switch_A(config-if)# switchport trunk encapsulation {dot1q | isl}

A ce stade, la configuration VLAN du commutateur serveur est transmise au client. Il faut cependant assigner les ports du commutateur client aux VLANs spécifiés (la configuration transmise énumère seulement les VLANs crées et leurs noms) :

Switch_B(config)# interface fastEthernet {numéro_interface}
Switch_B(config-if)# switchport mode access
Switch_B(config-if)# switchport access vlan {numéro}

Désormais, chaque hôte peut communiquer avec un hôte du même VLAN, connecté sur un commutateur différent.

2. Configuration spécifique au routage inter VLAN
2.1 Sur le commutateur
Lorsque deux utilisateurs se trouvent sur des VLANS différents, ils se trouvent - en général - sur des sous-réseaux différents. Pour communiquer, ils doivent donc passer par une passerelle commune : l'interface du routeur connectée au commutateur. Pour spécifier au commutateur la passerelle utilisée pour "passer" d'un VLAN à un autre (ou plus généralement d'un sous-réseau à un autre), on utilise la commande :

Switch_A# ip default-gateway {adresse_ip}

2.2 Sur le routeur
La liaison routeur-commutateur constitue également un trunk. Cette connexion regroupe en effet plusieurs liens logiques : un trafic VLAN par sous-interface, sur une liaison physique : un câble droit connectant une interface du routeur à une interface d'un commutateur.



Chaque trafic de VLAN est supporté par une sous-interface du routeur. Il faut donc, pour chaque sous-interface, attribuer une adresse IP appartenant au sous-réseau du VLAN et spécifier l'encapsulation (étiquetage) utilisée:

R1(config)# interface fastEthernet {sous-interface}
R1(config-sub)# encapsulation {dot1q | isl}
R1(config-sub)# ip address {adresse_ip}



L'interface doit également avoir une adresse IP afin de constituer la passerelle:

R1(config)# interface fastEthernet {interface}
R1(config-if)# ip address {adresse_ip}

Chaque hôte peut désormais communiquer avec un hôte sur un VLAN différent. Lorsque le premier envoi une trame avec pour destination un sous-réseau différent du sous-réseau source, le commutateur l'encapsule et l'envoi à la passerelle par défaut. Après avoir traversé le trunk, la trame est traitée au niveau du routeur. Celui-ci la désencapsule, la réencapsule pour le VLAN de destination avant de l'envoyer sur la sous-interface correspondante.

3. Configuration complète
3.1 Configuration du switch_A
Création des VLANs
Switch_A# vlan database
Switch_A(vlan)# vlan 2 name VLAN_2
Switch_A(vlan)# vlan 3 name VLAN_3
Switch_A(vlan)# vlan 4 name VLAN_4
Switch_A(vlan)# vtp domain cisco
Switch_A(vlan)# vtp server
Switch_A(vlan)# exit
Création des trunk
Switch_A(config)# interface fastEthernet 0/1
Switch_A(config-if)# switchport mode trunk
Switch_A(config-if)# switchport trunk encapsulation dot1q
Switch_A(config-if)# exit

Switch_A(config)# interface fastEthernet 0/8
Switch_A(config-if)# switchport mode trunk
Switch_A(config-if)# switchport trunk encapsulation dot1q
Switch_A(config-if)# exit
Attribution des VLANs aux ports
Switch_A(config)# interface fastEthernet 0/2
Switch_A(config-if)# switchport mode access
Switch_A(config-if)# switchport access vlan 2
Switch_A(config-if)# exit
Switch_A(config)# interface fastEthernet 0/3
Switch_A(config-if)# switchport mode access
Switch_A(config-if)# switchport access vlan 3
Switch_A(config-if)# exit
Switch_A(config)# interface fastEthernet 0/4
Switch_A(config-if)# switchport mode access
Switch_A(config-if)# switchport access vlan 4
Switch_A(config-if)# exit
Définition de la passerelle par défaut
Switch_A# ip default-gateway 200.0.0.1

3.2 Configuration du switch_B
Adhésion au domaine cisco
Switch_B# vlan database
Switch_B(vlan)# vtp domain cisco
Switch_B(vlan)# vtp client
Switch_B(vlan)# exit
Création du trunk
Switch_B(config)# interface fastEthernet 0/1
Switch_B(config-if)# switchport mode trunk
Switch_B(config-if)# switchport trunk encapsulation dot1q
Switch_B(config-if)# exit
Attribution des VLANs aux ports
Switch_B(config)# interface fastEthernet 0/2
Switch_B(config-if)# switchport mode access
Switch_B(config-if)# switchport access vlan 2
Switch_B(config-if)# exit
Switch_B(config)# interface fastEthernet 0/3
Switch_B(config-if)# switchport mode access
Switch_B(config-if)# switchport access vlan 3
Switch_B(config-if)# exit
Switch_B(config)# interface fastEthernet 0/4
Switch_B(config-if)# switchport mode access
Switch_B(config-if)# switchport access vlan 4
Switch_B(config-if)# exit
Définition de la passerelle par défaut
Switch_B# ip default-gateway 200.0.0.1






3.3 Configuration du Routeur R1
R1(config)# interface fastEthernet 0/0
R1(config-if)# ip address 200.0.0.1
R1(config-if)# exit

R1(config)# interface fastEthernet 0/0.2
R1(config-sub)# encapsulation dot1q
R1(config-sub)# ip address 10.0.0.1
R1(config-sub)# exit

R1(config)# interface fastEthernet 0/0.3
R1(config-sub)# encapsulation dot1q
R1(config-sub)# ip address 172.16.0.1
R1(config-sub)# exit

R1(config)# interface fastEthernet 0/0.4
R1(config-sub)# encapsulation dot1q
R1(config-sub)# ip address 192.168.0.1
R1(config-sub)# exit

Conclusion
Vous avez pu voir que pour réaliser un routage entre VLANs, il ne suffit pas de brancher un routeur sur un commutateur... Bien que la configuration paraisse longue, 15 min seront assez pour l'exécuter.
En espérant que cet article vous aura été utile.
69
Nico le Vosgien Messages postés 1551 Date d'inscription vendredi 23 février 2007 Statut Contributeur Dernière intervention 19 novembre 2016 263
13 déc. 2010 à 13:28
Quel intérêt de déterrer un post vieux de 2 ans pour y coller ce pavé ?

Qui plus est :

"Le VLAN Trunking Protocol (VTP) est nécessaire si l'on veut étendre une configuration de VLAN sur plusieurs commutateurs"

VTP n'est absolument pas nécessaire : il a un interêt certain selon l'architecture dans laquelle on se trouve et/ou le nombre de vlan utilisés mais ce n'est pas un prérequis.
0
merci salim
0
Ca sert à ce que des gens qui tombent dessus par hasard, sont quand même aidé
0
Nico le Vosgien Messages postés 1551 Date d'inscription vendredi 23 février 2007 Statut Contributeur Dernière intervention 19 novembre 2016 263
17 févr. 2011 à 15:15
Et tu as lu l'ensemble des réponses données ? le lien donné par bob (2007 hein !!) semble déjà répondre à la question ... mais bon ....
0
Coucou, il te manque juste un pti truc.. j'pense.. :

R1(config-sub)# encapsulation dot1q <id-Vlan>
id-vlan : N° du Vlan a laquel cette interface corespond.. ;-)
0
Ya mieux avec les liens suivants:
http://www.adm4net.com/adm4net/matactif/cisco/vlan.php
et
http://www.adm4net.com/adm4net/matactif/cisco/vtp.php

a+
8
kelux Messages postés 3056 Date d'inscription vendredi 18 juin 2004 Statut Contributeur Dernière intervention 22 septembre 2022 429
8 avril 2006 à 19:59
Salut ,


tu as tout ce qu'il te faut ici :

http://www.labo-cisco.com/ArticleComp.asp?ARID=58

C'est la base ;)

@+
3
zizou99 Messages postés 7 Date d'inscription lundi 22 octobre 2007 Statut Membre Dernière intervention 4 mars 2008 5
17 déc. 2007 à 15:52
bonjour les ami(e)s
voila je suis sur un projet de création de VLANs dans ma société alors svp si vous pouvez au moins m'aider pour élaborer un schéma de depart .on a un immeuble de 4 étages des switchs 2950 et d'autrs 3500 .on veut separer chaque direction de sorte que dans chaque favoris réseau de chaque direction il ne verront que les utilisateurs de cette direction et leqs autres n'apparaitront pas.
merci à l'avance
1
docter Cisco
14 avril 2014 à 16:46
Mr BAM
si vous voulez creer des VLANs pour s'eparer les directions
http://www.youtube.com/watch?v=GFCDwLEedCA
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
salut je suis aussi en btsig arle pourrez tu m'envoyé une copie de ton rapport de stage
1
Bonjour,

J'ai une etude a rendre sur les 2950 et je veux en acheter un pour moi.

Quelqu'un connait une adresse ou on peut en acheter d'occasion?

J'ai trouvé ce site qui en vend, mais je n'ai pas testé, vous en pensez quoi?

http://www.predictive-solutions.eu
0
docter Cisco
14 avril 2014 à 16:44
http://www.youtube.com/watch?v=GFCDwLEedCA
voila comment configurer les vlans sous switch
NB:2 vlan differentes ne peut pas communiquer entre eux sauf que vous ajoutez un routeur.
bon travaille
0