Apache ne se lance pas !!! [Résolu/Fermé]

Signaler
Messages postés
13
Date d'inscription
samedi 4 février 2006
Statut
Membre
Dernière intervention
11 juillet 2006
-
 nabil -
j'ai installer easyphp 1.8 et apache ne veut pas se lancer, j'ai toujours le message d'erreur : " le serveur n'a pas pu se lancer : un autre serveur utilise le port requis ou le port est bloqué par un parefeu ", j'ai un antivirus Avast et non un pare feu, et avec easyphp 1.6 l'apache fonctionne normalement!!!!!!

22 réponses

en effet ta solution fonctionne pour moi!
(éteindre skype fonctionne aussi, mais j'ai pas envie de toucher à skype).

Pourquoi ça fonctionne comme ça?
Car EasyPHP ne teste du coup PAS si les ports sont occupés.

Donc la solution PLUS SIMPLE est:
_______________________________________________________________
* Configuration>EasyPHP (ou Ctrl+E)
* Décochez "Vérifier que les ports ne sont pas occupés par d'autres serveurs"
_______________________________________________________________

Et pour moi ça fonctionne! ;)
29
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

le prob d'apache a été résolu mais il reste celui de mysql
salut Joora,
j'avais le même problème mais ta solution m'a aidé

merci
salut joora ta solution m'a aidé merci bien!

tu es mon héro ... tu viens de changer ma vie :') !
Ouverture du fichier httpd.conf d'apache (Fonction Recherche de fichiers si besoin)
Puis édition (avec le bloc-notes), recherche du mot 'Listen'
Sur la même ligne, écrire 8080 (ou un autre chiffre) à la place de 80.

Lancer Apache.
Se connecter sur http://127.0.0.1:8080

-----
Et accessoirement, si nécessaire, identifier le programme qui utilise déjà le port 80 et voir s'il est possible de libérer l'utilisation de ce port, et remettre 80 dans httpd.conf (et relancer Apache)
supeeeeeeeeeeeeeeeeeer ca march merci bcp A.Nonymous
tranquille ça fonctionne
J'avais ce problème et j'ai trouvé la solution me concernant.

Il fallait simplement installer "Microsoft Visual C++ 2008 SP1 Redistributable Package" (http://www.microsoft.com/download/en/details.aspx?id=5582)

Pour les x64 voila le lien (https://www.microsoft.com/en-us/download/details.aspx?id=15336

Apres avoir installé ce package ca fonctionne parfaitement !!!
Merci a toi
(lien mort petite recherche google et voila)
Merci beaucoup! Super efficace!!
Petite astuce pour continuer à utiliser Skype et Apache sans que cela pose de problème,
Dans Skype:
Aller dans Outils/Options/Avancées/Connexion/ puis décocher la case "Utiliser les ports 80 et 443 comme alternative"
voili voilou !!

Salutaitons. Arguûl.
comment je peux aller par la, pouvez m'indiquer la ou je peux passer ?Outils/Options/Avancées/Connexion/ puis décocher la case
J'ai le même problème, mais avec EasyPHP 3.0 sous Windows Vista.

A savoir qu'au début tout fonctionnait sans aucun problème (du moins avec EasyPHP 2.0b1), puis d'un seul coup, Apache a refusé de se lancer. Il me semble que ce fut juste après l'installation d'un programme ou d'une mise à jour de Windows... quel programme, quelle mise à jour ? Je n'en sais strictement rien.

J'ai donc installer la dernière version d'EasyPHP, la 3.0, mais le problème persiste.
J'ai changé le port à la ligne "Listen", mais apparement, selon Apache lui-meme (ou EasyPHP), la ligne PORT n'existe plus. Bref, quoiqu'il en soit, peu importe le port que je met, aucun ne fonctionne.

J'ai voulu tester un truc à tout hasard... j'ai double-cliqué sur apache.exe pour voir ce que ça faisait. ça ouvre une fenetre semblable à DOS où à celle qu'on à en lancer CMD, avec un curseur qui cligonte. J'ai abaissé la fenêtre puis lancé EasyPHP, vu qu'apprement Apache ne m'a parler d'aucune erreur... Et Oh miracle, EasyPHP ce lance, indique bien que tous les servers sont connecté, et je peux aller dans Web Local ou Administration sans probleme. Et je peux meme parcourrir ma base de donnée...

Donc voila, si je laisse EasyPHP (2.0b1 ou 3.0) tout lancer lui-même, ça plante pour apache.exe, mais si je lance d'abord apache.exe puis ensuite EasyPHP, tout fonctionne...

Ce n'est pas pratique, mais au moins ça fonctionne.
Si quelqu'un a une idée d'où peut provenir ce problème...

vraiment merci de bien de votre idée...j'été en grand problem
sous easyPHP 5.3.3.1 clic droit / configuration / cocher démarrer en tant que service et decocher verifier les ports.
executer services.msc et mettre apache et mysql en manuel.
moi je trouve plus simple ça vue que AGV ne me répond pas pour que le port 80 reste valide.

j'ai changé le premier paramètre avec un autre numéro...120, 112 215, 90....et même numéro au 2ème,

et ça cohabite bien avec IE7 et maintemant IE8.., mettre par contre en "conformité avec ie7",
c'est mieux semble t il.

on me propose xampp....pour d'autre template qui tourne sur Mysql

Bye
bonjour à tous,

voila une solution qui peut être la meilleur : force le démarrage de easyphp en même temps que de windows

1- configuration --> EasyPhp
2- cochez : Démarrer easyphp en même temps que windows

et ça marchera, normallement, car pour mos ça marche trés bien

bonne courage
Messages postés
908
Date d'inscription
lundi 18 avril 2005
Statut
Membre
Dernière intervention
3 août 2008
501
Salut,
Je connais pas le contexte EasyPhp, mais il semberait qu'un serveur Web soit
dèja en activité : as-tu bien arrèté le apache de EasyPhp 1.6 avant d'essayer
de lancer celui du 1.8 ?
Il faut faire certainement pareil avec le serveur MySQL.
A+, crabs
Messages postés
13
Date d'inscription
samedi 4 février 2006
Statut
Membre
Dernière intervention
11 juillet 2006

non pas de tout le serveur apache n'est pas actif !!!!
Bonjour,
Moi aussi j'ai le même probleme..
Je ne sais vraiment pas koi faire.
Prière de me répondre moi aussi sur cela..
MSN: amigo.84@hotmail.com
Salut
J'ai deja eu ce probleme. Deja desinstall la 1.6 et si tu as un logiciel tel que skype il utilise les memes ports. J'ai eu ce probleme avec skype une fois desinstallé plus de souci donc regarde bien dans tes services. Ou si tu as un serveur IIS
voili voilou bon courage
Oui c'était Skype le problème pour moi..je l'ai juste arrêté et Apache a pu démarrer :D?
idem pour moi mais c Panda Titanium Antivirus 2005 qui oqp le port.
y'a juste a le stopper et apres c ready!
slt
j ai un pb similaire sur easyphp c est le serveur msql qui ne demarre pas il dit que le port et occupé.j ai egalemnet installé sql server sur mon pc le pb vient d la ou pas?
j attends votre reponse merci
Messages postés
5205
Date d'inscription
samedi 20 janvier 2007
Statut
Contributeur
Dernière intervention
19 avril 2020
1 336
nils
oui il y as de tres forte chances que cela vienne de la !!
bonjour, j'ai le même problème mais je ne dispose pas de skype, donc je sais pas comment modifier les ports

de l'aide svp !!
slt j'ai le méme bléme sur ma machine et je n'aipas skype et le service IIS est désinstallé. J'ai beau cherché mais je ne trouve pas de solution
j'ai trouver la solution moi j'aivai le meme prblm et j'ai desactiver l'antivirus kaspersky et j'ai relancer easyphp et il marche correctement.
J'ai le même problème et j'ai pas de skype sur ma machine, par contre j'ai l'antivirus AVG édition Réseau qui est installer.
ma machine eberge AVG Admin Serveur. J'ai fait les modif dans le fichier "C:\Program Files\EasyPHP1-8\apache\conf\httpd.conf" en remplaçant le port 80 par 8080 mais tjrs la même salade.
merci pour votre aide.
Messages postés
2
Date d'inscription
jeudi 18 décembre 2008
Statut
Membre
Dernière intervention
20 novembre 2014

attention, dans le fichier de configuration de apache, il y a 2 lignes à modifier...Listen.. et un peu plus bas PORT .

mais moi aussi j'ai dû changer de port...avec AVG internet security, et Skype option décoché...çà marche pas, il faut impérativement changer de port...le 80 bug...

j'ai envoyé un post chez AVG technique, je vous ferais part de la solution si elle fonctionne.

Bye