[Ubuntu] Modifier AZERTY en QWERTZ

Résolu/Fermé
minux2
Messages postés
17
Date d'inscription
mardi 10 septembre 2002
Statut
Membre
Dernière intervention
19 octobre 2006
- 19 févr. 2006 à 20:05
Marcellus48
Messages postés
8
Date d'inscription
vendredi 19 juin 2015
Statut
Membre
Dernière intervention
20 juin 2015
- 20 juin 2015 à 19:40
Bonjour,

J'ai installé Ubuntu sur mon pc. Malheureusement, le clavier est configuré en AZERTY (et moi j'ai un QWERTZ), j'ai beau changer dans le menu "système>préférence>clavier" et de mettre par défaut un clavier suisse romand (Switzerland French, Sun dead keys) mais ca n'as aucun effet sur mon clavier. Celui-ci continue de réagir en AZERTY (meme après multiples démarrages).

Avez vous une solution ? merci d'avance
A voir également:

17 réponses

Je viens de trouver : pour passer le clavier devenu anglais sous ubuntu 7.1, il suffit de faire :

Systeme / Preferences / Clavier puis choisir "Agencement".

En bas - a gauche de la fenetre, cliquer sur " + Ajouter "

En haut, cliquer dans "Agencements" et choisir " France " et laisser en dessous "par defaut"...

Cliquer sur " + Ajouter " puis fermer la fenetre ..... Le tour est joue.....
31
Merci beaucoup pour votre message. Il m'a été très utile. Je suis nouvellement convertie à Ubuntu et j'ai encore plus envie de continuer à utiliser ce système vraiment efficace !

Karine
0
Moi aussi, ca m'a vraiment servi

Mercccccccccciiiii
0
Et encore merci: toujours d'actualité le truc !
0
tu es le patron merci
0
merci
0
mamiemando
Messages postés
31312
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
12 août 2022
7 398
19 févr. 2006 à 20:50
Ouvre une console et tape :
su -

Tape ton mot de passe root
loadkeys us

Pour revenir à un clavier français :
loadkeys fr


Bonne chance
14
J'ai egalement le meme probleme, je viens de tester les commandes et j'ai toujours mon clavier en QWERTY au lieu de QWERTZ.

Apparemment, il y a un bug :
https://launchpad.net/ubuntu/+source/xfree86/+bug/8836

D'autres idees ?

Merci
Yann
0
Du génie, merci :)
0
cimer
0
bonsoir

moi j'ai résolu mon choix de clavier au boot en modifiant le paramètre dans le fichier xorg.conf qui se situe
dans /etc/X11/ en remplaçant dans la section keyboard l'option "us" par "fr"
et là j'ai eu mon clavier français ua boot

netement plus pratique pour taper mon mon de passe surtout avec les m ou le a

bon courage
2
Tu ferais bien d'aller jeter un coup d'oeil et tu ne te poseras plus de questions...

http://forum.ubuntu-fr.org/viewtopic.php?id=155124
2

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
mamiemando
Messages postés
31312
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
12 août 2022
7 398
24 avril 2007 à 19:02
Tu utilises quoi KDE gnome ou autre chose ?

Si c'est gnome :
http://www.trustonme.net/didactels/67.html

Configuration de Gnome

Gnome dispose d'un outil central de configuration, qui vous permet de configurer, votre clavier, votre souris, vos thèmes ... Vous pouvez le lancer de 2 manières, la plus intuitive : start here -> Desktop Preferences ou l'autre équivalente : Applications -> Desktop Preferences.
1
lami20j
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 566
17 nov. 2007 à 15:11
Salut,

si tu as un XP
On est dans le Forum Linux ;-))
Pas besoin de XP ;-)
1
Bonjour, moi j'ai trouvé,
il faut appuyer sur la flèche au dessus de ctrl et sur le alt le plus proche,
sur le mien ça marche j'espère pour vous aussi^^
au revoir
1
merci mais sa ca marche sous windows
0
merci,j'ai fais comme tu as dis et le miracle s'accomplie!
0
lami20j
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 566
27 mai 2006 à 09:13
Salut,

J'ai egalement le meme probleme, je viens de tester les commandes et j'ai toujours mon clavier en QWERTY au lieu de QWERTZ.

C'est normal, puisque mamiemando t'as donné la commande loadkeys us (clavier americain -> QWERTY, est ça fonctionne donc pas de bug)

Pour configurer ton clavier tu peux faire :

1. loadkeys sg

ou

2. dpkg-reconfigure console-data

lami20j
0
mamiemando
Messages postés
31312
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
12 août 2022
7 398
30 mai 2006 à 19:44
us = clavier us (qwerty)
fr = clavier francais (azerty)

Etonnant non ? ;)
0
jon-1800
Messages postés
15
Date d'inscription
lundi 23 avril 2007
Statut
Membre
Dernière intervention
21 mars 2010
1
23 avril 2007 à 20:36
je n 'ai pas compri comment mettre son clavier azerty en clavier qwertz???????????Expliquer en francais pas en informatique dsl je suis novice....
0
Marcellus48
Messages postés
8
Date d'inscription
vendredi 19 juin 2015
Statut
Membre
Dernière intervention
20 juin 2015

20 juin 2015 à 19:40
Pour linux ubuntu

Si cela vous arrive tapez sur les touches en même temps......

Shift + touche super ( a gauche entre CTRL et ALT) + barre espacement
Et ça redevient QWERTZ.
Amitiés à tous
Marcellus48
0
au demarrage tu n a pas le choix du clavier. Sur simplymepis (debian) j ai ce choix.
0
mamiemando
Messages postés
31312
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
12 août 2022
7 398
24 avril 2007 à 00:51
Ton clavier est en qwerty en mode graphique (le mode où il y a des fenêtres) ou en mode texte ? Si c'est en mode graphique ça se corrige au niveau du "panneau de configuration" de ton window manager (par exemple le centre de contrôle KDE pour KDE).

Bonne chance
0
dsl j ai tjs pas capter faut aller sur panneau de configuration pis après????
0
Bonjour,

si tu as un XP (je c'est pas si sur les autres ordinateurs ça marche), pour passer de AZERTY au QWERTZ tu fais Alt+la touche qui ce trouve en dessus de Majuscule. Et pour revenir en AZERTY tu fais pareil
0
merci françois ça a marché pour moi tks a lot
0
vlar
Messages postés
2281
Date d'inscription
vendredi 17 août 2007
Statut
Membre
Dernière intervention
29 novembre 2013
623
12 avril 2008 à 22:16
+1 Chrislab
tu mas fais gagner un temps fou
Merci
0
steflinux
Messages postés
6
Date d'inscription
lundi 27 septembre 2010
Statut
Membre
Dernière intervention
9 novembre 2010

27 sept. 2010 à 19:18
D'autres pistes et commandes : dumpkeys (va de pair avec loadkeys)

... et attention aux mappings supplémentaires sous X (cf. xmodmap, Xkbcomp, ...)

Et surtout bien penser à sauvegarder sa configuration lorsque le résultat est atteint...
0
Toniioo
Messages postés
8
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
14 août 2012
4
7 déc. 2010 à 10:47
Merci Chrislab !
0
Pour ne pas trop compliquer,
Faut aller dans Systems all settings
puis
Keyboard layout
puis
il y a un petit plus (symbole en bas de la phenetre à gauche)
clicker dessus
puis ajouter le clavier francais
puis supprimer l'us
pour aller de qwerty vers azerty

ou le cotraire pour aller de azerty à qwerty c à d enlever le fr et ajouter le us

en tout les cas on a une vision enfin une possibilité de visualiser le clavier résultat

see you,
A plus
0