Inserer une formule dans une cellule VBA [Résolu/Fermé]

Signaler
-
 Han onyme -
Bonjour,

j'essayes de mettre une formule dans une cellule excel quand je le fais sans variable elle fonctionne super bien mais des que j'insère ma variable arrêt j'ai une erreur une idée dessus ??
Merci d'avance

Code:

fonctionnel

Sheets("Test").Range("K43").FormulaLocal = "=SOMME.SI(VQS!G8:G19 ;I43;VQS!F8:F19)"

Erreur
arret = 19
Sheets("Test").Range("K43").FormulaLocal = "=SOMME.SI(VQS!G8:G & arret ;I43;VQS!F8:F & arret)"

4 réponses

Messages postés
274
Date d'inscription
mardi 23 novembre 2010
Statut
Membre
Dernière intervention
23 avril 2011
87
"=SOMME.SI(VQS!G8:G & arret ;I43;VQS!F8:F" & arret & ")"
manqué 2 guillemets
Yes j'ai trouvé voila la solution pour une autre persoone qui la voudrais

arret = Sheets("vtest").Range("E3") - 1
variable_1 = "VQS!G8:G" & arret & ";"
variable_2 = "VQS!F8:F" & arret

Sheets("Test").Range("K43").FormulaLocal = "=SOMME.SI(" + CStr(variable_1) + "I43;" + CStr(variable_2) + ")"
Messages postés
274
Date d'inscription
mardi 23 novembre 2010
Statut
Membre
Dernière intervention
23 avril 2011
87
ouai tu a réécris le truc avec des +, mais il te manuait quand meme que les guillemets
>>"=SOMME.SI(VQS!G8:G" + arret + ";I43;VQS!F8:F" & arret & ")"
manqué 4 guillemets
Messages postés
14
Date d'inscription
jeudi 19 février 2015
Statut
Membre
Dernière intervention
25 février 2015

Bonjour ,
je veux inserer une formule simple dans une cellule de ma page excel:
la formule est =SOMME(C27;c76)*N$2
que je dois inserrer dans la cellule B9

voici le code que j'ai mis mais ca ne me donne rien
Range("B" & 9).Formula = "=SOMME(""B""&29;""B""&76)*N$2"
Bonjour,

Soit tu veux que ta fomule s'adapte, (qu'elle utilise les valeurs en B):
Range("B9").Formula = "=SOMME(B29;B76)*N$2"

Soit tu veux que ta formule reste avec les valeurs en C:
Range("B9").Formula = "=SOMME(C29;C76)*N$2"