Excel/date calendrier / [Résolu/Fermé]

Signaler
Messages postés
738
Date d'inscription
samedi 22 mars 2008
Statut
Membre
Dernière intervention
4 janvier 2015
-
Messages postés
738
Date d'inscription
samedi 22 mars 2008
Statut
Membre
Dernière intervention
4 janvier 2015
-
Bonjour à tous et ttes,

j'ai une tite question. si je palce en a1 la premier jour du mois et que je veux que à partir de la cellule b1 s'inscrive les jours du mois jusq'au dernier jour, j'écrie en b1 =A1+1 et je tire la formule...

mais si je veux faire en sorte que cela n'aille pas plus loin que le dernier jour du mois comment dois-je faire...

exemple si en a1 j'ai la date du 01/01/2010 et b2 je vais avoir 02/01/2010, en c1 le 03/01/2010...etc..jusqu'a la cellule ae1 ou va se retrouver la date du 31/01/2010.
maintenant si je tape le 01/02/2010, je vais avoir en ac1, ad1 et ae1 les trois permiers jours du mois suivant.

comment puis-je faire pour éviter cela et donc n'avoir que les date du mois sélectionné en a1 ?

merci de me donner votre avis et vos idées.

bien à vous.


berni...le roi des ennuis... :-)



7 réponses

Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 397
bonjour à tous,

Avec ceci tu devrais avoir ce que tu cherches :

=SI(A1="";"";SI(MOIS(A1+1)<>MOIS(A1);"";A1+1))

Il faut utiliser deux Si car sinon tu as une erreur sur la fonction MOIS de la date vide

Toujours zen
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
8535
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
9 avril 2021
1 647
Bonjour,

Avec un seul SI :
=SI(MOIS($A1)=MOIS($A1+COLONNE()-1);$A1+COLONNE()-1;"")
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
25953
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
10 avril 2021
5 866
Re re
EN B1 à faire suivre =SI(MOIS(A1+1)>MOIS(A1);"";A1+1)
ou à partir du 28° jour , ça suffit
mais ne marche pas en Décembre (on passe de 12 à1!)

Pour couvrir Décembre, on peut compléter avec:
=SI(ET(MOIS(A1)=12;MOIS(A1)+1=1);"";A1+1)
ce qui donne au total:
=SI(ET(MOIS(A1)=12;MOIS(A1)+1=1);"";SI(MOIS(A1)+1>MOIS(A1);"";A1+1))
Crdlmnt


Messages postés
53610
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
12 avril 2021
15 654
Simplissime ! Taper 01/01/2010 en A1, tirer vers la droite avec la poignée.
Le reste se fait tout seul, et sans erreur (y compris pour les années bissextiles !).
Messages postés
53610
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
12 avril 2021
15 654
J'avais lu incomplètement ton message "... jusqu'a la cellule ae1 ou va se retrouver la date du 31/01/2010. maintenant si je tape le 01/02/2010, je vais avoir ..."

Pourquoi taper 01/02/2010 ? Il te suffit de continuer à tirer ta formule !

Du coup, tu as induit mon ami Vaucluse en erreur, qui s'est lancé dans des formules compliquées ...

Salutations à tous les deux.
Messages postés
25953
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
10 avril 2021
5 866
Bonsoir mon ami Raymond
Pour ma part, je n'ai pas compris tout à fait ça, mais on attendra la confirmation de Benji
je crois que ce qu'il veut, c'est avoir les formules sur la ligne 1 qui affiche automatiquement les dates du mois lorsque l'on rentre le premier jour en 1° cellule.
Ce qui expliquerait que au delà de la fin du mois de 28 ou 30 jours, c'est le mois suivant qui s'affiche dans les cellules restantes.
Le but et sans doute d'avoir un tableau à formules fixes pour ces titres,dans lequel il ne change que la 1°date
Crdlmnt
Messages postés
53610
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
12 avril 2021
15 654
Oui, tu as tout à fait raison ; j'avais mal compris sa problématique.
Ce sont donc tes formules qui conviennent ...

Très amicalement.
Messages postés
738
Date d'inscription
samedi 22 mars 2008
Statut
Membre
Dernière intervention
4 janvier 2015
25
bonsoir le vaucluse et raymond,

voici le fichier...j'ai seulement changé le sens dans laquelle les dates doivent venir mais pour le reste ....c'est presque bon...

en fait si je mets en a1 le premier jour d'un mois, je souhaiterais que le restant des jours viennent automatiquement s'inscrire jusqu'au dernier jour du mois repris en a1..Mais le problème est que nous n'avons pas tjrs des mois de 31 jours...

j'ai donc indiqué la formule proposé par vaucluse mais si j'introduit kle mois de février les trois derniers jours indique #valeur...comment puis je remédier à ce problème ?

j'ai pas bien compris pour l'opération à faire pour décembre...je peux, sans abuser, te dder de me montrer un exemple sur le fichier..merci à toi...

voici le fichier : http://www.cijoint.fr/cjlink.php?file=cj201011/cijyidlCeN.xls


merci à vous..

berni...et ses tits misères... :-)
Messages postés
25953
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
10 avril 2021
5 866
Effectivement, il, manquait la pris en compte de la première cellule vide de la rangée. Voir les deux propositions de Patrice et Gbinform remontées en début de fil
Crdlmnt
Messages postés
738
Date d'inscription
samedi 22 mars 2008
Statut
Membre
Dernière intervention
4 janvier 2015
25
Bonjour à tous,

merci à vaucluse, gbinforme et patrice pour leurs éclairages...et vos précieux conseils.

bien à vous .

berni///