Ne pas afficher #DIV!0 sur une plage de cellu

[Fermé]
Signaler
-
Messages postés
26122
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
30 juillet 2021
-
Bonjour,


Je voudrais ne pas afficher le DIV sur toute une plage de cellule. Je n'arrive pas à appliquer ma mise en forme conditionnelle à toute cette plage de cellules.

Pouvez-vous m'aider ?

2 réponses

Messages postés
26122
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
30 juillet 2021
5 999
Bonjour
ce n'est pas la MFC qui résoudra le problème;
Si votre cellule affiche #DIV0, c'est que le diviseur dans la formule est égal à 0.
Faites précéder votre formule d'une condition:
=SI(diviseur=0;0;formule)
diviseur étant soit:
_l'adresse de la cellule où il se trouve
_la formule qui permet de le calculer
Vous pouvez aussi remplacer le ;0; suivant par ;""; pour n'avoir aucun affichage dans la cellule, mais au risque de perturber les formules qui pourraient s'appuyer dessus;

Crdlmnt

Demandons nous si nous ne sommes pas seuls à comprendre ce que l'on explique?

Bonsoir,
C'est vrai. J'ajoute juste que c'est mieux (rassurant) de voir qu'une division par rien s'effectue mais certe pas esthétique à l'impression...sauf si la MFC prévoit qu'en pareil cas alors la police est de couleur blanche...sur papier blanc, "invisible" à l'écran autant.
Messages postés
26122
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
30 juillet 2021
5 999
Avec une MFC en couleur police/couleur cellule effectivement, ça disparaît, mais on perd aussi la faculté de se rassurer avec l'affichage :-)
une autre option, écrire un code "propre" entre les guillemets de la condition dans la formule qui signalera plus proprement le défaut, un underscore par exemple.
crdlmnt