[Excel] référence à une autre feuille [Résolu/Fermé]

Signaler
Messages postés
5
Date d'inscription
mardi 22 décembre 2009
Statut
Membre
Dernière intervention
22 décembre 2009
-
 pickatshou -
Bonjour,

j'ai crée dans une cellule une référence vers une autre feuille calcul:

exemple: A1= SOMME(Toto!A1:A10) Toto étant le nom de la feuille auquelle je fais référence

maintenant, je voudrai remplacer dans ma formule le nom Toto par une référence vers une cellule de la feuille active qui contiendrai le nom Toto.

je ne sais pas si je suis clair ...

est-ce possible ?

merci de votre aide
A voir également:

11 réponses

Messages postés
5
Date d'inscription
mardi 22 décembre 2009
Statut
Membre
Dernière intervention
22 décembre 2009
12
Yes, c'est exactement ce que j'essaie d'expliquer ... de façon alambiquer ...
11
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
23988
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
7 avril 2021
6 717
Bonsoir,

=SOMME(INDIRECT(A1&"!C1:C10"))

eric
Dommage cette methode n'accepte pas ces symbole dans le nom feuille: "-" "=" "+"
Messages postés
6285
Date d'inscription
lundi 28 janvier 2008
Statut
Membre
Dernière intervention
29 avril 2020
1 304
Bon je narrive pas à créer ce que tu demandes (peut-être quelquun y arrivera).

Combien as-tu de feuilles (car s'il y'en a peu, une fonction si peut tout arranger)?
Messages postés
416
Date d'inscription
vendredi 26 juin 2009
Statut
Membre
Dernière intervention
17 octobre 2011
44
Pas de problème cliques juste sur la cellule auquel tu souhaites faire référence
Messages postés
29
Date d'inscription
jeudi 10 juillet 2008
Statut
Membre
Dernière intervention
9 juin 2010
2
En laissant les deux page ouverte tu clic sur la cellule de reference et Excel fait le reste, du type:
='C:\Users\XXX\Desktop\[Nom_fichier.xlsx]Feuil1'!$N$17
Messages postés
416
Date d'inscription
vendredi 26 juin 2009
Statut
Membre
Dernière intervention
17 octobre 2011
44
Pas de problème cliques juste sur la cellule auquel tu souhaites faire référence
Messages postés
23988
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
7 avril 2021
6 717
Ok, n'oublie pas de mettre en résolu alors
Messages postés
5
Date d'inscription
mardi 22 décembre 2009
Statut
Membre
Dernière intervention
22 décembre 2009
12
merci mais je crois que j'ai pas été clair.

donc je reprends:

sur ma feuille excel j'ai la colonne A qui reprend tous les noms de feuilles de mon fichier excel.

dans ma colonne B je veux créer une référence vers la feuille dont le nom a été saisi dans la colonne A et sur la ligne correspondante

exemple:

______[colonne A]________[colonne B]

1 ______[Toto]___________[=somme( feuille(A1)!C1:C10)]
2 ______[Titi]____________[=somme( feuille(A2)!D12:D15)]
3 ______[Riri]____________[=somme( feuille(A3)!E1:E5)]

la fonction feuille() n'existe bien sur pas, mais j'aimerai trouver un équivalent...

encore merci
Messages postés
6285
Date d'inscription
lundi 28 janvier 2008
Statut
Membre
Dernière intervention
29 avril 2020
1 304
En gros tu as des noms en A qui changent (et qui correspondent aux noms de tes autres feuilles) et tu désires qu'en B tu aies la formule suivante:

=somme("Nom en a"!C1:C10)


Est-ce ça que tu essayes d'expliquer?
Messages postés
5
Date d'inscription
mardi 22 décembre 2009
Statut
Membre
Dernière intervention
22 décembre 2009
12
j'ai 14 feuilles, çà fait un peu beaucoup pour être géré avec la fonction si
Messages postés
5
Date d'inscription
mardi 22 décembre 2009
Statut
Membre
Dernière intervention
22 décembre 2009
12
C'est exactement ce que je voulais.

Merci