Référence de cellule variable formule excel

[Fermé]
Signaler
-
 liloudenice -
Bonjour,

Je souhaiterai compter le nombre de valeur dans une plage.

J'utilise donc une formule nb.val(x;A1:B5) par exemple.

Mais au lieu d'avoir A1:B5, je souhaiterai pouvoir lire ces valeurs dans 2 cellules car la plage va varier. Je peux afficher les réferences (A1 et B5 dans cet exemple) dans 2 cellules, mais je ne sais pas comment les intégrer à ma formule.

C'est ma première question sur ce forum, si vous avez besoin de plus de précision, n'hésitez pas.

Merci à tous ceux qui se pencheront sur mon problème.


A voir également:

4 réponses

Messages postés
26239
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 octobre 2021
6 090
Bonjour
essayez dans votre formule:
=NBVAL(INDIRECT(Cell1&":"&Cell2))
Celle 1 et Celle 2 étant bien sur les cellules ou se trouve vos références.
crdlmnt
Re-bonjour,
Je me suis trompé sur un petit point. J'utilise NB.SI et pas NBVAL...
Messages postés
26239
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 octobre 2021
6 090
Ça ne change rien à ma proposition un message plus bas, le champ est à traduire par:
=NB.SI(INDIRECT(Cell 1&":"&Cell 2);Valeur à compter)
Crdlmnt
Ca marche!!
Merci beaucoup