EXCEL : multiplier un nombre par des heures [Résolu/Fermé]

Signaler
-
 Mohsen -
Bonjour,

Quelqu'un peut il m'aider dans la multiplication d'un nombre par des heures
exemple:

en A1 j'ai le chiffre 2
en B1 j'ai 2:10 (format heure [hh]:mm)
et en C1 je souhaiterai obtenir le resultat en heure de la multiplication de A1 par B1 sachant que la valeur de A1 peut etre variable et que la valeur de B1 est toujours fixe.

merci de votre aide.

9 réponses

Messages postés
331
Date d'inscription
samedi 16 avril 2005
Statut
Membre
Dernière intervention
14 juin 2007
50
pour faire des opérations sur des heures, il fait les transformer en centieme d'heure (ch)..
100ch = 60mn
1ch = 0,6mn

conversion minute > ch

30mn = 30/0,6 = 50ch
42mn = 42/0,6 = 70ch
60mn = 60/0,6 = 100ch



1er exemple (2h30 x 3)

convertir 2h30 en ch
= 2h + 30mn = 200 + (30/0,6) = 250ch

opération:
250 x 3 = 750

convertir 750 en heure minute
>> 700ch = 7h
>> 50ch = 50 x 0,6 = 30mn

résultat:
2h30 x 3 = 7h30mn




2ieme exemple (3h45 x 3)

convertir 3h45 en ch
= 3h + 45mn = 300 + (45/0,6) = 375ch

opération:
375 x 3 = 1125

convertir 1125 en heure minute
>> 1100ch = 11h
>> 25ch = 25 x 0,6 = 15mn

résultat:
3h45 x 3 = 11h15mn


a toi d'optimiser cela avec des formules dans excel
12
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65104 internautes nous ont dit merci ce mois-ci

bonsoir,

je dois effectuer un dépouillement de questionnaire sur excel. je voudrais multiplier un nombre par un mot. Pour être plus précise je souhaite savoir combien de personne ont répondu oui et combien de personne ont répondu non pour une meme question.merci pour ceux qui voudront m'aider
1-Créer une colonne par exemble la C avec le chiffre 1 dans toutes les cellules (inscrire 1 dans une cellule puis copier/selectionner la colonne C/coller)

Mettre toutes les réponses aux même format OUI/NON dans la colonne B (Ce qui laisse une marge en A si besoin sinon direct en A en modifiant les formules en dessous)
Attention si les réponses OUI/NON ne sont pas en majuscule ça ne les comptera pas ou alors il faut modifer le critère entre guillemets de la formule.

En D1 indiquer OUI
En D2 reprendre la formule : =SOMME.SI(B:B;"OUI";C:C)
En E1 indiquer NON
En E2 reprendre la formule : =SOMME.SI(B:B;"NON";C:C)

Voilà.
Messages postés
17128
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
2 juillet 2020
4 113
Salut,

Pour avoir des réponses, vous devriez ouvrir votre propre discution et ne pas en reprendre une dont le statut est résolu.

Mais en reprenant l'exemple de Marco, en

A1 la durée exemple 1:30
en A2 une somme monétaire exemple 5,20 €

en A3 mettre la cellule au format monétaire et la formule est

=A2*((A1-TRONQUE(A1))*24)

A+


__________________________________________________________________

Besoin d’aide. Auprès du forum, des bénévoles prennent le temps de décrypter vos explications parfois confuses, et proposent leur connaissance.
Solution trouvée, ayez la courtoisie de porter votre statut résolu. Afin que votre problème soit classé, et serve de référence pour d’autres cas similaires.
IMPEC; ça marche
Bravo et merci. Réponse simple et efficace.
Merci beaucoup
c est génial
=A1*1440/60*B1
Messages postés
5
Date d'inscription
mardi 19 avril 2005
Statut
Membre
Dernière intervention
19 avril 2005
5
Salut,

Je ne comprends pas ce que tu cherches ?

Tu as fait le

=A1*B1
=2*2:10
=4:20

Tout simplement
Bonjour,
Essaye...
=A1*B1
=2*12:15
=00:30
!!!
Au delà de 24:00 en résultat, cela ne fonctionne plus
Au delà de 24:00 il faut passer le format de cellule en personnalisé -> [h]:mm:ss
donc ça fonctionnera.
Bonjour,

en Exel version US cela fait :

soit A3= A2 * ( HOUR(A1) + MIN(A1)/60+second(A1)/3600)
Il suffit de fixer le format de la cellule en € et le tour est joué...

CQFD
salut annonymous, merci pour ton aide,je n'ai pas la version US d'excel,mais je vais voir ce que ça donne et je te tiens au courant
c'est encore moi,j'ai suivi tes instructions,mais ça ne marche pas,la formule contient une erreur ou alors elle me donne une valeur érronée,??????????????????????
Meilleure réponse!
à la place de HOUR, MIN et SECOND écrire les formules en francais, certainement HEURE, MINUTE, SECONDE (malheureusement j'utilise excel en allemand)

Également, si vous voulez multiplier chaque minute et non les heures, adapter la formule
A3= A2 * ( HEURE(A1)*60 + MINUTE(A1)+SECONDE(A1)/60)
Messages postés
2
Date d'inscription
dimanche 6 avril 2008
Statut
Membre
Dernière intervention
2 juin 2016
2
il faut transformer les heures en 100ème d'heure
ex: A1 est au format heure : 1:30
il suffit de multiplier A1 par 24, avec la formule =A1*24 ce qui donne 1,50 au format nombre (dans la colonne A2 que l'on aura masquée)
en A3 on a 5,20 euros au format monétaire, la multiplication se fait en A4 au format monétaire avec la formule : =A2*A3
Bonjour,
personne n'a de réponse SVP??????
Messages postés
18
Date d'inscription
dimanche 30 octobre 2005
Statut
Membre
Dernière intervention
12 octobre 2008
2
pb resolu
merci
Bonjours
Un petit coup de main svp.
A1 et au format heure : 1:30
A2 et au format monétaire : 5,20 €
A3 et au format euros = A1 x A2
Comment peut ont multiplier des heures avec des euros pour un résultat en euro.
Merci d' avance.
Salut marco,j'ai le meme problème que toi, merci de me dire si tu as trouvé la solution au problème