[Excel] Faire un calcul si condition vérifiée

Fermé
gigi3c - 16 avril 2009 à 07:13
Raymond PENTIER Messages postés 57015 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 8 février 2023 - 17 avril 2009 à 05:44
Bonjour,

alors voilà j'explique mon souci, je voudrais faire un calcul particulier si une des cases est différente de 0 (pour éviter la division par zéro), j'ai donc tapé :

=SI(A3<>0;((B3-A3)*100)/A3);"") {je calcule en fait un pourcentage d'augmentation}
j'ai aussi essayé : =SI(A3<>0;=((B3-A3)*100)/A3);"") et =SI(A3<>0;(=((B3-A3)*100)/A3));"") mais Excel me dit toujours que j'ai une erreur dans la formule...

Si quelqu'un a déjà rencontré ce problème ou connait la solution, merci d'avance!

2 réponses

Raymond PENTIER Messages postés 57015 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 8 février 2023 17 174
17 avril 2009 à 05:44
... d'autant que tu as des parenthèses inutiles !
=SI(A3<>0;(B3-A3)*100/A3;"") suffit largement ...
1