Connexion localhost

Résolu
Bonjour,
Je viens d'installer MAMP 4.0.2. et je suis confronté à l'aperçu dans les navigateurs. à chaque fois que je lance l'aperçu dans Firefox ou Opera je reçois les messages suivants:
- avec firefoxe: Firefox ne peut établir de connexion avec le serveur à l’adresse localhost.
- avec opera: Ce site est inaccessible. localhost n'autorise pas la connexion.
Je travaille avec dreamweaver CS6.
Merci de me venir en aide.

1 réponse

  1. Bonjour,

    Peut-on avoir un peu plus de détails? Configurations, dossier web pointé, logs serveurs, etc.
    1. Bonjour,

      Je vous remercie pour votre attention.

      Si vous insinuez configuration de mon système, c'est:
      - imac, OSX EL Capitan, processeur 3,06 GHz Intel Core i3,
      Quant à MAMP j'ai la version 4.0.2. utilisant comme port pour apache 8888, Nginx8888 et mysql 8889 une configuration par défault et le cocument root: application->mamp->hrdocs.

      Je vous prie de m'excuser je ne suis qu'un autodidacte en ce domaine, je vous fournies ce que j'ai compris par vos questions.
      Encore une fois merci.

      Bonne journée/nuit à vous.
    2. Je ne connais pas MAMP suffisamment, mais il doit y avoir un ou plusieurs fichier(s) de log. Il y a fort à parier qu'il y est quelque chose d'intéressant à cet endroit.

      Une chose me paraît étrange, tu dis que Apache et Nginx écoutent sur le même port 8888?
    3. Salut
      Oui effectivement Apache et Nginx écoutent sur le même port 8888; configuration par default. quant aux fichiers log j'n'ai trouvé deux: apache_error.log et mysql_error_log.err. J'ai fait un petit tour sur le apache_error.log mais je ne sai pas à quel niveau du code je dois intervenir.

      Merci gardientdelanuit pour ton assistance.
    4. Je doute que nginx et apache s'accorde pour se partager le même port :D Commence déjà par leur attribuer chacun un port différent.
      Il faut absolument que tu trouves les logs, la raison à ton problème y est très certainement écrite!
    5. @gardiendelanuitMerci gardiendelanuit, ton assistance m'a permis de résoudre le problème? En effet j'ai configuré les ports comme suit:
      apache: 80
      Nginx:8888
      Mysql:8889

      Tout fonctionne bien. encore une fois merci. bonne journée