Erreur Accès refusé phpMyAdmin et wamp [Fermé]

Signaler
-
 loicosquaredemadrid -
Bonjour Tout le monde ,
J'ai un problème avec phpMyAdmin , en fait en voulant installer un script php j'ai du ajouter aux privilèges de l'utilisateur root un mot de passe mais après la fin de l'installation phpMyAdmin ne veut plus s'ouvrir et m'affiche l'erreur suivante : Accès refusé

Bienvenue sur phpMyAdmin


Erreur
MySQL a répondu:

#1045 - Access denied for user 'root'@'localhost' (using password: NO)
phpMyAdmin a tenté de se connecter au serveur MySQL, et le serveur a rejeté la connexion.
Veuillez vérifier les valeurs de host, username et password dans votre configuration et vous assurer qu'elles correspondent aux informations fournies par l'administrateur du serveur MySQL.


pouvez vous m'aider svp :)

Merci

2 réponses

Messages postés
1
Date d'inscription
dimanche 21 octobre 2012
Statut
Membre
Dernière intervention
21 octobre 2012
11
Dirige toi dans C:\wamp\Apache2\conf\alias\phpmyadmin.conf
Remplace la ligne " Allow from 127.0.0.1" par "Allow from all" et de redémarrer les services.

Si ça fonctionne pas, on demarre wamp et on ouvre MySql en ligne de commande et tapez :

SET PASSWORD FOR root@localhost=PASSWORD(' monmotdepasse ');
mysql> GRANT ALL PRIVILEGES ON *.* TO root@localhost IDENTIFIED BY ' monmotdepasse ' WITH GRANT OPTION;

Puis rendez vous dans wamp/apps/phpmyadmin3.4.5/config.inc.php :
Modifiez les lignes suivantes :

$cfg['Servers'][$i]['host']= 'localhost';
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password']= 'monmotdepasse';

Enfin rendez vous dans wamp, ouvrez le fichier php.ini, puis modifiez comme ce qui suit :

; Default host for mysql_connect() (doesn't apply in safe mode).
mysqli.default_host ='localhost'
; Default user for mysql_connect() (doesn't apply in safe mode).
mysqli.default_user ='root'
; file will be able to reveal the password as well.
mysqli.default_pw ='monmotdepasse'

Voilà !
Si maintenant tout comme moi vous n'avez vraiment pas de chance, vous pouvez toujours essayer de changer le nom du dossier wamp.

Vérifiez bien que vous avez les droits de demarrer les services, et surtout verifiez les allias par defauts !!

Bon courage ;D
11
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 57092 internautes nous ont dit merci ce mois-ci

Messages postés
1
Date d'inscription
mardi 19 mai 2015
Statut
Membre
Dernière intervention
19 mai 2015

c cool! ca marche ossi pour moi. Merci loooooooooo!
ça marche très bien merçiiiiii
Messages postés
1
Date d'inscription
mercredi 14 octobre 2015
Statut
Membre
Dernière intervention
14 octobre 2015

Merci tagadah ! j'ai appliqué et ça à marcher !
Messages postés
1
Date d'inscription
vendredi 24 novembre 2017
Statut
Membre
Dernière intervention
24 novembre 2017

Merci ca a marché pour moi. Thanks

merci tadagah ca marche
Messages postés
3
Date d'inscription
dimanche 3 juin 2012
Statut
Membre
Dernière intervention
5 juin 2012

desinstale completement [wamp] , meme dans le registre dabord e reinstalle
Merci hackerpeace