Impossible de lancer APACHE2

Résolu
Bonjour,

J'ai installé PHPmyAdmin via

sudo apt-get install phpmyadmin


Mais le problème, quand je veux lancer Apache2

via, la ligne de commande

sudo service apache2 start


Il m'affiche ce message d'erreur:

ninie@ninie-laptop:~$ sudo service apache2 start
 * Starting web server apache2                                                  apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
                                                                         [fail]


Ca fait 3jours que j'essaie de toruver une solution mais rien.

Merci d'avance pour votre aide.

20 réponses

  1. Contributeur
    Salut,
    est ce que par hasard il n'y aurait pas apache (version 1) qui tourne également ?

    1. Cela m'etonnerait, j'ai reformaté mon pc aujourd'hui matin pour resoudre se problème, mais il y a toujours le meme message d'erreur
      1. voila

        ninie@ninie-laptop:~$ netstat -lpn | grep :80
        (Tous les processus ne peuvent être identifiés, les infos sur les processus
        non possédés ne seront pas affichées, vous devez être root pour les voir toutes.)
        tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN      -               
        
        1. Modérateur
          Re,

          ps aux | egrep 'apache|http'
          --
          GNU/Linux:Linux is Not Ubuntu! Quel linux choisir ne veut pas dire votre Distribution préférée,
          106485010510997108
          1. Voila

            ninie@ninie-laptop:~$ ps aux | egrep 'apache|http'
            ninie     1849  0.0  0.5  19248  3984 ?        S    09:20   0:00 /usr/lib/gvfs/gvfsd-http --spawner :1.6 /org/gtk/gvfs/exec_spaw/2
            root      2206  0.0  2.1  51136 16776 ?        Ss   09:27   0:00 /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
            nobody    2358  0.0  1.4  47508 10868 ?        S    09:27   0:00 /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
            nobody    2359  0.0  1.6  51136 12780 ?        S    09:27   0:00 /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
            nobody    2360  0.0  1.6  51136 12788 ?        S    09:27   0:00 /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
            nobody    2361  0.0  1.6  51136 12780 ?        S    09:27   0:00 /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
            nobody    2362  0.0  1.6  51136 12780 ?        S    09:27   0:00 /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
            nobody    2363  0.0  1.6  51136 12780 ?        S    09:27   0:00 /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
            ninie     7087  0.0  0.1   3332   820 pts/0    S+   10:37   0:00 egrep --color=auto apache|http
            ninie@ninie-laptop:~$ 
            
            1. Modérateur
              Re,

              Ben, voilà.
              Tu as installé lamp et aussi le paquetage apache2
              Il faut choisir, lamp ou conduire ;-)

              Sous GNU/Linux l'installation de lamp je trouve que c'est une des pires choses qu'on peut le faire.
              Il suffit d'utiliser le gestionnaire de paquets.
              Sinon, installation depuis les sources, mais pas lamp (je parle de l'application lamp pas de principe LAMPP - Linux Apache PhpPerl)

              1. Alors, pour regler se problème:
                T me conseille quoi?
                Supprimer tout proprement et recommencer, garder apache ou le supprimer et si possible les commandes pour le faire.

                PS: Merci bcp de votre aides ;-)
                1. Contributeur
                  Salut,
                  soit tu utilise lampp soit tu utilises les outils installés via le gestionnaire de paquetage.
                  C'est à toi de voir.
              2. ok je vais supprimer via synaptic
                car je prefere lampp car + simple d'utilisation.

                Je fais ca des que je peux et vous tien au courant

                Merci beaucoup pour votre aide
                1. Voila,
                  J'ai supprimé apache 2 et redémarré mon pc.
                  Mtn j'ai tapé la commande

                  sudo lampp start


                  et il me repond ceci

                  ninie@ninie-laptop:~$ sudo lampp start
                  [sudo] password for ninie: 
                  Starting XAMPP for Linux 1.7.3a...
                  XAMPP: Starting Apache with SSL (and PHP5)...
                  XAMPP: Starting MySQL...
                  XAMPP: Couldn't start MySQL!
                  XAMPP: Starting ProFTPD...
                  XAMPP for Linux started.
                  ninie@ninie-laptop:~$ 
                  


                  Quelqu'un saurait me dire comment démarrer MySQL ou dois-je creer un nouveau sujet?
                  1. Modérateur
                    Re,

                    ps aux | grep mysql
                    --
                    GNU/Linux:Linux is Not Ubuntu! Quel linux choisir ne veut pas dire votre Distribution préférée,
                    106485010510997108
                    1. Voila la reponse qu'il me donne
                      ninie@ninie-laptop:~$ ps aux | grep mysql
                      ninie     1906  0.0  0.1   3336   800 pts/1    S+   11:17   0:00 grep --color=auto mysql
                      ninie@ninie-laptop:~$ 
                      1. Modérateur
                        Re,

                        Il faut regarder les logs de mysql alors.
                        Tu as respecté la procédure d'installation expliqué sur le site de xampp?
                        1. Modérateur
                          Re,

                          Oui, tout est correct.
                          Ben, non, puisque mysql ne démarre pas.
                          Affiche

                          ls -ld /opt/lampp

                          1. Enfin, l'installation est complete.
                            Voila

                            drwxr-xr-x 18 root root 4096 2010-08-06 09:46 /opt/lampp
                            1. Modérateur
                              Re,

                              On va essayer comme ça

                              sudo chwon -R /opt/lampp  
                              sudo chmod -R /opt/lampp  
                              sudo /opt/lampp/lampp restart

                              --
                              GNU/Linux:Linux is Not Ubuntu! Quel linux choisir ne veut pas dire votre Distribution préférée,
                              106485010510997108
                              1. Voila le resultat total

                                ninie@ninie-laptop:~$ sudo chwon -R /opt/lampp
                                sudo: chwon: command not found
                                ninie@ninie-laptop:~$ sudo chmod -R /opt/lampp
                                chmod: opérande manquante après '/opt/lampp'
                                Pour en savoir davantage, faites: « chmod --help ».
                                ninie@ninie-laptop:~$ sudo /opt/lampp/lampp restart
                                Stopping XAMPP for Linux 1.7.3a...
                                XAMPP: Stopping Apache with SSL...
                                XAMPP: XAMPP-MySQL is not running.
                                XAMPP: Stopping ProFTPD...
                                XAMPP stopped.
                                Starting XAMPP for Linux 1.7.3a...
                                XAMPP: Starting Apache with SSL (and PHP5)...
                                XAMPP: Starting MySQL...
                                XAMPP: Couldn't start MySQL!
                                XAMPP: Starting ProFTPD...
                                XAMPP for Linux started.
                                ninie@ninie-laptop:~$ 
                                
                                1. Modérateur
                                  Re,

                                  Oups, j'ai oublié de mettre les droits

                                  sudo chwon -R /opt/lampp  
                                  sudo chmod -R 0777 /opt/lampp  
                                  sudo /opt/lampp/lampp restart


                                  1. Merci beaucoup, cela fonctionne voila les reponses

                                    ninie@ninie-laptop:~$ sudo chwon -R /opt/lampp  
                                    sudo: chwon: command not found  
                                    ninie@ninie-laptop:~$ sudo chmod -R 0777 /opt/lampp  
                                    ninie@ninie-laptop:~$ sudo /opt/lampp/lampp restart  
                                    Stopping XAMPP for Linux 1.7.3a...  
                                    XAMPP: Stopping Apache with SSL...  
                                    XAMPP: Stopping MySQL...  
                                    XAMPP: Stopping ProFTPD...  
                                    XAMPP stopped.  
                                    Starting XAMPP for Linux 1.7.3a...  
                                    XAMPP: Starting Apache with SSL (and PHP5)...  
                                    XAMPP: Starting MySQL...  
                                    Warning: World-writable config file '/opt/lampp/etc/my.cnf' is ignored  
                                    Warning: World-writable config file '/opt/lampp/etc/my.cnf' is ignored  
                                    XAMPP: Starting ProFTPD...  
                                    XAMPP for Linux started.  
                                    


                                    Et pour vérifier j'ai executer

                                    sudo lampp status


                                    Et voila la réponse

                                    ninie@ninie-laptop:~$ sudo lampp status  
                                    Version: XAMPP for Linux 1.7.3a  
                                    Apache is running.  
                                    MySQL is running.  
                                    ProFTPD is running.  
                                    ninie@ninie-laptop:~$ 


                                    ET ENCORE MERCI POUR VOTRE AIDE !!!!!
                                    JE VAIS VIVEMENT RECOMMENDER CE FORUM!
                                    1. Modérateur
                                      Re,

                                      On peu dire que c'est résolu alors.