Apt-get install ... e
Résoluje suis sur le point d'installer un packet que j'ai mis sur mon bureau :
apt-get install /home/vsadmin/Desktop/packet.deb
Donc je me connecte a mon terminal .... puis :
linux@debian:~$ sudo apt-get install /home/linux/Desktop/packet.deb
[sudo] password for linux: /****je tappe mon mot de passe ***/
je retombe sur
linux@debian:~$
<gras>linux@debian:~$ sudo apt-get install /home/linux/Desktop/packet.deb
[sudo] password for linux: /****je tappe mon mot de passe ***/
je retombe sur
linux@debian:~$
<gras>linux@debian:~$ sudo apt-get install /home/linux/Desktop/packet.deb
[sudo] password for linux: /****je tappe mon mot de passe ***/
je retombe sur
</gras>
bref une petite boucle :s
Ou est l'erreur ?
Merci
45 réponses
Le souci central est l’installation d’un paquet .deb sur Debian via apt-get et l’utilisation de sudo lorsque les droits d’administration ne sont pas correctement configurés. Plusieurs contributions proposent d’agir en tant que root avec dpkg -i, ou de configurer sudo via /etc/sudoers, ou d’utiliser sudo -c pour exécuter la commande en tant que root. Des propositions détaillent aussi des approches pratiques comme le passage en root avec su -, ou l’installation en mode root sans passer par sudo, puis l’installation du paquet. Une nuance utile est que la modification de /etc/sudoers doit être réalisée avec précaution, car une erreur peut bloquer durablement les droits administratifs et nécessiter une récupération via mode recovery ou sauvegardes.
-
merci a toi !
J'ai tout reinitialiser car trops de problème...
A bientôt !! -
ModérateurSalut,
find / -name 'packet.deb' 2>/dev/null
--
106485010510997108 -
salut lami20j, j'ai crée un compte root sur mon serveur.
avec un apt-get install, mes packets sont lus, un arbre des dépendances est créé mais j'ai le message :
E: Impossible de trouver le paquet packet.deb
Sa pourrait venir de quoi ? -
en mode single, c'est a dire reboot de ma machine .....
http://www.commentcamarche.net/forum/affich 680630 mot de passe perdu
et tout ce qui s'en suit -
ModérateurRe,
ok, d'accord, je n'ai pas vu ;-)
de toute façon pour modifier le fichier /etc/groups tu dois être root
donc tu n'as pas la possibilité
essaie une connexion en mode single, peut être que tu auras de la chance et le mot de passe ne sera pas demandé
-
si regarde en gras plus haut
-
ModérateurDans le fichier /etc/groups, tu n'as pas le groupe admin ?!
-
root:x:0:
daemon:x:1:
bin:x:2:
sys:x:3:
adm:x:4:
.......
mlocate:x:110:
ssh:x:111:
user:x:1000:
lpadmin:x:112:
admin:x:113:
gdm:x:114:
messagebus:x:115:
polkituser:x:116:
haldaemon:x:117:
webmaster:x:1001:user
de toute manière je n'ai pas les droits de modifier le fichier, donc reboot oblige :( -
ModérateurRe,
non, ce n'est pas comme ça que tu dois faire
affiche le résultat de cat /etc/groups -
initialement le fichier est :
root:x:0:
...
.....
......
.webmaster:x:1001:user
je suppose que je doit le modifier de cette manière : ??
root:x:0:user
...
...
...
.webmaster:x:1001:
ou plutôt
root:x:0:root
...
...
...
webmaster:x:1001:user
??? -
ton utilisateur dois faire parti du groupe admin pour qu'il fasse sudo
du groupe root tu veux dire?
CD Live et modifier le fichier /etc/groups
je ne peu pas le faire en mode console a distance ?
merci pour tes remarques -
ModérateurSalut,
ton utilisateur dois faire parti du groupe admin pour qu'il fasse sudo
mais je vois que chez toi tu n'as que user webmaster
mets comme tu n'as pas accès à ton compte root, alors ça sera difficile
tu peux demarrer avec un CD Live et modifier le fichier /etc/groups -
ModérateurRe,
affiche aussi le résultat defor i in $(cat /etc/passwd |cut -d':' -f1,3| egrep '[1-9][0-9][0-9]');do groups ${i%%:*};done
-
ModérateurRe,
Affiche le résultat decat /etc/passwd
-
J'ai lu sa aussi sur d'autres forum..
en QWERTY c'est pareil !!
Mais l'erreur n'est pas un mot de passe erronné.
C'est que je n'arrive pas a acceder en root, sa reboucle sur un prompt en user (avec le bon mot de passe).
et la commande su e retourne une erreur d'authentification
en resumé :
sudo su reboucle toujours sur "user"
su:
erreur de ce type --> Authentication failure
et non d'erreur de mot de passe -->Sorry, try again. -
ContributeurPourquoi nous parler de DEbian depuis le début alors ??? La gestion des droits ne se fait pas de la même manière...
-
-
Contributeur@-CCM-Ubuntu est dérivée de Debian, comme Knoppix, Xandros et tant d'autres. Mais ce n'est pas Debian.
Donc pour avoir les droits admin, il suffit d'utiliser ton compte utilateur avec sudo. -
@Franzuxonc pour avoir les droits admin, il suffit d'utiliser ton compte utilateur avec sudo.
c'est ce que j'essai de faire mais sa ne fonctionne pas ! :(
-
-
essaye en tapant ton mot de passe en QWERTY
-
ubuntu
-
* Pour accéder à un shell en root, tapez simplement dans un terminal: sudo -i
* Pour lancer une commande en tant que root, tapez: sudo commande
* Pour lancer une application graphique en tant que root, tapez: gksudo application
Votre mot de passe vous sera demandé (vous n'entrez pas celui de root... puisqu'il n'en possède pas !)
le souci c'est quand je fait un sudo -i par exemple, il me demande bien le mot de passe de l'user, mais le prompte reste en user et ne passe pas en sudo . -
re, jai saisis le mot de passe de l'user...puis la touche "entrer" car par defaut le mot de passe est vide..
http://www.commentcamarche.net/faq/sujet 8159 il n y a pas de compte root sous ubuntu
je ne me souvient pas avoir eu a enregistrer un mot de passe pour root !
le "user" que j'ai créé etait censé avoir les droits de root .
- 1
- 2
- 3