Impossible d'accéder à mes BDD à partir explorateur objet SSMS
Résolu
Bonjour,
J'ai subitement un problème que je ne comprends pas. Dans l'explorateur d'objet de SSMS, quand je déroule " Bases de données " pour accéder à mes BDD, je reçois le message suivant:
je suis sous SQLSERVER 2008. Mes BDD tournent bien , parce que mes sauvegardes se font normalement; et je peux même accéder aux BDD via les applications.
Je voudrais accéder aux données via SSMS pour régler un problème de connexion .
Aidez moi sil vous plait.
J'ai subitement un problème que je ne comprends pas. Dans l'explorateur d'objet de SSMS, quand je déroule " Bases de données " pour accéder à mes BDD, je reçois le message suivant:
TITRE : Microsoft SQL Server Management Studio
------------------------------
Échec de la récupération de données pour cette demande. (Microsoft.SqlServer.Management.Sdk.Sfc)
Pour obtenir de l'aide, cliquez sur : https://www.microsoft.com/fr-fr/?ref=go
------------------------------
INFORMATIONS SUPPLÉMENTAIRES :
Une exception s'est produite lors de l'exécution d'une instruction ou d'un lot Transact-SQL. (Microsoft.SqlServer.ConnectionInfo)
------------------------------
ID de base de données 9 introuvable. La base de données n'a peut-être pas encore été activée ou elle est en transition. Réexécutez la requête dès que la base de données est disponible. Si vous ne pensez pas que cette erreur est due à la transition d'état d'une base de données et que l'erreur continue à se produire, contactez votre fournisseur d'assistance principal. Consultez le journal des erreurs de Microsoft SQL Server ainsi que toute autre information pertinente relative aux circonstances de l'erreur. (Microsoft SQL Server, Erreur : 913)
Pour obtenir de l'aide, cliquez sur : https://www.microsoft.com/fr-fr/?ref=go
------------------------------
BOUTONS :
OK
------------------------------
je suis sous SQLSERVER 2008. Mes BDD tournent bien , parce que mes sauvegardes se font normalement; et je peux même accéder aux BDD via les applications.
Je voudrais accéder aux données via SSMS pour régler un problème de connexion .
Aidez moi sil vous plait.
2 réponses
-
Merci HDU, le problème a été réglé en redémarrant le serveur . Merci infiniment.
-
-
Et je ne veux pas faire l'oiseau de mauvaise augure, mais ne veux que te conseiller vu "l’événement" (à part si ton serveur sql n'avait pas été redémarré depuis xx temps) :
j'espère que tu fais des sauvegardes des bases systèmes à heure H. J'ai un peu peur que le souci vienne d'une des bases msdb ou tempdb ( bases sys en + de model et master, mais ce n'étaient pas elles vu le souci rencontré).
Je pense à une corruption de la msdb perso, mais sans voir les logs difficile...
Regardes vite les logs de msdb, à la première heure si tu est dba (ou sinon préviens le ce matin). Et aussi la taille du journal des transactions, mais si tu es dba, tu dois le savoir.
Mais cela me fait penser à un souci rencontré lors du test MS 70-764 que j'ai passé il n'y a pas 15j...
A+ (et ne lésines pas sur les sauvegardes des db system, surtout demain)
-