Problème pour accéder à mon serveur FTP

Résolu
Bonjour à tous,

J'ai fait des tonnes de recherches depuis deux jours sur la façon dont créer son propre serveur FTP. Et j'ai un problème que je n'arrive absolument pas à résoudre ... Je m'explique :

Je suis actuellement sous Windows 7, edition familiale.
A l'aide du logiciel TYPSoft FTP Server, j'ai donc créé mon serveur dans la partie "FTP Setup" (port 21)
J'arrive à me connecter dessus avec FileZilla ou même Firefox en utilisant mon adresse IP locale (192.168.1.12).
Tout baigne !

Mais dès que j'essaie d'accéder à mon serveur FTP via mon autre adresse IP (celle d'internet, que j'obtiens sur http://www.mon-ip.com/ )
Impossible de me connecter, rien à faire.

Je suis pourtant bien sur le port 21.
Ma box (Livebox) n'empêche pas les connexions sur le port 21 (j'ai vérifié aussi).

Je ne sais pas comment faire, j'en viens même à me demander si c'est possible d'accéder à son server FTP depuis l'extérieur de son réseau local.... o_O

Je bloque complétement, et j'ai fait plein de recherche sur des forums, rien à faire . . .

Voyez-vous quelque chose que j'aurai mal fait ou mal paramétré ?

Merci beaucoup d'avance !

4 réponses

  1. Bonsoir à tous,

    Tout d'abord, merci pour vos réponses pertinentes : mon problème a bien avancé, il est pratiquement résolu à mon avis.

    Alors, ce matin, j'ai redémarré ma livebox (le nat n'était plus là), mais le problème était que je n'avais pas sélectionné le bon équipement. Du coup j'ai recréé une règle nat avec le bon équipement.

    Dans la journée, j'ai pu tenter de me reconnecter sur mon ftp depuis un autre poste et super : ça a marché, mon serveur ftp est maintenant accessible depuis internet.

    Du coup, je n'ai pas eu besoin d'essayer de mettre une ip statique, ni de modifier des paramètres de mon par-feu.

    J'ai même créé mon hôte avec le logiciel "No-IP" (et ce tutoriel http://www.mon-ip.com/obtenir-une-adresse-ip-fixe.php )

    Mais j'ai un dernier problème. J'explique :

    Je peux me connecter à l'aide de FileZilla sur mon serveur ftp : tout marche (c'est ce que je voulais)
    Par contre quand je veux tester mon serveur ftp, toujours sur le site https://ftptest.net/ , j'ai un message d'erreur :
    "Error: FEAT response lines must begin with a single space character "

    Voici le test log complet :

    Status: Resolving address of (adresse_de_mon_hôte.org)
    Status: Connecting to xx.xxx.xx.xxx
    Status: Connected, waiting for welcome message
    Reply: 220 TYPSoft FTP Server 1.11 ready...
    Command: CLNT https://ftptest.net/ on behalf of xx.xxx.xx.xxx
    Reply: 500 'CLNT': command not understood.
    Command: USER coffi
    Reply: 331 Password required for coffi.
    Command: PASS ***
    Reply: 230 User coffi logged in.
    Command: SYST
    Reply: 215 UNIX Type: L8
    Command: FEAT
    Reply: 211-Extensions supported:
    Reply: SIZE
    Error: FEAT response lines must begin with a single space character

    Sur FileZilla je n'ai pas d'erreur du tout...

    Puis-je remédier à cette erreur que j'obtiens sur https://ftptest.net/ ?

    Merci d'avance.
    0
    1. OK, parfait,
      ne t'en fais pas pour la réponse à la commande features, c'est une querelle entre serveurs ftp (le testeur est fait pour filezilla server), peut-etre que ton serveur ne respecte pas bien la syntaxe, je ne sais pas si il y a une rfc qui décrit le protocole à respecter pour ces extensions du langage.
      clnt n'est pas reconnue non plus.
      mais ton serveur fonctionne.
      la solution, serait d'installer filezilla server ;-)
      0
    2. Super nouvelle, Enjoy!!
      0
    3. Génial !
      Bon alors mon problème est résolu !
      Merci pour toutes ces réponses : CCM au top !
      A bientôt !
      0