Problèmes après Apt-get update upgrade
RésoluVoici mon problème
Je suis sur serveur Debian
à la suite d'un apt-get update suivit d'un apt-get upgrade
voici l'erreur qu'il me donne
ParamÈtrage de apache2.2-common (2.2.9-10+lenny8) ... /bin/rm: ne peut enlever '/etc/apache2/ports.conf.dpkg-apache2.2-common.old': Aucun fichier ou rÈpertoire de ce type dpkg+: erreur de traitement de apache2.2-common (--configure)+: le sous-processus post-installation script a retournÈ une erreur de sortie d'Ètat 1 dpkg+: des problËmes de dÈpendances empÍchent la configuration de apache2-mpm-worker+: apache2-mpm-worker dÈpend de apache2.2-common (= 2.2.9-10+lenny8)+; cependant+: Le paquet apache2.2-common n'est pas encore configurÈ. dpkg+: erreur de traitement de apache2-mpm-worker (--configure)+: problËmes de dÈpendances - laissÈ non configurÈ dpkg+: des problËmes de dÈpendances empÍchent la configuration de apache2+: apache2 dÈpend de apache2-mpm-worker (>= 2.2.9-10+lenny8) | apache2-mpm-prefork (>= 2.2.9-10+lenny8) | apache2-mpm-event (>= 2.2.9-10+lenny8)+; cependant+: Le paquet apache2-mpm-worker n'est pas encore configurÈ. Le paquet apache2-mpm-prefork n'est pas installÈ. Le paquet apache2-mpm-event n'est pas installÈ. dpkg+: erreur de traitement de apache2 (--configure)+: problËmes de dÈpendances - laissÈ non configurÈ Des erreurs ont ÈtÈ rencontrÈes pendant l'exÈcution+: apache2.2-common apache2-mpm-worker apache2 E: Sub-process /usr/bin/dpkg returned an error code (1)
je tente apt-get -f install :
Lecture des listes de paquets... Fait Construction de l'arbre des dÈpendances Lecture des informations d'Ètat... Fait 0 mis # jour, 0 nouvellement installÈs, 0 # enlever et 2 non mis # jour. 3 partiellement installÈs ou enlevÈs. AprËs cette opÈration, 0o d'espace disque supplÈmentaires seront utilisÈs. ParamÈtrage de apache2.2-common (2.2.9-10+lenny8) ... /bin/rm: ne peut enlever '/etc/apache2/ports.conf.dpkg-apache2.2-common.old': Aucun fichier ou rÈpertoire de ce type dpkg+: erreur de traitement de apache2.2-common (--configure)+: le sous-processus post-installation script a retournÈ une erreur de sortie d'Ètat 1 dpkg+: des problËmes de dÈpendances empÍchent la configuration de apache2-mpm-worker+: apache2-mpm-worker dÈpend de apache2.2-common (= 2.2.9-10+lenny8)+; cependant+: Le paquet apache2.2-common n'est pas encore configurÈ. dpkg+: erreur de traitement de apache2-mpm-worker (--configure)+: problËmes de dÈpendances - laissÈ non configurÈ dpkg+: des problËmes de dÈpendances empÍchent la configuration de apache2+: apache2 dÈpend de apache2-mpm-worker (>= 2.2.9-10+lenny8) | apache2-mpm-prefork (>= 2.2.9-10+lenny8) | apache2-mpm-event (>= 2.2.9-10+lenny8)+; cependant+: Le paquet apache2-mpm-worker n'est pas encore configurÈ. Le paquet apache2-mpm-prefork n'est pas installÈ. Le paquet apache2-mpm-event n'est pas installÈ. dpkg+: erreur de traitement de apache2 (--configure)+: problËmes de dÈpendances - laissÈ non configurÈ Des erreurs ont ÈtÈ rencontrÈes pendant l'exÈcution+: apache2.2-common apache2-mpm-worker apache2 E: Sub-process /usr/bin/dpkg returned an error code (1)
biensur apache ne fonctionne plus.
et surtout
j'ai mon system fichier comme ça :
Sys. de fich. Tail. Occ. Disp. %Occ. Monté sur /dev/sda1 1,7G 1,6G 0 100% / tmpfs 1,4G 0 1,4G 0% /lib/init/rw udev 10M 752K 9,3M 8% /dev tmpfs 1,4G 0 1,4G 0% /dev/shm /dev/sda9 277G 8,1G 255G 4% /home /dev/sda8 373M 11M 343M 3% /tmp /dev/sda5 4,6G 1,4G 3,1G 30% /usr /dev/sda6 2,8G 417M 2,3G 16% /var
/dev/sda1 est saturé !!
comment faire pour qu'un apt-get -f install marche et remette tout si ma racine est 100% occupé...
j'avais déjà augmenté ce disque et je pensais qu'avec 1,7G c'était bon !! dois-je l'augmenter
NB : j'ai regardé dans /root qui est sur / s'il n'y avait pas de fichier plus gros que la normale, mais je n'ai rien vu...
je suis bloquée
merci de votre aide
--
Sirius 911
« On n'est pas le meilleur quand on le croit, mais quand on le sait... »
33 réponses
Suite à apt-get update et apt-get upgrade sur Debian, l’installation échoue en raison d’un échec de configuration d’apache2 et de dépendances bloquées par une racine saturée à 100%. Le diagnostic combine des messages dpkg indiquant que apache2.2-common ne peut pas être configuré et que des paquets dépendants restent en échec, avec un système de fichiers racine rempli. Plusieurs approches évoquées proposent soit purger et réinstaller Apache complètement pour libérer l’espace et rétablir les dépendances, soit d’abord libérer de l’espace sur la racine avant toute réparation. En cas de doute, commencer par libérer de l’espace sur / et/ou déplacer des données vers d’autres partitions, puis exécuter apt-get -f install afin de terminer la configuration et réinstaller les paquets.
-
ModérateurSalut,
Je suis content pour toi ;-)
Bonne continuation.
-
bon se matin tout est redevenu normal avec firefox !!
un coup de calgon !!
merci encore Lami20j -
lol
ben c'est quand même bizarre ce truc ?!
bon je vais aller regarder le foot sinon mon copain va être jaloux de toi !!!
en tous les cas merci mille fois lamy
grosse bise -
ModérateurRe,
Oups, j'ai oublié te dire que j'ai testé sur Firefox ;-)
-
ben je vais regarder sur un autre ordi qui a firefox pour être sur
à moins que toi tu ai firefox pour tester ! -
ModérateurRe,
Réinstalle ton firefox, on ne sait jamais. -
ben crotte alors !!!
oui sur Safari ça marche ?!?!?!
-
ModérateurRe,
Ben, moi j'ouvre ta page http://serveurlorin.dyndns.org/phpBB3/
Alors c'est plutôt une histoire de ton firefox, je ne sais pas.
Essaie avec un autre navigateur. -
ok alors mes pages php fonctionnent mais en faite
lorsque je clic sur le lien
http://serveurlorin.dyndns.org/phpBB3/
qui ne pointe pas directement sur un fichier firefox m'ouvre une boite de dialogue
pour me demander avec quoi je dois ouvrir le fichier
c'est certainement dans le apache2.conf mais pourtant j'ai bien :
DirectoryIndex index.html index.php
si je pointe sur
http://serveurlorin.dyndns.org/phpBB3/index.php
ça fonctionne
on est tout proche... merci Lami20j !!! -
ModérateurRe,
apt-get install libapache2-mod-php5
-
trop contente je l'avais fait avant de voir ton message !!
maintenant le serveur fonctionne mais il doit manquer des truc car les pages en php ne fonctionne pas
http://serveurlorin.dyndns.org/phpBB3/
j'ai installé php5 mais il manque encore quelque chose
-
ModérateurRe,
Donc l'installation c'est bien passé, mais apache ne veut pas démarrer
Cannot load /usr/lib/apache2/modules/mod_perl.so into server: /usr/lib/apache2/modules/mod_perl.so: cannot open shared object file: No such file or directory
Ben, on va installer le paquet manquant.
On va chercher le paquet qui contiens ce ficher d'abord.
lami20j@debian-acer:~$ apt-file search mod_perl.so libapache2-mod-perl2: /usr/lib/apache2/modules/mod_perl.so
Et on installe
apt-get install libapache2-mod-perl2
-
voilà
apt-get install apache2Lecture des listes de paquets... Fait Construction de l'arbre des dépendances Lecture des informations d'état... Fait Les NOUVEAUX paquets suivants seront installés : apache2 0 mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour. Il est nécessaire de prendre 0o/45,4ko dans les archives. Après cette opération, 102ko d'espace disque supplémentaires seront utilisés. Sélection du paquet apache2 précédemment désélectionné. (Lecture de la base de données... 64764 fichiers et répertoires déjà installés.) Dépaquetage de apache2 (à partir de .../apache2_2.2.9-10+lenny8_all.deb) ... Paramétrage de apache2 (2.2.9-10+lenny8) ...
mais quand je lance :
/etc/init.d/apache2 startStarting web server: apache2apache2: Syntax error on line 192 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/perl.load: Cannot load /usr/lib/apache2/modules/mod_perl.so into server: /usr/lib/apache2/modules/mod_perl.so: cannot open shared object file: No such file or directory failed!
-
ModérateurRe,
Continue avec apt-get pour voir
GNU/Linux:Linux is Not Ubuntu! Quel linux choisir ne veut pas dire votre Distribution préférée,
106485010510997108 -
j'ai plus de problème sur apt-get upgrade
dois-je ré-installé apache maintenant ?
et comment ?
par apt-get install apache2 ou par aptitude ?
j'ai toujours utilisé apt-get, je ne connais pas aptitude
merci en tous les cas lamy 20j
-
aptitude safe-upgrade
Lecture des listes de paquets... Fait Construction de l'arbre des dépendances Lecture des informations d'état... Fait Lecture de l'information d'état étendu Initialisation de l'état des paquets... Fait Lecture des descriptions de tâches... Fait Résolution des dépendances... Résolution des dépendances... Les NOUVEAUX paquets suivants vont être installés : apache2-mpm-worker{a} apache2-utils{a} apache2.2-common{a} libapr1{a} libaprutil1{a} libbind9-50{a} libdns55{a} libisc52{a} libisccc50{a} libisccfg50{a} liblwres50{a} Les paquets suivants seront ENLEVÉS : python2.4-minimal{u} Les paquets suivants seront mis à jour : bind9-host dnsutils 2 paquets mis à jour, 11 nouvellement installés, 1 à enlever et 0 non mis à jour. Il est nécessaire de télécharger 1216ko/2630ko d'archives. Après dépaquetage, 3703ko seront utilisés. Voulez-vous continuer ? [Y/n/?] Y Écriture de l'information d'état étendu... Fait Prendre : 1 https://www.debian.org/security/ lenny/updates/main libisc52 1:9.6.ESV.R1+dfsg-0+lenny2 [169kB] Prendre : 2 https://www.debian.org/security/ lenny/updates/main libdns55 1:9.6.ESV.R1+dfsg-0+lenny2 [664kB] Prendre : 3 https://www.debian.org/security/ lenny/updates/main libisccc50 1:9.6.ESV.R1+dfsg-0+lenny2 [29,2kB] Prendre : 4 https://www.debian.org/security/ lenny/updates/main libisccfg50 1:9.6.ESV.R1+dfsg-0+lenny2 [51,4kB] Prendre : 5 https://www.debian.org/security/ lenny/updates/main libbind9-50 1:9.6.ESV.R1+dfsg-0+lenny2 [32,6kB] Prendre : 6 https://www.debian.org/security/ lenny/updates/main liblwres50 1:9.6.ESV.R1+dfsg-0+lenny2 [48,5kB] Prendre : 7 https://www.debian.org/security/ lenny/updates/main bind9-host 1:9.6.ESV.R1+dfsg-0+lenny2 [65,4kB] Prendre : 8 https://www.debian.org/security/ lenny/updates/main dnsutils 1:9.6.ESV.R1+dfsg-0+lenny2 [157kB] 1216ko téléchargés en 1s (645ko/s) (Lecture de la base de données... 64460 fichiers et répertoires déjà installés.) Suppression de python2.4-minimal ... Unlinking and removing bytecode for runtime python2.4 libapache2-mod-python: 2.5 (['purge', 'ok', 'installed']) python-newt: 2.4, 2.5 (['install', 'ok', 'installed']) reportbug: current, >= 2.5 (['install', 'ok', 'installed']) python-imaging: 2.4, 2.5 (['install', 'ok', 'installed']) python-foomatic: all (['install', 'ok', 'installed']) fail2ban: current, >= 2.4 (['install', 'ok', 'installed']) Traitement des actions différées (« triggers ») pour « man-db »... Sélection du paquet libisc52 précédemment désélectionné. (Lecture de la base de données... 64309 fichiers et répertoires déjà installés.) Dépaquetage de libisc52 (à partir de .../libisc52_1%3a9.6.ESV.R1+dfsg-0+lenny2_amd64.deb) ... Sélection du paquet libdns55 précédemment désélectionné. Dépaquetage de libdns55 (à partir de .../libdns55_1%3a9.6.ESV.R1+dfsg-0+lenny2_amd64.deb) ... Sélection du paquet libisccc50 précédemment désélectionné. Dépaquetage de libisccc50 (à partir de .../libisccc50_1%3a9.6.ESV.R1+dfsg-0+lenny2_amd64.deb) ... Sélection du paquet libisccfg50 précédemment désélectionné. Dépaquetage de libisccfg50 (à partir de .../libisccfg50_1%3a9.6.ESV.R1+dfsg-0+lenny2_amd64.deb) ... Sélection du paquet libbind9-50 précédemment désélectionné. Dépaquetage de libbind9-50 (à partir de .../libbind9-50_1%3a9.6.ESV.R1+dfsg-0+lenny2_amd64.deb) ... Sélection du paquet liblwres50 précédemment désélectionné. Dépaquetage de liblwres50 (à partir de .../liblwres50_1%3a9.6.ESV.R1+dfsg-0+lenny2_amd64.deb) ... Préparation du remplacement de bind9-host 1:9.5.1.dfsg.P3-1+lenny1 (en utilisant .../bind9-host_1%3a9.6.ESV.R1+dfsg-0+lenny2_amd64.deb) ... Dépaquetage de la mise à jour de bind9-host ... Préparation du remplacement de dnsutils 1:9.5.1.dfsg.P3-1+lenny1 (en utilisant .../dnsutils_1%3a9.6.ESV.R1+dfsg-0+lenny2_amd64.deb) ... Dépaquetage de la mise à jour de dnsutils ... Sélection du paquet libapr1 précédemment désélectionné. Dépaquetage de libapr1 (à partir de .../libapr1_1.2.12-5+lenny2_amd64.deb) ... Sélection du paquet libaprutil1 précédemment désélectionné. Dépaquetage de libaprutil1 (à partir de .../libaprutil1_1.2.12+dfsg-8+lenny4_amd64.deb) ... Sélection du paquet apache2-utils précédemment désélectionné. Dépaquetage de apache2-utils (à partir de .../apache2-utils_2.2.9-10+lenny8_amd64.deb) ... Dépaquetage de apache2.2-common (à partir de .../apache2.2-common_2.2.9-10+lenny8_amd64.deb) ... Dépaquetage de apache2-mpm-worker (à partir de .../apache2-mpm-worker_2.2.9-10+lenny8_amd64.deb) ... Traitement des actions différées (« triggers ») pour « man-db »... Paramétrage de libisc52 (1:9.6.ESV.R1+dfsg-0+lenny2) ... Paramétrage de libdns55 (1:9.6.ESV.R1+dfsg-0+lenny2) ... Paramétrage de libisccc50 (1:9.6.ESV.R1+dfsg-0+lenny2) ... Paramétrage de libisccfg50 (1:9.6.ESV.R1+dfsg-0+lenny2) ... Paramétrage de libbind9-50 (1:9.6.ESV.R1+dfsg-0+lenny2) ... Paramétrage de liblwres50 (1:9.6.ESV.R1+dfsg-0+lenny2) ... Paramétrage de bind9-host (1:9.6.ESV.R1+dfsg-0+lenny2) ... Paramétrage de dnsutils (1:9.6.ESV.R1+dfsg-0+lenny2) ... Paramétrage de libapr1 (1.2.12-5+lenny2) ... Paramétrage de libaprutil1 (1.2.12+dfsg-8+lenny4) ... Paramétrage de apache2-utils (2.2.9-10+lenny8) ... Paramétrage de apache2.2-common (2.2.9-10+lenny8) ... Paramétrage de apache2-mpm-worker (2.2.9-10+lenny8) ... Starting web server: apache2apache2: Syntax error on line 192 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/perl.load: Cannot load /usr/lib/apache2/modules/mod_perl.so into server: /usr/lib/apache2/modules/mod_perl.so: cannot open shared object file: No such file or directory failed! invoke-rc.d: initscript apache2, action "start" failed. Lecture des listes de paquets... Fait Construction de l'arbre des dépendances Lecture des informations d'état... Fait Lecture de l'information d'état étendu Initialisation de l'état des paquets... Fait Écriture de l'information d'état étendu... Fait Lecture des descriptions de tâches... Fait État actuel : 0 paquet cassé [-1], 0 mise à jour restante [-2].
-
ModérateurRe,
aptitude safe-upgrade
donne quoi? -
dpkg -P --force-all libapache2-mod-python
(Lecture de la base de données... 64460 fichiers et répertoires déjà installés.) Suppression de libapache2-mod-python ... /bin/rm: ne peut enlever '/var/lib/pycentral/libapache2-mod-python.pkgremove': Aucun fichier ou répertoire de ce type dpkg : erreur de traitement de libapache2-mod-python (--purge) : le sous-processus pre-removal script a retourné une erreur de sortie d'état 1 Des erreurs ont été rencontrées pendant l'exécution : libapache2-mod-python
dpkg -P --force-all python2.4-minimal(Lecture de la base de données... 64460 fichiers et répertoires déjà installés.) Suppression de python2.4-minimal ... Unlinking and removing bytecode for runtime python2.4 libapache2-mod-python: 2.5 (['purge', 'ok', 'installed']) python-newt: 2.4, 2.5 (['install', 'ok', 'installed']) reportbug: current, >= 2.5 (['install', 'ok', 'installed']) python-imaging: 2.4, 2.5 (['install', 'ok', 'installed']) python-foomatic: all (['install', 'ok', 'installed']) fail2ban: current, >= 2.4 (['install', 'ok', 'installed']) /bin/rm: ne peut enlever '/var/lib/python-support/python2.4': est un répertoire dpkg : erreur de traitement de python2.4-minimal (--purge) : le sous-processus pre-removal script a retourné une erreur de sortie d'état 1 Des erreurs ont été rencontrées pendant l'exécution : python2.4-minimal
aptitude updateÉcriture de l'information d'état étendu... Fait Atteint http://ftp.fr.debian.org lenny Release.gpg Atteint http://ftp.fr.debian.org lenny/main Translation-fr Atteint http://ftp.fr.debian.org lenny Release Atteint https://www.debian.org/security/ lenny/updates Release.gpg Ign https://www.debian.org/security/ lenny/updates/main Translation-fr Ign https://www.debian.org/security/ lenny/updates/contrib Translation-fr Ign http://ftp.fr.debian.org lenny/main Packages/DiffIndex Atteint https://www.debian.org/security/ lenny/updates Release Prendre : 1 ftp://ftp.mondorescue.org 5.0 Release.gpg Ign http://ftp.fr.debian.org lenny/main Sources/DiffIndex Ign https://www.debian.org/security/ lenny/updates/main Packages/DiffIndex Ign https://www.debian.org/security/ lenny/updates/contrib Packages/DiffIndex Atteint http://ftp.fr.debian.org lenny/main Packages Ign https://www.debian.org/security/ lenny/updates/main Sources/DiffIndex Ign https://www.debian.org/security/ lenny/updates/contrib Sources/DiffIndex Atteint https://www.debian.org/security/ lenny/updates/main Packages Ign ftp://ftp.mondorescue.org 5.0 Release.gpg Atteint http://ftp.fr.debian.org lenny/main Sources Atteint https://www.debian.org/security/ lenny/updates/contrib Packages Atteint https://www.debian.org/security/ lenny/updates/main Sources Atteint https://www.debian.org/security/ lenny/updates/contrib Sources Prendre : 2 ftp://ftp.mondorescue.org 5.0/contrib Translation-fr Ign ftp://ftp.mondorescue.org 5.0/contrib Translation-fr Prendre : 3 ftp://ftp.mondorescue.org 5.0 Release Ign ftp://ftp.mondorescue.org 5.0 Release Prendre : 4 ftp://ftp.mondorescue.org 5.0/contrib Packages/DiffIndex Ign ftp://ftp.mondorescue.org 5.0/contrib Packages/DiffIndex Prendre : 5 ftp://ftp.mondorescue.org 5.0/contrib Sources/DiffIndex Ign ftp://ftp.mondorescue.org 5.0/contrib Sources/DiffIndex Prendre : 6 ftp://ftp.mondorescue.org 5.0/contrib Packages Ign ftp://ftp.mondorescue.org 5.0/contrib Packages Prendre : 7 ftp://ftp.mondorescue.org 5.0/contrib Sources Ign ftp://ftp.mondorescue.org 5.0/contrib Sources Atteint ftp://ftp.mondorescue.org 5.0/contrib Packages Atteint ftp://ftp.mondorescue.org 5.0/contrib Sources Lecture des listes de paquets... Fait
Sirius 911
« On n'est pas le meilleur quand on le croit, mais quand on le sait... » -
ModérateurRe,
dpkg -P --force-all libapache2-mod-python dpkg -P --force-all python2.4-minimal
ensuiteaptitude update
-
Debian Lenny
uname -r2.6.26-2-amd64
- 1
- 2