Problèmes après Apt-get update upgrade [Résolu/Fermé]

Signaler
Messages postés
269
Date d'inscription
mardi 30 janvier 2007
Statut
Membre
Dernière intervention
14 mars 2017
-
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
-
Bonjour à tous
Voici mon problème
Je suis sur serveur Debian
à la suite d'un apt-get update suivit d'un apt-get upgrade
voici l'erreur qu'il me donne

ParamÈtrage de apache2.2-common (2.2.9-10+lenny8) ...
/bin/rm: ne peut enlever '/etc/apache2/ports.conf.dpkg-apache2.2-common.old': Aucun fichier ou rÈpertoire de ce type
dpkg+: erreur de traitement de apache2.2-common (--configure)+:
 le sous-processus post-installation script a retournÈ une erreur de sortie d'Ètat 1
dpkg+: des problËmes de dÈpendances empÍchent la configuration de apache2-mpm-worker+:
 apache2-mpm-worker dÈpend de apache2.2-common (= 2.2.9-10+lenny8)+; cependant+:
 Le paquet apache2.2-common n'est pas encore configurÈ.
dpkg+: erreur de traitement de apache2-mpm-worker (--configure)+:
 problËmes de dÈpendances - laissÈ non configurÈ
dpkg+: des problËmes de dÈpendances empÍchent la configuration de apache2+:
 apache2 dÈpend de apache2-mpm-worker (>= 2.2.9-10+lenny8) | apache2-mpm-prefork (>= 2.2.9-10+lenny8) | apache2-mpm-event (>= 2.2.9-10+lenny8)+; cependant+:
 Le paquet apache2-mpm-worker n'est pas encore configurÈ.
  Le paquet apache2-mpm-prefork n'est pas installÈ.
  Le paquet apache2-mpm-event n'est pas installÈ.
dpkg+: erreur de traitement de apache2 (--configure)+:
 problËmes de dÈpendances - laissÈ non configurÈ
Des erreurs ont ÈtÈ rencontrÈes pendant l'exÈcution+:
 apache2.2-common
 apache2-mpm-worker
 apache2
E: Sub-process /usr/bin/dpkg returned an error code (1)


je tente apt-get -f install :
Lecture des listes de paquets... Fait
Construction de l'arbre des dÈpendances       
Lecture des informations d'Ètat... Fait
0 mis # jour, 0 nouvellement installÈs, 0 # enlever et 2 non mis # jour.
3 partiellement installÈs ou enlevÈs.
AprËs cette opÈration, 0o d'espace disque supplÈmentaires seront utilisÈs.
ParamÈtrage de apache2.2-common (2.2.9-10+lenny8) ...
/bin/rm: ne peut enlever '/etc/apache2/ports.conf.dpkg-apache2.2-common.old': Aucun fichier ou rÈpertoire de ce type
dpkg+: erreur de traitement de apache2.2-common (--configure)+:
 le sous-processus post-installation script a retournÈ une erreur de sortie d'Ètat 1
dpkg+: des problËmes de dÈpendances empÍchent la configuration de apache2-mpm-worker+:
 apache2-mpm-worker dÈpend de apache2.2-common (= 2.2.9-10+lenny8)+; cependant+:
 Le paquet apache2.2-common n'est pas encore configurÈ.
dpkg+: erreur de traitement de apache2-mpm-worker (--configure)+:
 problËmes de dÈpendances - laissÈ non configurÈ
dpkg+: des problËmes de dÈpendances empÍchent la configuration de apache2+:
 apache2 dÈpend de apache2-mpm-worker (>= 2.2.9-10+lenny8) | apache2-mpm-prefork (>= 2.2.9-10+lenny8) | apache2-mpm-event (>= 2.2.9-10+lenny8)+; cependant+:
 Le paquet apache2-mpm-worker n'est pas encore configurÈ.
  Le paquet apache2-mpm-prefork n'est pas installÈ.
  Le paquet apache2-mpm-event n'est pas installÈ.
dpkg+: erreur de traitement de apache2 (--configure)+:
 problËmes de dÈpendances - laissÈ non configurÈ
Des erreurs ont ÈtÈ rencontrÈes pendant l'exÈcution+:
 apache2.2-common
 apache2-mpm-worker
 apache2
E: Sub-process /usr/bin/dpkg returned an error code (1)


biensur apache ne fonctionne plus.
et surtout
j'ai mon system fichier comme ça :

Sys. de fich.         Tail. Occ. Disp. %Occ. Monté sur
/dev/sda1             1,7G  1,6G     0 100% /
tmpfs                 1,4G     0  1,4G   0% /lib/init/rw
udev                   10M  752K  9,3M   8% /dev
tmpfs                 1,4G     0  1,4G   0% /dev/shm
/dev/sda9             277G  8,1G  255G   4% /home
/dev/sda8             373M   11M  343M   3% /tmp
/dev/sda5             4,6G  1,4G  3,1G  30% /usr
/dev/sda6             2,8G  417M  2,3G  16% /var

/dev/sda1 est saturé !!
comment faire pour qu'un apt-get -f install marche et remette tout si ma racine est 100% occupé...
j'avais déjà augmenté ce disque et je pensais qu'avec 1,7G c'était bon !! dois-je l'augmenter
NB : j'ai regardé dans /root qui est sur / s'il n'y avait pas de fichier plus gros que la normale, mais je n'ai rien vu...
je suis bloquée
merci de votre aide


33 réponses

Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 505
Salut,

Affiche le résultat de (à faire en root)

du -sh /* 

Messages postés
269
Date d'inscription
mardi 30 janvier 2007
Statut
Membre
Dernière intervention
14 mars 2017
10
merci lami20j
voilà

4,6M	/bin
28M	/boot
0	/cdrom
752K	/dev
8,2M	/emul
21M	/etc
8,9G	/home
1,0K	/initrd
0	/initrd.img
0	/initrd.img.old
146M	/lib
0	/lib32
0	/lib64
12K	/lost+found
4,0K	/media
2,0K	/mnt
1,0K	/opt
du: ne peut accéder '/proc/19561/task/19561/fd/4': Aucun fichier ou répertoire de ce type
du: ne peut accéder '/proc/19561/task/19561/fdinfo/4': Aucun fichier ou répertoire de ce type
du: ne peut accéder '/proc/19561/fd/4': Aucun fichier ou répertoire de ce type
du: ne peut accéder '/proc/19561/fdinfo/4': Aucun fichier ou répertoire de ce type
0	/proc
330K	/root
3,9M	/sbin
1,0K	/selinux
1,0K	/srv
0	/sys
509K	/tmp
1,2G	/usr
349M	/var
0	/vmlinuz
0	/vmlinuz.old
1,0K	/webmin-setup.out

Messages postés
269
Date d'inscription
mardi 30 janvier 2007
Statut
Membre
Dernière intervention
14 mars 2017
10
personne ne peut m'aider?
au moins pouvez vous me dire si c'est normal de passer de 222Mo à 1,7G sur mon repertoire racine juste après un apt-get upgrade ?
faut-il que je repartitionne ?
puis-je mettre temporairement des fichiers sur mon /home pour que
apt-get -f install fonctionne, puis les remettre ensuite ?
merci de m'aider assez vite
biz
Messages postés
269
Date d'inscription
mardi 30 janvier 2007
Statut
Membre
Dernière intervention
14 mars 2017
10
bon toujours personne pour m'aider ?
j'ai rebooter le serveur et mon disque / n'est plus plein...
fonctionne toujours pas le apt-get -f install

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les NOUVEAUX paquets suivants seront installés :
  apache2-mpm-worker apache2.2-common
Les paquets suivants ont été conservés :
  bind9-host dnsutils
0 mis à jour, 2 nouvellement installés, 0 à enlever et 2 non mis à jour.
1 partiellement installés ou enlevés.
Il est nécessaire de prendre 0o/1073ko dans les archives.
Après cette opération, 4059ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? O
(Lecture de la base de données... 69944 fichiers et répertoires déjà installés.)
Dépaquetage de apache2.2-common (à partir de .../apache2.2-common_2.2.9-10+lenny8_amd64.deb) ...
/bin/rm: ne peut enlever '/var/lib/dpkg/info/apache2-common.postrm': Aucun fichier ou répertoire de ce type
dpkg : erreur de traitement de /var/cache/apt/archives/apache2.2-common_2.2.9-10+lenny8_amd64.deb (--unpack) :
 le sous-processus pre-installation script a retourné une erreur de sortie d'état 1
Dépaquetage de apache2-mpm-worker (à partir de .../apache2-mpm-worker_2.2.9-10+lenny8_amd64.deb) ...
/bin/rm: ne peut enlever '/var/cache/apache2/reload': Aucun fichier ou répertoire de ce type
dpkg : erreur de traitement de /var/cache/apt/archives/apache2-mpm-worker_2.2.9-10+lenny8_amd64.deb (--unpack) :
 le sous-processus pre-installation script a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/apache2.2-common_2.2.9-10+lenny8_amd64.deb
 /var/cache/apt/archives/apache2-mpm-worker_2.2.9-10+lenny8_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 505
Salut,

Je n'ai pas eu le temps de regarder et maintenant je suis au boulot ;-(

Pour le moment je vois pas avec quoi est remplie ta racine, puisque dans le résultat de la commande je ne vois pas les 1,6 Go occupés.


Vu que tu as crées pour home,usr,tmp,var des partitions dediées, alors la taille de la racine est suffisante.

Si jamais tu n'auras pas d'autre réponses, je vais regarder ça ce soir ou demain.

Messages postés
269
Date d'inscription
mardi 30 janvier 2007
Statut
Membre
Dernière intervention
14 mars 2017
10
je te remercie
le problème de la saturation du disque est parti ...
j'avais peut-etre des fichiers temporaires qui sont partis avec le reboot ??
mais le problème de l'apt get n'ai pas résolu
je te donne mon fichier lists

# 
#deb http://ftp.fr.debian.org/debian/ etch main
deb http://ftp.fr.debian.org/debian/ lenny main

#deb-src http://ftp.fr.debian.org/debian/ etch main
deb-src http://ftp.fr.debian.org/debian/ lenny main

#deb https://www.debian.org/security/ etch/updates main contrib
deb https://www.debian.org/security/ lenny/updates main contrib

#deb-src https://www.debian.org/security/ etch/updates main contrib
deb-src https://www.debian.org/security/ lenny/updates main contrib

deb ftp://ftp.mondorescue.org/debian 5.0 contrib
deb-src ftp://ftp.mondorescue.org/debian 5.0 contrib


merci d'avance
Messages postés
269
Date d'inscription
mardi 30 janvier 2007
Statut
Membre
Dernière intervention
14 mars 2017
10
personne pour m'aider ?
Messages postés
269
Date d'inscription
mardi 30 janvier 2007
Statut
Membre
Dernière intervention
14 mars 2017
10
voici une chose bizarre :
apt-cache policy apache2-mpm-prefork<br>

apache2-mpm-prefork:<br>
  Installé : (aucun)<br>
  Candidat : 2.2.9-10+lenny8<br>
 Table de version :<br>

     2.2.9-10+lenny8 0<br>
        500 <a href="http://ftp.fr.debian.org">http://ftp.fr.debian.org</a> lenny/main Packages<br>
     2.2.9-10+lenny7 0<br>
        500 <a href="https://www.debian.org/security/">http://security.debian.org</a> lenny/updates/main Packages<br>


est-ce normal qu'il y ai lenny8 0 et lenny 7 0 ?????

Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 505
Salut,

A part un essaie de mise à jour, as-tu fait autre chose?
Suppression à la main des fichiers de configuration, etc.


Affiche le résultat (la commande find à faire en root)
ps aux | grep apache
aptitude search ^apache
find / -name '*apache*' 2>/dev/null


Fin bref, on va essayer de supprime complètement apache et ensuite le réinstaller
Messages postés
269
Date d'inscription
mardi 30 janvier 2007
Statut
Membre
Dernière intervention
14 mars 2017
10
coucou
non je n'ai rien supprimé...

ps aux | grep apache
root     12195  0.0  0.0   5656   772 pts/0    R+   13:39   0:00 grep apache


aptitude search ^apache
B   apache2                                                                               - Métapaquet pour le serveur HTTP Apache                                                          
p   apache2-dbg                                                                           - Apache debugging symbols                                                                        
v   apache2-dev                                                                           -                                                                                                 
i   apache2-doc                                                                           - Documentation du serveur HTTP Apache                                                            
v   apache2-mpm                                                                           -                                                                                                 
p   apache2-mpm-event                                                                     - Apache HTTP Server - event driven model                                                         
p   apache2-mpm-itk                                                                       - multiuser MPM for Apache 2.2                                                                    
p   apache2-mpm-prefork                                                                   - Serveur HTTP Apache - modèle traditionnel « non-threaded »                                      
pi  apache2-mpm-worker                                                                    - Apache HTTP Server - high speed threaded model                                                  
p   apache2-prefork-dev                                                                   - Apache development headers - non-threaded MPM                                                   
p   apache2-src                                                                           - Code source de Apache                                                                           
p   apache2-suexec                                                                        - Standard suexec program for Apache 2 mod_suexec                                                 
p   apache2-suexec-custom                                                                 - Configurable suexec program for Apache 2 mod_suexec                                             
p   apache2-threaded-dev                                                                  - Apache development headers - threaded MPM                                                       
i A apache2-utils                                                                         - Programmes utilitaires pour serveurs web                                                        
ciA apache2.2-common                                                                      - Apache HTTP Server (fichiers communs)                                                           
i   apachetop                                                                             - Outil de surveillance de Apache en temps réel                                                   


find / -name '*apache*' 2>/dev/null


/usr/sbin/apachetop
/usr/lib/apache2
/usr/lib/python2.5/site-packages/mod_python/apache.pyc
/usr/lib/python2.5/site-packages/mod_python/apache.py
/usr/share/bug/apache2
/usr/share/pyshared/mod_python/apache.py
/usr/share/pyshared-data/libapache2-mod-python
/usr/share/doc-base/apache2-manual
/usr/share/selinux/refpolicy-targeted/apache.pp
/usr/share/webmin/mscstyle3/apache
/usr/share/webmin/apache
/usr/share/webmin/apache/apache-lib.pl
/usr/share/webmin/apache/mod_apachessl.pl
/usr/share/webmin/blue-theme/apache
/usr/share/webmin/status/services/apache.serv
/usr/share/webmin/status/apache-monitor.pl
/usr/share/webmin/caldera/apache
/usr/share/man/man1/apachetop.1.gz
/usr/share/doc/apache2
/usr/share/doc/apache2-doc
/usr/share/doc/apache2-doc/manual/fr/programs/apachectl.html
/usr/share/doc/apache2-doc/manual/ja/programs/apachectl.html
/usr/share/doc/apache2-doc/manual/ko/programs/apachectl.html
/usr/share/doc/apache2-doc/manual/tr/programs/apachectl.html
/usr/share/doc/apache2-doc/manual/es/programs/apachectl.html
/usr/share/doc/apache2-doc/manual/pt-br/programs/apachectl.html
/usr/share/doc/apache2-doc/manual/de/programs/apachectl.html
/usr/share/doc/apache2-doc/manual/en/programs/apachectl.html
/usr/share/doc/apache2-doc/manual/images/apache_header.gif
/usr/share/doc/apache2-utils
/usr/share/doc/apachetop
/usr/share/doc/libapache2-mod-python
/var/log/apache2
/var/lib/dpkg/info/libapache2-mod-python.postinst
/var/lib/dpkg/info/apachetop.md5sums
/var/lib/dpkg/info/apache2-doc.prerm
/var/lib/dpkg/info/apache2-doc.list
/var/lib/dpkg/info/apache2.2-common.list
/var/lib/dpkg/info/libapache2-mod-python.templates
/var/lib/dpkg/info/libapache2-mod-perl2.postrm
/var/lib/dpkg/info/apachetop.list
/var/lib/dpkg/info/libapache2-mod-python.config
/var/lib/dpkg/info/libapache2-mod-python.postrm
/var/lib/dpkg/info/apache2-doc.md5sums
/var/lib/dpkg/info/libapache2-mod-python.prerm
/var/lib/dpkg/info/apache2.list
/var/lib/dpkg/info/apache2-doc.conffiles
/var/lib/dpkg/info/libapache2-mod-python.conffiles
/var/lib/dpkg/info/libapache2-mod-php5.postrm
/var/lib/dpkg/info/apache2.2-common.postrm
/var/lib/dpkg/info/apache2.md5sums
/var/lib/dpkg/info/libapache2-mod-python.list
/var/lib/dpkg/info/apache2-doc.postinst
/var/lib/dpkg/info/libapache2-mod-python.preinst
/var/lib/dpkg/info/libapache2-mod-python.md5sums
/var/lib/dpkg/info/libapache2-mod-php5.list
/var/lib/dpkg/info/apache2-utils.md5sums
/var/lib/dpkg/info/libapache2-mod-perl2.list
/var/lib/dpkg/info/apache2-utils.list
/var/run/apache2
/var/www/phpBB3/includes/auth/auth_apache.php
/var/lock/apache2
/var/cache/apt/archives/apache2.2-common_2.2.9-10+lenny8_amd64.deb
/var/cache/apt/archives/apache2-mpm-worker_2.2.9-10+lenny8_amd64.deb
/home/sandrine/www/phpBB3/includes/auth/auth_apache.php
/etc/rc3.d/S91apache2
/etc/rc6.d/K09apache2
/etc/rc5.d/S91apache2
/etc/fail2ban/filter.d/apache-auth.conf
/etc/fail2ban/filter.d/apache-overflows.conf
/etc/fail2ban/filter.d/apache-noscript.conf
/etc/fail2ban/filter.d/apache-badbots.conf
/etc/init.d/apache2
/etc/webmin/status/services/apache.serv
/etc/webmin/apache
/etc/cron.daily/apache2
/etc/rc1.d/K09apache2
/etc/default/apache2
/etc/squirrelmail/apache.conf
/etc/rc2.d/S91apache2
/etc/bash_completion.d/apache2.2-common
/etc/rc4.d/S91apache2
/etc/logrotate.d/apache2
/etc/php5/apache2
/etc/rc0.d/K09apache2
/etc/apache2
/etc/apache2/apache2.conf.dpkg-dist
/etc/apache2/conf.d/apache2-doc
/etc/apache2/apache2.conf
/etc/apache2/apache2.conf.0

--

je suis d'accord sur l'idée de supprimer et réinstaller apache mais
apt-get remove ne fonctionne bien sur pas et je ne sais pas comment faire
merci
Sirius 911
« On n'est pas le meilleur quand on le croit, mais quand on le sait... »
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 505
Re,

Tu as quoi comme version Debian?
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 505
Re,

Essayons d'abord une réinstallation

aptitude reinstall apache2
Messages postés
269
Date d'inscription
mardi 30 janvier 2007
Statut
Membre
Dernière intervention
14 mars 2017
10
aptitude reinstall apache2
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Lecture de l'information d'état étendu      
Initialisation de l'état des paquets... Fait
Écriture de l'information d'état étendu... Fait
Lecture des descriptions de tâches... Fait     
Les paquets suivants sont CASSÉS : 
  apache2 libapache2-mod-python 
Les paquets suivants seront ENLEVÉS : 
  apache2-utils{u} cupsys-common{u} libapr1{u} libaprutil1{u} libasn1-6-heimdal{u} libaudio2{u} libcupsys2{u} libdevel-symdump-perl{u} libgssapi4-heimdal{u} libio-zlib-perl{u} 
  libkrb5-17-heimdal{u} libmng1{u} libpoppler0c2{u} libpq4{u} libqt3-mt{u} libroken16-heimdal{u} libsnmp9{u} linux-kernel-headers{u} manpages-fr-dev{u} manpages-fr-extra{u} 
  php5-common{u} postgresql-client-7.4{u} postgresql-doc-7.4{u} python-qt3{u} python-sip4{u} python2.4{u} python2.4-minimal{u} 
0 paquets mis à jour, 0 nouvellement installés, 1 réinstallés, 27 à enlever et 2 non mis à jour.
Il est nécessaire de télécharger 0o d'archives. Après dépaquetage, 80,7Mo seront libérés.
Les paquets suivants ont des dépendances non satisfaites :
  apache2: Dépend: apache2-mpm-worker (>= 2.2.9-10+lenny8) mais il n'est pas installable ou
                   apache2-mpm-prefork (>= 2.2.9-10+lenny8) mais il n'est pas installable ou
                   apache2-mpm-event (>= 2.2.9-10+lenny8) mais il n'est pas installable
  libapache2-mod-python: Dépend: apache2.2-common mais il n'est pas installable
Les actions suivantes permettront de résoudre ces dépendances :

Supprimer les paquets suivants :
apache2
libapache2-mod-python

Le score est de 188

Accepter cette solution ? [Y/n/q/?]
Y
Les paquets suivants seront ENLEVÉS : 
  apache2{a} apache2-utils{u} cupsys-common{u} libapache2-mod-python{a} libapr1{u} libaprutil1{u} libasn1-6-heimdal{u} libaudio2{u} libcupsys2{u} libdevel-symdump-perl{u} 
  libgssapi4-heimdal{u} libio-zlib-perl{u} libkrb5-17-heimdal{u} libmng1{u} libpoppler0c2{u} libpq4{u} libqt3-mt{u} libroken16-heimdal{u} libsnmp9{u} linux-kernel-headers{u} 
  manpages-fr-dev{u} manpages-fr-extra{u} php5-common{u} postgresql-client-7.4{u} postgresql-doc-7.4{u} python-qt3{u} python-sip4{u} python2.4{u} python2.4-minimal{u} 
0 paquets mis à jour, 0 nouvellement installés, 29 à enlever et 2 non mis à jour.
Il est nécessaire de télécharger 0o d'archives. Après dépaquetage, 81,3Mo seront libérés.
Voulez-vous continuer ? [Y/n/?] 
Y
Écriture de l'information d'état étendu... Fait
(Lecture de la base de données... 69939 fichiers et répertoires déjà installés.)
Suppression de libapache2-mod-python ...
/bin/rm: ne peut enlever '/var/lib/pycentral/libapache2-mod-python.pkgremove': Aucun fichier ou répertoire de ce type
dpkg : erreur de traitement de libapache2-mod-python (--remove) :
 le sous-processus pre-removal script a retourné une erreur de sortie d'état 1
Suppression de apache2-utils ...
Suppression de cupsys-common ...
Suppression de libaprutil1 ...
Suppression de libapr1 ...
Suppression de libgssapi4-heimdal ...
Suppression de libkrb5-17-heimdal ...
Suppression de libasn1-6-heimdal ...
Suppression de python-qt3 ...
Suppression de libqt3-mt ...
Suppression de libaudio2 ...
Suppression de libcupsys2 ...
Suppression de libdevel-symdump-perl ...
Suppression de libio-zlib-perl ...
Suppression de libmng1 ...
Suppression de libpoppler0c2 ...
Suppression de libpq4 ...
Suppression de libroken16-heimdal ...
Suppression de libsnmp9 ...
Suppression de linux-kernel-headers ...
Suppression de manpages-fr-dev ...
Suppression de manpages-fr-extra ...
Suppression de php5-common ...
Suppression de postgresql-client-7.4 ...
Suppression de postgresql-doc-7.4 ...
Suppression de python-sip4 ...
Suppression de python2.4 ...
Suppression de python2.4-minimal ...
Unlinking and removing bytecode for runtime python2.4
    libapache2-mod-python: 2.5 (['deinstall', 'ok', 'installed'])
    python-newt: 2.4, 2.5 (['install', 'ok', 'installed'])
    reportbug: current, >= 2.5 (['install', 'ok', 'installed'])
    python-imaging: 2.4, 2.5 (['install', 'ok', 'installed'])
    python-foomatic: all (['install', 'ok', 'installed'])
    fail2ban: current, >= 2.4 (['install', 'ok', 'installed'])
/bin/rm: ne peut enlever '/var/lib/python-support/python2.4': est un répertoire
dpkg : erreur de traitement de python2.4-minimal (--remove) :
 le sous-processus pre-removal script a retourné une erreur de sortie d'état 1
dpkg : apache2 : problème de dépendance, mais suppression comme demandé :
 libapache2-mod-python dépend de apache2 ; cependant :
  Le paquet apache2 doit être supprimé.
Suppression de apache2 ...
Traitement des actions différées (« triggers ») pour « man-db »...
Des erreurs ont été rencontrées pendant l'exécution :
 libapache2-mod-python
 python2.4-minimal
E: Sub-process /usr/bin/dpkg returned an error code (1)
Échec de l'installation d'un paquet. Tentative de réparation : 
Lecture des listes de paquets... Fait          
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Lecture de l'information d'état étendu      
Initialisation de l'état des paquets... Fait
Écriture de l'information d'état étendu... Fait
Lecture des descriptions de tâches... Fait     

État actuel : 1 paquet cassé [-1].

Messages postés
269
Date d'inscription
mardi 30 janvier 2007
Statut
Membre
Dernière intervention
14 mars 2017
10
Debian Lenny
uname -r
2.6.26-2-amd64

Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 505
Re,

dpkg -P --force-all libapache2-mod-python
dpkg -P --force-all python2.4-minimal

ensuite
aptitude update



Messages postés
269
Date d'inscription
mardi 30 janvier 2007
Statut
Membre
Dernière intervention
14 mars 2017
10
dpkg -P --force-all libapache2-mod-python

(Lecture de la base de données... 64460 fichiers et répertoires déjà installés.) 
Suppression de libapache2-mod-python ... 
/bin/rm: ne peut enlever '/var/lib/pycentral/libapache2-mod-python.pkgremove': Aucun fichier ou répertoire de ce type 
dpkg : erreur de traitement de libapache2-mod-python (--purge) : 
 le sous-processus pre-removal script a retourné une erreur de sortie d'état 1 
Des erreurs ont été rencontrées pendant l'exécution : 
 libapache2-mod-python


dpkg -P --force-all python2.4-minimal
(Lecture de la base de données... 64460 fichiers et répertoires déjà installés.) 
Suppression de python2.4-minimal ... 
Unlinking and removing bytecode for runtime python2.4 
    libapache2-mod-python: 2.5 (['purge', 'ok', 'installed']) 
    python-newt: 2.4, 2.5 (['install', 'ok', 'installed']) 
    reportbug: current, >= 2.5 (['install', 'ok', 'installed']) 
    python-imaging: 2.4, 2.5 (['install', 'ok', 'installed']) 
    python-foomatic: all (['install', 'ok', 'installed']) 
    fail2ban: current, >= 2.4 (['install', 'ok', 'installed']) 
/bin/rm: ne peut enlever '/var/lib/python-support/python2.4': est un répertoire 
dpkg : erreur de traitement de python2.4-minimal (--purge) : 
 le sous-processus pre-removal script a retourné une erreur de sortie d'état 1 
Des erreurs ont été rencontrées pendant l'exécution : 
 python2.4-minimal


aptitude update
Écriture de l'information d'état étendu... Fait 
Atteint http://ftp.fr.debian.org lenny Release.gpg 
Atteint http://ftp.fr.debian.org lenny/main Translation-fr                                                
Atteint http://ftp.fr.debian.org lenny Release                                                            
Atteint https://www.debian.org/security/ lenny/updates Release.gpg                                      
Ign https://www.debian.org/security/ lenny/updates/main Translation-fr                
Ign https://www.debian.org/security/ lenny/updates/contrib Translation-fr             
Ign http://ftp.fr.debian.org lenny/main Packages/DiffIndex                      
Atteint https://www.debian.org/security/ lenny/updates Release 
Prendre : 1 ftp://ftp.mondorescue.org 5.0 Release.gpg               
Ign http://ftp.fr.debian.org lenny/main Sources/DiffIndex                               
Ign https://www.debian.org/security/ lenny/updates/main Packages/DiffIndex                    
Ign https://www.debian.org/security/ lenny/updates/contrib Packages/DiffIndex 
Atteint http://ftp.fr.debian.org lenny/main Packages                                    
Ign https://www.debian.org/security/ lenny/updates/main Sources/DiffIndex                     
Ign https://www.debian.org/security/ lenny/updates/contrib Sources/DiffIndex                  
Atteint https://www.debian.org/security/ lenny/updates/main Packages                                        
Ign ftp://ftp.mondorescue.org 5.0 Release.gpg                                                         
Atteint http://ftp.fr.debian.org lenny/main Sources                                     
Atteint https://www.debian.org/security/ lenny/updates/contrib Packages    
Atteint https://www.debian.org/security/ lenny/updates/main Sources 
Atteint https://www.debian.org/security/ lenny/updates/contrib Sources 
Prendre : 2 ftp://ftp.mondorescue.org 5.0/contrib Translation-fr 
Ign ftp://ftp.mondorescue.org 5.0/contrib Translation-fr 
Prendre : 3 ftp://ftp.mondorescue.org 5.0 Release 
Ign ftp://ftp.mondorescue.org 5.0 Release 
Prendre : 4 ftp://ftp.mondorescue.org 5.0/contrib Packages/DiffIndex 
Ign ftp://ftp.mondorescue.org 5.0/contrib Packages/DiffIndex 
Prendre : 5 ftp://ftp.mondorescue.org 5.0/contrib Sources/DiffIndex 
Ign ftp://ftp.mondorescue.org 5.0/contrib Sources/DiffIndex 
Prendre : 6 ftp://ftp.mondorescue.org 5.0/contrib Packages 
Ign ftp://ftp.mondorescue.org 5.0/contrib Packages 
Prendre : 7 ftp://ftp.mondorescue.org 5.0/contrib Sources 
Ign ftp://ftp.mondorescue.org 5.0/contrib Sources 
Atteint ftp://ftp.mondorescue.org 5.0/contrib Packages 
Atteint ftp://ftp.mondorescue.org 5.0/contrib Sources 
Lecture des listes de paquets... Fait        






Sirius 911
« On n'est pas le meilleur quand on le croit, mais quand on le sait... »
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 505
Re,
aptitude safe-upgrade
donne quoi?
Messages postés
269
Date d'inscription
mardi 30 janvier 2007
Statut
Membre
Dernière intervention
14 mars 2017
10
aptitude safe-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Lecture de l'information d'état étendu      
Initialisation de l'état des paquets... Fait
Lecture des descriptions de tâches... Fait  
Résolution des dépendances...
Résolution des dépendances...
Les NOUVEAUX paquets suivants vont être installés : 
  apache2-mpm-worker{a} apache2-utils{a} apache2.2-common{a} libapr1{a} libaprutil1{a} 
  libbind9-50{a} libdns55{a} libisc52{a} libisccc50{a} libisccfg50{a} liblwres50{a} 
Les paquets suivants seront ENLEVÉS : 
  python2.4-minimal{u} 
Les paquets suivants seront mis à jour : 
  bind9-host dnsutils 
2 paquets mis à jour, 11 nouvellement installés, 1 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 1216ko/2630ko d'archives. Après dépaquetage, 3703ko seront utilisés.
Voulez-vous continuer ? [Y/n/?] Y
Écriture de l'information d'état étendu... Fait
Prendre : 1 https://www.debian.org/security/ lenny/updates/main libisc52 1:9.6.ESV.R1+dfsg-0+lenny2 [169kB]
Prendre : 2 https://www.debian.org/security/ lenny/updates/main libdns55 1:9.6.ESV.R1+dfsg-0+lenny2 [664kB]
Prendre : 3 https://www.debian.org/security/ lenny/updates/main libisccc50 1:9.6.ESV.R1+dfsg-0+lenny2 [29,2kB]
Prendre : 4 https://www.debian.org/security/ lenny/updates/main libisccfg50 1:9.6.ESV.R1+dfsg-0+lenny2 [51,4kB]
Prendre : 5 https://www.debian.org/security/ lenny/updates/main libbind9-50 1:9.6.ESV.R1+dfsg-0+lenny2 [32,6kB]
Prendre : 6 https://www.debian.org/security/ lenny/updates/main liblwres50 1:9.6.ESV.R1+dfsg-0+lenny2 [48,5kB]
Prendre : 7 https://www.debian.org/security/ lenny/updates/main bind9-host 1:9.6.ESV.R1+dfsg-0+lenny2 [65,4kB]
Prendre : 8 https://www.debian.org/security/ lenny/updates/main dnsutils 1:9.6.ESV.R1+dfsg-0+lenny2 [157kB]
 1216ko téléchargés en 1s (645ko/s)
(Lecture de la base de données... 64460 fichiers et répertoires déjà installés.)
Suppression de python2.4-minimal ...
Unlinking and removing bytecode for runtime python2.4
    libapache2-mod-python: 2.5 (['purge', 'ok', 'installed'])
    python-newt: 2.4, 2.5 (['install', 'ok', 'installed'])
    reportbug: current, >= 2.5 (['install', 'ok', 'installed'])
    python-imaging: 2.4, 2.5 (['install', 'ok', 'installed'])
    python-foomatic: all (['install', 'ok', 'installed'])
    fail2ban: current, >= 2.4 (['install', 'ok', 'installed'])
Traitement des actions différées (« triggers ») pour « man-db »...
Sélection du paquet libisc52 précédemment désélectionné.
(Lecture de la base de données... 64309 fichiers et répertoires déjà installés.)
Dépaquetage de libisc52 (à partir de .../libisc52_1%3a9.6.ESV.R1+dfsg-0+lenny2_amd64.deb) ...
Sélection du paquet libdns55 précédemment désélectionné.
Dépaquetage de libdns55 (à partir de .../libdns55_1%3a9.6.ESV.R1+dfsg-0+lenny2_amd64.deb) ...
Sélection du paquet libisccc50 précédemment désélectionné.
Dépaquetage de libisccc50 (à partir de .../libisccc50_1%3a9.6.ESV.R1+dfsg-0+lenny2_amd64.deb) ...
Sélection du paquet libisccfg50 précédemment désélectionné.
Dépaquetage de libisccfg50 (à partir de .../libisccfg50_1%3a9.6.ESV.R1+dfsg-0+lenny2_amd64.deb) ...
Sélection du paquet libbind9-50 précédemment désélectionné.
Dépaquetage de libbind9-50 (à partir de .../libbind9-50_1%3a9.6.ESV.R1+dfsg-0+lenny2_amd64.deb) ...
Sélection du paquet liblwres50 précédemment désélectionné.
Dépaquetage de liblwres50 (à partir de .../liblwres50_1%3a9.6.ESV.R1+dfsg-0+lenny2_amd64.deb) ...
Préparation du remplacement de bind9-host 1:9.5.1.dfsg.P3-1+lenny1 (en utilisant .../bind9-host_1%3a9.6.ESV.R1+dfsg-0+lenny2_amd64.deb) ...
Dépaquetage de la mise à jour de bind9-host ...
Préparation du remplacement de dnsutils 1:9.5.1.dfsg.P3-1+lenny1 (en utilisant .../dnsutils_1%3a9.6.ESV.R1+dfsg-0+lenny2_amd64.deb) ...
Dépaquetage de la mise à jour de dnsutils ...
Sélection du paquet libapr1 précédemment désélectionné.
Dépaquetage de libapr1 (à partir de .../libapr1_1.2.12-5+lenny2_amd64.deb) ...
Sélection du paquet libaprutil1 précédemment désélectionné.
Dépaquetage de libaprutil1 (à partir de .../libaprutil1_1.2.12+dfsg-8+lenny4_amd64.deb) ...
Sélection du paquet apache2-utils précédemment désélectionné.
Dépaquetage de apache2-utils (à partir de .../apache2-utils_2.2.9-10+lenny8_amd64.deb) ...
Dépaquetage de apache2.2-common (à partir de .../apache2.2-common_2.2.9-10+lenny8_amd64.deb) ...
Dépaquetage de apache2-mpm-worker (à partir de .../apache2-mpm-worker_2.2.9-10+lenny8_amd64.deb) ...
Traitement des actions différées (« triggers ») pour « man-db »...
Paramétrage de libisc52 (1:9.6.ESV.R1+dfsg-0+lenny2) ...
Paramétrage de libdns55 (1:9.6.ESV.R1+dfsg-0+lenny2) ...
Paramétrage de libisccc50 (1:9.6.ESV.R1+dfsg-0+lenny2) ...
Paramétrage de libisccfg50 (1:9.6.ESV.R1+dfsg-0+lenny2) ...
Paramétrage de libbind9-50 (1:9.6.ESV.R1+dfsg-0+lenny2) ...
Paramétrage de liblwres50 (1:9.6.ESV.R1+dfsg-0+lenny2) ...
Paramétrage de bind9-host (1:9.6.ESV.R1+dfsg-0+lenny2) ...
Paramétrage de dnsutils (1:9.6.ESV.R1+dfsg-0+lenny2) ...
Paramétrage de libapr1 (1.2.12-5+lenny2) ...
Paramétrage de libaprutil1 (1.2.12+dfsg-8+lenny4) ...
Paramétrage de apache2-utils (2.2.9-10+lenny8) ...
Paramétrage de apache2.2-common (2.2.9-10+lenny8) ...
Paramétrage de apache2-mpm-worker (2.2.9-10+lenny8) ...
Starting web server: apache2apache2: Syntax error on line 192 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/perl.load: Cannot load /usr/lib/apache2/modules/mod_perl.so into server: /usr/lib/apache2/modules/mod_perl.so: cannot open shared object file: No such file or directory
 failed!
invoke-rc.d: initscript apache2, action "start" failed.
Lecture des listes de paquets... Fait          
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Lecture de l'information d'état étendu      
Initialisation de l'état des paquets... Fait
Écriture de l'information d'état étendu... Fait
Lecture des descriptions de tâches... Fait     

État actuel : 0 paquet cassé [-1], 0 mise à jour restante [-2].

Messages postés
269
Date d'inscription
mardi 30 janvier 2007
Statut
Membre
Dernière intervention
14 mars 2017
10
j'ai plus de problème sur apt-get upgrade
dois-je ré-installé apache maintenant ?
et comment ?
par apt-get install apache2 ou par aptitude ?
j'ai toujours utilisé apt-get, je ne connais pas aptitude
merci en tous les cas lamy 20j
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 505
Re,

Continue avec apt-get pour voir


GNU/Linux:Linux is Not Ubuntu! Quel linux choisir ne veut pas dire votre Distribution préférée,
106485010510997108