Recherchev sur 2 feuilles

[Résolu/Fermé]
Signaler
Messages postés
32
Date d'inscription
vendredi 8 décembre 2006
Statut
Membre
Dernière intervention
4 mars 2009
-
Messages postés
54518
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
30 août 2021
-
Bonjour,voila, dans le classeur excel,j'ai sur la feuille2 une grille de données , c'est une correspondance entre chiffre et frequence, dans la 1er colonne il ya des chiffres, 1 a 21 et dans la 2me colonne de frequences allant de 1.1 a 1 en 21 palier aussi. Sur la feuille1, j'ai une cellule D83 dans laquel je dois mettre l'un des 21 chiffres ( de 1 a 21) et les resultat de la recherche doit se trouvé dans la cellule E83, freq correspondante de 0.1 a 1 ( c'est pas linéair).qlq peut-il m'aider?

5 réponses

Messages postés
26144
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
29 août 2021
6 031
Bonjour


Je crois important de préciser en règle gènèrale que pour ce qui est de la fonction RECHERCHE telle qu'elle est libellé dans vos exemples et recommandations, elle ne focnctionne que si les données de la colonne de recherche sont triées par ordre croissant.
Pour la faire fonctionner correctemment avec une colonne non triée, il faut la complèter (juste avant la dernière parenthèse) avec soit ;0 soit ;FAUX

Auquel cas le classement n'a plus d'importance.

Ceci dit, la réponse que vous avez donnée, Raymond et g, correspond bien entendu parfaitement à la demande en l'état.

Crdlmnt
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
1263
Date d'inscription
vendredi 23 avril 2004
Statut
Membre
Dernière intervention
15 mai 2017
570
Ce n'est pas FAUX cela, Vaucluse.....

:-))
Messages postés
1263
Date d'inscription
vendredi 23 avril 2004
Statut
Membre
Dernière intervention
15 mai 2017
570
Bonjour,

E83=RECHERCHEV(D83;Feuil2!A1:B21;2)

Bonne journée.
Messages postés
54518
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
30 août 2021
16 451
Fonction RECHERCHEV()
Messages postés
54518
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
30 août 2021
16 451
feuil2 > Les chiffres étant en B3:B23, nommer cette plage "chiffre".
Les fréqiuences étant en C3:C23, nommer la plage B3:C23 "matrice"

feuil1 > En E83 saisir =RECHERCHEV(D83;matrice;2)

https://www.cjoint.com/?kFqRScp71b
Messages postés
447
Date d'inscription
mercredi 29 août 2007
Statut
Membre
Dernière intervention
19 janvier 2021
6
bonjour, la formule RECHERCHEV que tu m'as donnée fonctionne, mais, j'avais a cette place, enfin dans cette cellule un nombre exemple 1.6 ) qui etait repris par une fonction logique =SI(E85>=1.6;"ok") ça marche plus car c'est remplacé par la formule RECHERCHEV.Il y a un remède a cela?
Messages postés
54518
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
30 août 2021
16 451 >
Messages postés
447
Date d'inscription
mercredi 29 août 2007
Statut
Membre
Dernière intervention
19 janvier 2021

Qu'est-ce qui "ne marche plus" ? Je ne comprends pas !
Ne s'agirait-il pas d'une simple question de virgule, 1.6 au lieu de 1,6 ?
Messages postés
447
Date d'inscription
mercredi 29 août 2007
Statut
Membre
Dernière intervention
19 janvier 2021
6 >
Messages postés
54518
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
30 août 2021

bonjour, je ne pense pas qu'il s'agisse de point ou virgule, seulement , la cellue ou se trouvait un nombre(1.6) par exemple a été remplacée par la formule RECHERCHEV,qui marche très bien, a part ce détail. J'ai trouvé la parade et maintenant, ca fonctionne complètement, MERCI et bonne journée.
Messages postés
54518
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
30 août 2021
16 451 >
Messages postés
447
Date d'inscription
mercredi 29 août 2007
Statut
Membre
Dernière intervention
19 janvier 2021

OK ! Parfait.
Messages postés
32
Date d'inscription
vendredi 8 décembre 2006
Statut
Membre
Dernière intervention
4 mars 2009
1
bonjour, merci pour ces infos, je vais mettre cela en pratique, bonne journée