Bridge wifi mandriva 2008.1 [Fermé]

Signaler
Messages postés
673
Date d'inscription
samedi 30 avril 2005
Statut
Membre
Dernière intervention
6 juin 2017
-
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
-
Bonjour à tous.
Je voudrais créer un point d'accés internet avec une carte wifi installer sur mon PC fixe. J'ai déja réalisé l'opération sous mandriva 2007.0 http://www.commentcamarche.net/forum/affich 2962546 partage de connexion via wifi mais la impossible.
J'ai partager ma connexion grâce au outils graphique puis j'ai configuré le essid et le mode de ma carte mais voila le résultat :
# iwconfig
lo no wireless extensions.

eth1 no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11g ESSID:""
Mode:Ad-Hoc Frequency:2.412 GHz Cell: Not-Associated
Tx-Power=20 dBm
Retry min limit:7 RTS thr:off Fragment thr=2346 B
Encryption key:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

sit0 no wireless extensions.

Comment attibuer l'adresse IP, le masque, les outils mandriva ont changé et je n'arrive plus a rien.
Merci de votre aide.

6 réponses

Messages postés
673
Date d'inscription
samedi 30 avril 2005
Statut
Membre
Dernière intervention
6 juin 2017
41
Je rajoute un détail.
Je n'est pas de route pour le partage de ma connexion
# route
Table de routage IP du noyau
Destination Passerelle Genmask Indic Metric Ref Use Iface
192.168.0.0 * 255.255.255.0 U 10 0 0 eth1
link-local * 255.255.0.0 U 10 0 0 eth1
default 192.168.0.1 0.0.0.0 UG 10 0 0 eth1



de plus :
# route add -net 192.168.0.0 netmask 255.255.255.0 dev wlan0
SIOCADDRT: Le réseau ne fonctionne pas.

merci de votre aide
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 543
Salut,

As-tu essayé ça http://club.mandriva.com/ ?
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 543
Re,

il me semble que les fichiers de configuration tu les trouves dans /etc/sysconfig/network-scripts/
Messages postés
673
Date d'inscription
samedi 30 avril 2005
Statut
Membre
Dernière intervention
6 juin 2017
41
Merci pour vos réponse. Je crois que je me suis embalé. Il faut que je configure bien ma carte avant de router quoi que ce soit. Je ne pense pas avoir le bon pilote et le petit lien lami20j me parait fort bien. Je voit cela demain.
Merci à tous et bonne nuit.
Messages postés
673
Date d'inscription
samedi 30 avril 2005
Statut
Membre
Dernière intervention
6 juin 2017
41
Bonjour a tous.
J'ai bien avancé sur mon histoire donc voila les étapes que j'ai réalisé et ce qui me reste a faire.
J'ai trouver les pilote cette adresse http://rt2x00.serialmonkey.com/wiki/index.php/Main_Page.
Mandriva ne donne pas les bon pilote et/ou firmware(rt61pci).
une fois l'archive télécharger il faut extraire les fichiers, aller dans le dossier Modules puis compiler et installer :
#tar -xvzf rt61-cvs-daily.tar.gz
#cd ./rt61-cvs-2008081605/Module
#make
#make install

ensuite on vérifie l'installation en chargent le module
#modprobe rt61

Pour charger le module au démarrage on ajoute la ligne "rt61" dans le fichier /etc/modules ce qui donne simplement
# /etc/modules: kernel modules to load at boot time.
#
# This file should contain the names of kernel modules that are
# to be loaded at boot time, one per line. Comments begin with
# a `#', and everything on the line after them are ignored.
rt61


Voila pour le pilote.

Ma table de routage ressemble à présent à cela. Je ne peux pas dire comment faire car j'ai fait une partie en ligne de commande mais je crois que l'outil graphique de mandriva me l'a modifier.
Table de routage IP du noyau
Destination Passerelle Genmask Indic Metric Ref Use Iface
192.168.1.0 * 255.255.255.0 U 30 0 0 wlan0
192.168.0.0 * 255.255.255.0 U 10 0 0 eth1
link-local * 255.255.0.0 U 10 0 0 eth1
link-local * 255.255.0.0 U 30 0 0 wlan0
default 192.168.0.1 0.0.0.0 UG 10 0 0 eth1


JE configure ma carte wifi en ad-hoc et je lui rentre le nom du réseau
#iwconfig wlan0 mode ad-hoc
#iwconfig wlan0 essid nom_du_reseau


Il me reste un problème, c'est au redémarrage, ma configuration de la carte wifi est perdu. Si vous avez la solution merci d'avance.

NB : J'espère ne pas dire trop de bêtises.
Messages postés
673
Date d'inscription
samedi 30 avril 2005
Statut
Membre
Dernière intervention
6 juin 2017
41
RE
J'ai effectivement configuré ma carte comme tu l'as présiser plus haut dans /etc/sysconfig/network-scripts/
Pour plus d'info j'ai été voir le man ifcfg. La carte est donc bien configuré au démarrage.
Merci de ton aide.
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 543
Salut,

ben de rien, même si je n'ai rien fait moi ;-)