Connexion à SQL Server 2000

Résolu
Bonjour,

slt j'ai un blème: j'ai créer des utilisateurs dans ma base SQL server 2000 de la manière suivante:

création du login
EXEC sp_addlogin @login, @pwd, 'GESEC_BD'

création du user
EXEC sp_adduser @login, @nom, @role


je rappelle que @login, @nom, @pwd, @role sont des paramètres de mes procédures stockée create_users et create_login renseignés par l'administrateur à traavers une interface vb.

La création se fait normalement dans mon moteur SQL Server 2000, mais le hic c'est que lorsque je veux l'utiliser pour me connecter j'ai le message d'erreur suivant: Login failed for users 'XXX' (XXX=@login)

NB: j'ai le mode d'authentification mixte.
Configuration: Windows Vista
Internet Explorer 7.0

2 réponses

  1. Merci à tous, mais j'ai trouvé la solution.

    En fait mon probléme se trouvait au niveau de mon code vb, il a une variable qui est chargée d'alimenter le parametre mot de passe dans ma procédure stoickée de création de login (@pwd). c'est elle qui recevait une mauvaise valeur.

    Encore merci
    0
    1. tu peux nous donner le code qui permet la connexion?
      tout..
      merci
      0