Erreur ora 12638 apres migration [Résolu/Fermé]

Signaler
Messages postés
12
Date d'inscription
vendredi 4 juillet 2008
Statut
Membre
Dernière intervention
1 août 2008
-
 BigOne -
Bonjour,
Je viens de rentrer des postes en domaine, sans problemes
sauf une erreur ORA 12638extraction des preferences utilisateurs impossibles
Quelqu'un connait il ce probleme?
merci

11 réponses

Messages postés
12
Date d'inscription
vendredi 4 juillet 2008
Statut
Membre
Dernière intervention
1 août 2008
10
Pour info,
J'ai résolu mon probleme (connu chez Oracle, sous windows)
Sur les poste clients, modofier le fichier c:\oracle\ora81\network\admin\sqlnet.ora
SQLNET.AUTHENTICATION_SERVICES=(NTS) en
SQLNET.AUTHENTICATION_SERVICES=(NONE)

et tout va bien.....
10
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60769 internautes nous ont dit merci ce mois-ci

Nickel merci !
Merci beaucoup, même si j'arrive 4 ans après votre aide.
Merci, fonctionne toujours
Merci beaucoup ca marche meme sur une version 11g
Grand merci pour le coup de pouce. je venais d'avoir ce problème mais grace à toi, je m'en suis bien tiré

Big One
Messages postés
19
Date d'inscription
samedi 10 mars 2007
Statut
Membre
Dernière intervention
25 mai 2013
4
Excellent ça m'a bien dépannée !

J'ai 2 sites web sur un même serveur IIS de test. Ils accèdent à une même base de données Oracle sur un autre serveur dans un autre domaine. Même chaine de connection, même utilisateur...

Sur mon site A la connection oracle se faisait, alors que mon site B affichait l'erreur de connection ORA-12638 !

Après mûres réflexions, j'ai fini par comprendre d'où venait le problème. Mon site A ne requiert par d'authentification, et le site B si. Et pourquoi diable le site web utilise le fichier sqlnet.ora de son client (ça je n'ai toujours pas compris) mais le fait est que de changer l'authentification NTS en NONE dans sqlnet.ora comme expliqué ci-dessus a fonctionné (après redémarrage du serveur sur lequel se trouve IIS) et je n'ai plus d'erreur.

Pour info le path change selon les versions d'oracle : sqlnet.ora se touve dans \oracle\product\10.2.0\client_1\NETWORK\ADMIN\
Merci beacoup,
ça m'a résoulu le problème .
C'est nul Ca marche pas !
Merci ça marche nickel
c ok pour moi
Comme on le dit chez nous, c'est propre
Merci mon frère
ça marche !
Merci pour ton aide précieuse.
Parfait!
Merci pour la solution Brève, Claire, EFFICACE !!!
Merci beaucoup pour cette réponse qui fonctionne aussi sous Oracle 11 !
J'ai effectivement corrigé le problème avec cette astuce. Cependant, j'avais installé oracle sur un autre disque et j'ai du modifié le fichier qui se trouvait dans : D:\app\xx\product\11.2.0\dbhome_2\NETWORK\ADMIN
Merci pour votre aide.