Bug sous Firefox 3 (javascript) [Résolu/Fermé]

Signaler
Messages postés
308
Date d'inscription
dimanche 8 juin 2008
Statut
Membre
Dernière intervention
28 octobre 2010
-
Messages postés
308
Date d'inscription
dimanche 8 juin 2008
Statut
Membre
Dernière intervention
28 octobre 2010
-
Bonjour,
Je ne comprends pas pourquoi j'ai avec une fonction javascript qui sous Firefox 3 ne peut pas se déclencher. La console d'erreurs m'indique que
mousemove_ is not defined
. Cette fonction se déclenche lorsque la sourie bouge (attribut mousemove=).

Voici l'adresse : http://benvii.e3b.org/dvp%20Benvii%202/dvp%20Bulles/test.html
Voici le fichier .js : http://benvii.e3b.org/dvp%20Benvii%202/dvp%20Bulles/fe.js

Benvii

4 réponses


Salut, je me demande si Firefox 3 n'est pas "trop nouveau"... Il y a pas mal de petites imperfections encore. Sur certains sites ça n'est pas encore top. Moi j'attendrais encore un peu et je préférerais rendre un site pleinement compatible Firefox 2 avant tout.
Messages postés
5358
Date d'inscription
dimanche 3 février 2008
Statut
Membre
Dernière intervention
13 février 2017
886
Si la console te dit ça c'est que ta fonction pose pb:

function mousemove_(ev)
{
if(fenetre_deplacee!=0) { mouve_fe(ev); }
if(fe_change_size!=0) { rezize(ev) }
var mouse=mouseCoords(ev);
document.getElementById("coorX").value=mouse.x;
document.getElementById("coorY").value=mouse.y;
}


regardes tous tes parametres
Messages postés
489
Date d'inscription
samedi 23 juin 2007
Statut
Membre
Dernière intervention
19 juin 2011
213
A noter aussi que le déclenchement d'une erreur est souvent dûe à une erreur précédente... Si tu regardes bien ta console, tu verras que la première erreur se situe au niveau de la l'instruction "var navigator=navigator.appName;" (erreur déclenchée aussi sous Internet Explorer).

Tu devrais d'abord résoudre cette erreur avant de résoudre les suivantes... les erreurs étant généralement présentées dans leur ordre d'apparition.
Messages postés
308
Date d'inscription
dimanche 8 juin 2008
Statut
Membre
Dernière intervention
28 octobre 2010
133
Bonjour,
Merci mon problème est résolue j'avais nommée ma variable navigator alors que la constant navigator existe aussi.

Benvii