ERREUR MySQL ??? oO

Résolu
Bonjour,

j'ai un petit souci avec ma base de données que j'essaye de créer mais à priori ça veut pas créer la Table...

le message d'erreur est le suivant :

#1064 - Erreur de syntaxe pr�s de '' bt_categories ' (
'id' mediumint(8) unsigned NOT NULL auto_' � la ligne 1

Quelqu'un peut-il m'aider à corriger cette erreur svp ?
voici le code complet pour créer ma Table :

 CREATE TABLE ' bt_categories '(
'id'mediumint( 8 ) unsigned NOT NULL AUTO_INCREMENT ,
'code'varchar( 20 ) NOT NULL default '',
'libel'varchar( 200 ) NOT NULL default '',
'langue'char( 2 ) NOT NULL default 'fr',
'description'text NOT NULL ,
'keywords'text NOT NULL ,
PRIMARY KEY ( 'id' ) ,
KEY 'libel'( 'libel' ) ,
KEY 'langue'( 'langue' ) ,
KEY 'code'( 'code' )
) ENGINE = MYISAM DEFAULT CHARSET = latin1 


merci pour vos réponses rapides ;)
Configuration: Windows XP
Firefox 2.0.0.13

5 réponses

  1. Salut

    pour ta clef primaire :'id'mediumint( 8 ) unsigned NOT NULL AUTO_INCREMENT ,

    utilise un int classique, ça devrait etre mieu
    0
    1. toujours le même problème.

      j'ai vérifié la version du code que je possède ainsi que la version de mon PHP et c'est la même : 4.3.10

      j'utilise la version d'EasyPHP 1.8.

      que faire de plus ?
      0
  2. Salut,

    Essaye d'enlever les espaces avant et après bt_categories (écrit '*****' a la place de ' *** ')
    0
    1. IDEM ça ne change rien :((
      0
  3. Contributeur
    CREATE TABLE `bt_categories` (
      `id` mediumint(8) unsigned NOT NULL AUTO_INCREMENT ,
      `code` varchar(20) NOT NULL default '',
      `libel` varchar(200) NOT NULL default '',
      `langue` char(2) NOT NULL default 'fr',
      `description` text NOT NULL ,
      `keywords` text NOT NULL ,
      PRIMARY KEY (`id`) ,
      KEY `libel`(`libel`) ,
      KEY `langue`(`langue`) ,
      KEY `code`(`code`)
    ) ENGINE = MYISAM DEFAULT CHARSET = latin1
    0
    1. Contributeur
      c'est un problème de caractère : ` (touche altgr+7) à la place de ' (touche 4) .
      0
      1. bon en fait j'ai résolu le problème... au lieu de l'importer je l'ai créer sur ma base de données et ça marche :/
        Bizarre quand même cette affaire ^^.

        merci pour vos réponses quand même chers amis du webmastering ;)
        0