Debian 4.0r3 (Etch) + Canon S500 + Samba

Fermé
raakhbaba Messages postés 44 Date d'inscription samedi 29 décembre 2007 Statut Membre Dernière intervention 13 novembre 2018 - 10 mars 2008 à 17:18
 raakhbaba - 11 mars 2008 à 12:44
Bonjour,

J'ai installé Debian(4.0r3 (Etch)) en dual-boot Wxp. Un coup j'ai deux Wxp en réseau (avec une Canon
S500 connectée en || sur mon ordinateur) ; un autre, mon ordinateur Linux avec Wxp.

Aujourd'hui installation de la Canon (cupsys, cupsys-bsd, cupsys-client, foomatic-bin, gs-esp, a2ps) avec une sortie plus que correcte de la page de test (avec le pilote bj8pa06n.upp).

Merci au Guide du partage...Linux et...Ms Win... de Ian Ward, Vincent Chartier, Claude Thomassin et au relecteur Jean-Philippe Guérard.

Pourquoi ne pas configurer Samba pour partager la Canon ? Ma compagne n'aimant pas trop les contraintes je vais autoriser un accès anonyme par cette ligne : /usr/sbin/adduser --system --disabled-password smbprint (Je vous garde au chaud les modifications de -smb.conf et trois fichiers cups). Le résultat...

Dans le groupe "grp" ma machine est reconnue de type Windows NT 4.9 server.

Je vois l'ordinateur de ma femme et même ce qu'elle m'offre "informatiquement" en partage.

Je m'approche de sa machine pour lui offrir le pilote de la S500 (pour Wxp...), imprimante que je vois mais qui ne veut pas sortir la page de test (accès refusé, connexion impossible).

Question 1 : comment dépanner ? Avais-je quelque chose de plus à configurer sur la machine Windows ?

Question 2 : comme j'ai gardé les fichiers de configuration d'origine je peux réinstaller Samba en le configurant avec un accès sécurisé par mot de passe (ce serait bien quand même). Mais que dois-je faire dans ce cas pour annuler l'accès anonyme que j'ai autorisé pour le groupe smbprint ?

Merci de m'avoir lu.

raakhbaba
A voir également:

1 réponse

Bonjour,

Pour vous aider à m'aider j'ai relevé les logs et quelques autres renseignements.

Je crois que j'ai fait un beau mélange.

Quand je regarde les imprimantes sur lyne (l'ordinateur Wxp connecté au mien qui est en dual-boot) il y en a deux partagées à partir de mon ordinateur, dont celle sur paul-deb (comme Debian) dont l'état est – Accès refusé. Connexion impossible – (l'autre - Connexion impossible – ce qui me semble normal puisque je suis en Debian).

J'ai ajouté à la fin quelques lignes sur la composition de ce petit réseau (j'ai modifié les noms des éléments du réseau en faisant attention à respecter la casse, y compris dans les logs (peut-être trop parano ?)).

J'ai du mal à m'y retrouver en ce qui concerne l'adressage car j'ai un routeur qui s'en occupait et maintenant le Dhcp...

=============== Les logs

log.lyne

[2008/03/11 10:59:45, 0] auth/auth_util.c:create_builtin_administrators(785)
create_builtin_administrators: Failed to create Administrators
[2008/03/11 10:59:45, 0] auth/auth_util.c:create_builtin_users(751)
create_builtin_users: Failed to create Users
[2008/03/11 10:59:45, 0] auth/auth_util.c:create_builtin_administrators(785)
create_builtin_administrators: Failed to create Administrators
[2008/03/11 10:59:45, 0] auth/auth_util.c:create_builtin_users(751)
create_builtin_users: Failed to create Users
[2008/03/11 10:59:48, 0] lib/util_sock.c:write_data(562)
write_data: write failure in writing to client 192.168.2.103. Error Connection reset by peer
[2008/03/11 10:59:48, 0] lib/util_sock.c:send_smb(769)
Error writing 4 bytes to client. -1. (Connection reset by peer)
[2008/03/11 11:00:05, 0] lib/util_sock.c:write_data(562)
write_data: write failure in writing to client 0.0.0.0. Error Connection reset by peer
[2008/03/11 11:00:05, 0] lib/util_sock.c:send_smb(769)
Error writing 4 bytes to client. -1. (Connection reset by peer)

log.192.168.2.103

[2008/03/11 11:13:31, 0] auth/auth_util.c:create_builtin_users(751)
create_builtin_users: Failed to create Users
[2008/03/11 11:13:31, 0] auth/auth_util.c:create_builtin_administrators(785)
create_builtin_administrators: Failed to create Administrators
[2008/03/11 11:13:31, 0] auth/auth_util.c:create_builtin_users(751)
create_builtin_users: Failed to create Users
[2008/03/11 11:15:57, 0] printing/printing.c:print_job_start(2404)
print_job_start: insufficient permissions to open spool file /home/smbprint/smbprn.00000020.7XgK7M.
[2008/03/11 11:16:58, 0] auth/auth_util.c:create_builtin_administrators(785)
create_builtin_administrators: Failed to create Administrators
[2008/03/11 11:16:58, 0] auth/auth_util.c:create_builtin_users(751)
create_builtin_users: Failed to create Users
[2008/03/11 11:16:58, 0] auth/auth_util.c:create_builtin_administrators(785)
create_builtin_administrators: Failed to create Administrators
[2008/03/11 11:16:58, 0] auth/auth_util.c:create_builtin_users(751)
create_builtin_users: Failed to create Users
[2008/03/11 11:16:58, 0] auth/auth_util.c:create_builtin_administrators(785)
create_builtin_administrators: Failed to create Administrators
[2008/03/11 11:16:58, 0] auth/auth_util.c:create_builtin_users(751)
create_builtin_users: Failed to create Users
[2008/03/11 11:16:58, 0] auth/auth_util.c:create_builtin_administrators(785)
create_builtin_administrators: Failed to create Administrators
[2008/03/11 11:16:58, 0] auth/auth_util.c:create_builtin_users(751)
create_builtin_users: Failed to create Users

log.192.168.2.104 rien

log paul-deb

[2008/03/10 15:12:21, 0] auth/auth_util.c:create_builtin_administrators(785)
create_builtin_administrators: Failed to create Administrators
[2008/03/10 15:12:21, 0] auth/auth_util.c:create_builtin_users(751)
create_builtin_users: Failed to create Users
[2008/03/10 15:12:21, 0] auth/auth_util.c:create_builtin_administrators(785)
create_builtin_administrators: Failed to create Administrators
[2008/03/10 15:12:21, 0] auth/auth_util.c:create_builtin_users(751)
create_builtin_users: Failed to create Users

log nmbd

[2008/03/10 21:25:21, 0] nmbd/nmbd.c:terminate(58)
Got SIGTERM: going down...
[2008/03/11 08:31:01, 0] nmbd/nmbd.c:main(699)
Netbios nameserver version 3.0.24 started.
Copyright Andrew Tridgell and the Samba Team 1992-2006
[2008/03/11 08:31:02, 0] nmbd/nmbd_subnetdb.c:create_subnets(190)
create_subnets: No local interfaces !
[2008/03/11 08:31:02, 0] nmbd/nmbd_subnetdb.c:create_subnets(191)
create_subnets: Waiting for an interface to appear ...
[2008/03/11 08:36:50, 0] nmbd/nmbd_become_lmb.c:become_local_master_stage2(396)

*

Samba name server PAUL-DEB is now a local master browser for workgroup TOIMOI on subnet 192.168.2.104

*

[2008/03/11 08:36:50, 0] nmbd/nmbd_browsesync.c:find_domain_master_name_query_fail(351)
find_domain_master_name_query_fail:
Unable to find the Domain Master Browser name TOIMOI<1b> for the workgroup TOIMOI.
Unable to sync browse lists in this workgroup.
[2008/03/11 08:51:51, 0] nmbd/nmbd_browsesync.c:find_domain_master_name_query_fail(351)
find_domain_master_name_query_fail:
Unable to find the Domain Master Browser name TOIMOI<1b> for the workgroup TOIMOI.
Unable to sync browse lists in this workgroup.

/.../

[2008/03/11 11:22:42, 0] nmbd/nmbd_browsesync.c:find_domain_master_name_query_fail(351)
find_domain_master_name_query_fail:
Unable to find the Domain Master Browser name TOIMOI<1b> for the workgroup TOIMOI.
Unable to sync browse lists in this workgroup.

log smbd

[2008/03/10 19:54:37, 0] param/loadparm.c:lp_do_parameter(3446)
Global parameter guest account found in service section!
[2008/03/10 19:54:37, 0] param/loadparm.c:lp_do_parameter(3446)
Global parameter unix charset found in service section!
[2008/03/11 08:31:02, 0] smbd/server.c:main(847)
smbd version 3.0.24 started.
Copyright Andrew Tridgell and the Samba Team 1992-2006
[2008/03/11 08:31:02, 0] param/loadparm.c:map_parameter(2698)
Unknown parameter encountered: "use client drivers"
[2008/03/11 08:31:02, 0] param/loadparm.c:lp_do_parameter(3428)
Ignoring unknown parameter "use client drivers"
[2008/03/11 08:31:02, 0] param/loadparm.c:lp_do_parameter(3446)
Global parameter guest account found in service section!
[2008/03/11 08:31:02, 0] param/loadparm.c:lp_do_parameter(3446)
Global parameter unix charset found in service section!
[2008/03/11 11:00:05, 0] lib/util_sock.c:get_peer_addr(1229)
getpeername failed. Error was Transport endpoint is not connected
[2008/03/11 11:00:05, 0] lib/util_sock.c:get_peer_addr(1229)
getpeername failed. Error was Transport endpoint is not connected

=========================

La machine sur Etch est paul-deb
Le seul utilisateur est paul

host.conf multi on
host.name paul-deb

hosts 127.0.0.1
127.0.1.1
paul-deb.toimoi paul-deb

mailname paul-deb.toimoi

networks default 0.0.0.0
loopback 127.0.0.0
link-local 169.254.0.0

resolv.conf nameserver 192.168.2.1

shadow smbprint pas de dollar car j'ai dit pas de mot de passe

Machine Win Xp en dual boot

Etat de connexion au réseau local

Support : adresse attribuée par dhcp 192.168.2.104
Masque de sous-réseau 255.255.255.0
Passerelle par défaut 192.168.2.1

Voir les ordinateurs du groupe de travail (icône avec 3 ordinateurs -> Toietmoi (T pas t) –

commentaire

lui (Pol) lui
elle (Lyne) elle (dont l'Ip est 192.168.2.103)

Dans propriété : lui (Pol) fait partie de groupe de TOIMOI (d'ailleurs dans smb.conf workgroup = TOIMOI)

==================

Dans smb.conf où faut-il mettre cette ligne : unix charset=ISO8859-1 (pour le jeu de caractères employé (sous Linux) dans les noms de fichiers (le défaut serait UTF8) selon Hertzog et Mas dans Debian Etch pages 242-243) ?

J'avais sous Xp comme nom de groupe TOIMOI
A la configuration de Etch j'ai donné le nom de domaine toimoi
et comme nom de workgroup TOIMOI

En pensant que Xp comme Linux tenait compte de la casse. Ceci dit nous voyons que Xp met parfois une majuscule là où on le lui a pas demandé (plus haut à - Voir les ordinateurs du groupe de travail -) ; idem, sur (Lyne) quand je regarde les favoris réseau, il écrit paul-deb server (Paul-deb).

Comment le routeur et le dhcp sur Linux communiquent-ils ?

Beaucoup d'erreurs je suppose.

Merci de prendre le temps de lire ceci.

Et bonne journée

raakhbaba

Configuration: Debian 4.0r3 Etch + Epiphany
Windows XP + Firefox 3 Beta 3.