Limiter nbr caractere cellule + couleur excel [Résolu/Fermé]

Signaler
-
 dezie -
Bonjour,

Pouvez vous m'aider svp???????????,
Je vous explique :

Je doit mettre en rouge les cellules qui depassent 38 caractere dans une base de donnée d'excel.
sachant qu'avec "mise en forme conditionnelle" je n'arrive pas a limiter le nombre de caractere, pareil pour la fonction si, et avec "données / validation..." je n'arive pas a insérer une couleur

Merci de m'aider c'est urgent!!!

2 réponses

Messages postés
25718
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
30 décembre 2020
5 690
Bonsoir
En principe, avec la mise en forme conditionnelle, vous n'avez pas besoin de la fonction si:
Il suffira de choisir l'option "formule " de la mise en forme et d'y placer la formule qui vous interresse, dans ce cas pour la celulle A1
=NBCAR(A1)>38
Choisir votre format, fermer par OK
A noter qu'avec le menu données / validation, vous pouvez non pas changer la couleur, mais passer un message d'avertissement quand le texte est trop long:
Données / Validation / Longueur du texte/ Mini 0 / Maxi 38
Cliquer sur l'onglet alerte d'erreur et choisir au lieu de arrêt: information ou message d'alerte.
Rentrer le titre (par exemple ATTENTION) et le texte (Par exemple "texte trop long")
Et fermer par OK
BCRDLMNT
13
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 66686 internautes nous ont dit merci ce mois-ci

merci beaucou pr votre reponse ossi!! je vais essayer vos deux solutions en espérant que ca marche!!
je vous tiens o courant!!
merciiiiiiiiiiiiiiiiiiiiiiiii!
oui merci!!!!!!!!!!!!! j'ai enfin reussie!!!
c'est exactement ce que je voulai!!


encore merci pour votre aide!
Messages postés
433
Date d'inscription
dimanche 17 février 2008
Statut
Membre
Dernière intervention
17 octobre 2008
301
Salut Dezie,
il faudra pourtant utiliser une mise en fome conditionnelle avec une fonction SI (formule) :
=SI(NBCAR(A1)>38;VRAI;FAUX)
puis appliquer la mise en forme

à ta disposition,
I.
merci beaucou our votre reponse rapidde!! je vais essayer