Excel 2007 obtenir validation sous condition [Résolu/Fermé]

Signaler
-
 john_johnk -
Bonjour,
Bonjour,
J'ai deux cellules A1 et B1.
Dans la cellule A1, j'ai une validation des données qui fait référence à une plage de données "maliste" qui contient {item1, item2, item3}.
j'aimerai avoir dans la cellule B1 une validation des données qui me crée une liste différente en fonction du choix opéré dans la liste de la cellule A1;
Par exemple, ma liste dans la cellule A1 est composée de {item1, item2, item3}.
Dans la cellue B1, je voudrai qu'il s'affiche SI "item1" dans cellule A1, "liste1" dans cellule B1;
Si "item2 dans cellule A1, "liste2 dans cellule B1; Si "item3" dans cellule A1, "liste3" dans cellule B1.
Je bidouille un peu sous Excel, mais je n'arrive pas à ecrire une fonction SI dans la "source" de la boite de validation des données sous l'onglet liste. Quelqu'un peut-il m'expliquer comment dois-je faire? Merci

4 réponses

Messages postés
16600
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
13 octobre 2020
9 802
Bonjour Paninak,

Il faut que tu mettes la formule dans la boîte de dialogue Validation :
=SI(A1="item1";liste1;SI(A1="item2";liste2;SI(A1="item3";liste3;liste4)))

Cet exemple mettra la liste nommée liste1 si le choix dans la cellule A1 est "item1"
mettra la liste nommée liste2 si le choix dans la cellule A1 est "item2"
etc.

m@rina
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Merci beaucoup, M@rina, ça marche et c'est exactement ce que je voulais
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Merci M@rina, t'es un ange, ça fait deux foix que tu m'aides. Je vais essayer ça. Je ne sais pas non plus comment on fait pour clore la discution. Merci encore
Bonjour,

Merci bcp la solution m'a également aidé. J'ai cependant un pb légèrement différent: je souhaite en effet que si cellule A1= " bonjour" alors la cellule B1 affiche la liste_5 mais si cellule A1 <> " bonjour" alors B1= 0%

Je ne souhaite pas que la cellule B1 affiche une liste si A1 est différente de bonjour mais je ne sais pas comment faire.

Merci pour votre aide.

Cdt,