Fonction Somme.Si.Ens avec plage de dates

Résolu
CBRiste31 Messages postés 53 Date d'inscription vendredi 8 août 2008 Statut Membre Dernière intervention 6 juin 2024 - 5 juin 2024 à 20:58
Le Pingou Messages postés 12116 Date d'inscription mercredi 11 août 2004 Statut Contributeur Dernière intervention 4 juillet 2024 - 6 juin 2024 à 11:06

Bonjour,

Je suis à la recherche d'une solution pour utiliser correctement une fonction Somme.Si.Ens; tenant compte de 2 critères:

  1. La référence
  2. Une plage de dates "volatiles" tenant compte du mois et de l'année relative à la fonction Aujourd'hui pour tenir compte des valeurs correspondantes sur 1 année tournante.

Comme on me l'a très justement rappelé sur une autre discussion, "mieux que des des mots, une démo" !

voir fichier ci-joint pour l'exemple ;-)

https://www.cjoint.com/c/NFfs4OuHC0k

Merci d'avance pour votre support !

Gexelpas 


Windows / Chrome 109.0.0.0

2 réponses

Le Pingou Messages postés 12116 Date d'inscription mercredi 11 août 2004 Statut Contributeur Dernière intervention 4 juillet 2024 1 442
5 juin 2024 à 22:48

Bonjour,

Essayer avec cette formule en H2 :

=SOMME(SOMMEPROD((A2:A9=G2)*(C2:C9=G1-1)*(D2:D9>=H1)*B2:B9);SOMMEPROD((A2:A9=G2)*(C2:C9=G1)*(D2:D9<=H1)*B2:B9))

CBRiste31 Messages postés 53 Date d'inscription vendredi 8 août 2008 Statut Membre Dernière intervention 6 juin 2024 2
6 juin 2024 à 07:07

Bonjour Le Pingou,

Au top, comme d'habitude car ce n'est pas la 1ère fois que vous m'aidez efficacement !

Merci beaucoup !

Cdlt,

Gexelpas

0
Le Pingou Messages postés 12116 Date d'inscription mercredi 11 août 2004 Statut Contributeur Dernière intervention 4 juillet 2024 1 442
6 juin 2024 à 11:06

Merci, bonne suite.