EXCEL formule

Fermé
Signaler
-
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
-
Bonjour,
comment faire avec une formule ?
je veux dans la plage B1:B1000 savoir combien il y a de mot inférieur à 8 caratères
merci

5 réponses

Messages postés
24222
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
29 novembre 2021
6 975
Bonjour,

Tes mots en A1:A24, tu insères une colonne B
En B1: =NBCAR(A1)
Tu copies ta formule vers le bas jusque B24
en B25: =NB.SI(B1:B24;"<8")

ou sinon en 1 formule où tu veux :
=SOMMEPROD((NBCAR(A1:A24)<8)*1)

eric

que je complète grace à gbinforme...
s'il y a des cellules vide alors
=SOMMEPROD((NBCAR(A17:A24)<8)*(A17:A24<>"")*1)
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 563
bonjour

La formule pour savoir combien il y a de mots inférieurs à 8 caractères dans la plage B1:B1000 peut être celle-ci :
=SOMME((NBCAR(B1:B1000)<8)*(B1:B1000<>"")*1)

à valider par CTRL + MAJ + ENTER car c'est une formule matricielle

La formule ne comptabilise pas les cellules vides, mais seulement celles qui sont renseignées avec 1 à 7 caractères.
Messages postés
24222
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
29 novembre 2021
6 975
Bonjour,

Bien joué, moi je n'ai pas pensé aux chaines vides :-)
eric
Messages postés
1603
Date d'inscription
jeudi 26 juillet 2007
Statut
Membre
Dernière intervention
3 février 2013
200
bonsoir, la dernière ,n'est pas mal, et si tu desire ne voir , par exemple , que les lignes, ou il n'y a que les mots de moins de 8 lettres? parmi toute les ligne?sans utiliser le filtre automatique, c'est possible ou non, juste pour ma curiosité...
merci pour vos réponses
c'est un bon début mais il faut que je précise que dans cette colonne j'ai des mots x et y qu'il faut exclure il que faut que je regarde mais je ne pense pas qu'il y est de blanc.
que veut dire *1
merci beaucoup
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 563
bonjour

j'ai des mots x et y qu'il faut exclure

Tu peux les exclure en rajoutant les conditions :
=SOMME((NBCAR(B1:B1000)<8)*(B1:B1000<>"")*(B1:B1000<>"x")*(B1:B1000<>"x")*1)

à valider par CTRL + MAJ + ENTER car c'est une formule matricielle

que veut dire *1
Les conditions qui sont testées renvoient "vrai" ou "faux" et en multipliant par 1 on obtiens le comptage
et si l'on a un faux, cela donne zéro et ne compte donc pas.
On pourrait remplacer le "*1" par "*(C1:C1000)" si l'on voulait additionner la valeur d'une colonne de même taille.