Excel: recherche de fonction

Résolu/Fermé
Signaler
-
Messages postés
24273
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
21 janvier 2022
-
Bonjour,
je suis a la recherche d'une fonction excel qui detecte si dans ma case qui est au format texte j'ai du texte ou du chiffre et qui me convertit le chiffre en chiffre en chiffre et le texte reste du texte jai utilise la fonction CNUM mais elle me met "#VALEUR!" quand jai du texteor je souhaite garder la valeur que j'ai dans ma cellule
meri d'avance

4 réponses

Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 590
bonjour

peut-être ceci va faire avancer ta réflexion ?
=SI(ESTERREUR(CNUM(A1));A1;CNUM(A1))
0
Messages postés
24273
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
21 janvier 2022
7 028
Bonjour,

cette formule devrait te convenir :
=SI(ESTNUM(CNUM(A1));CNUM(A1);A1)

eric
0
merci pour votre aide les formules marches bien
0
Messages postés
24273
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
21 janvier 2022
7 028
Bonjour,

tant mieux.. :-)
Pense à mettre résolu stp
eric
0