Somme.si valeur exacte pour une cellule dans plage

Résolu/Fermé
Nai Messages postés 711 Date d'inscription vendredi 29 avril 2005 Statut Membre Dernière intervention 25 août 2023 - 6 mars 2023 à 17:07
Nai Messages postés 711 Date d'inscription vendredi 29 avril 2005 Statut Membre Dernière intervention 25 août 2023 - 7 mars 2023 à 16:55

Bonjour à toutes et tous !

J'utilise la formule SOMME.SI dans de nombreux cas, mais là je ne vois pas :/

Je souhaite calculer le nombre de fois que telle valeur apparaît dans une plage pour une valeur précise d'une autre plage.

Dans l'exemple joint :

Je souhaite connaitre le nombre de fois qu'Aurélie à 7:30.

La formule 

=SOMME.SI($H$4:$H$85;A24;$I$4:$I$85)

me calcule le nombre d'heure. Or, je souhaite le nombre de valeur.

Je n'ai pas compris comment utiliser la formule ni même si j'utilise la bonne.

Je vous remercie par avance de votre aide ! :)

Fichier : https://www.cjoint.com/c/MCgqhGTujLS


Windows / Chrome 110.0.0.0


2 réponses

via55 Messages postés 14403 Date d'inscription mercredi 16 janvier 2013 Statut Membre Dernière intervention 24 avril 2024 2 703
6 mars 2023 à 17:22

Bonjour

Ici tu veux faire une dénombrement et non une somme, donc ce n'est pas SOMME.SI mais NB.SI qui convient

Ensuite comme il a plus d'une condition (le nom et l'horaire) c'est NB.SI.ENS qu'il faut utiliser :

=NB.SI.ENS($H$4:$H$85;A24;$I$4:$I$85;"7:30")

Cdlmnt

Via


1
Nai Messages postés 711 Date d'inscription vendredi 29 avril 2005 Statut Membre Dernière intervention 25 août 2023 54
7 mars 2023 à 16:55

Bonjour !

Ah ! Merci ! J'y avais pensé mais n'avais pas compris le fonctionnement!

Fonctionne parfaitement !

0
Mike-31 Messages postés 18313 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 21 avril 2024 5 073
Modifié le 6 mars 2023 à 17:50

Bonjour,

ou encore comme cela

=SOMMEPROD(($H$4:$H$85=A24)*($I$4:$I$85<>""))

ou pour 7:30

=SOMMEPROD(($H$4:$H$85=A24)*($I$4:$I$85="07:30:00"*1))

ou encore

=SOMMEPROD(($H$4:$H$85=A24)*($I$4:$I$85=("7:30"/24)*24))

ou tu mets le temps de référence 7:30 dans une cellule exemple en J1

=SOMMEPROD(($H$4:$H$85=A24)*($I$4:$I$85=$J$1))


1