Power Query fonction si et

Résolu/Fermé
keshia21 Messages postés 155 Date d'inscription jeudi 12 juillet 2018 Statut Membre Dernière intervention 14 mai 2024 - 11 juil. 2022 à 22:52
keshia21 Messages postés 155 Date d'inscription jeudi 12 juillet 2018 Statut Membre Dernière intervention 14 mai 2024 - 11 juil. 2022 à 23:32

Bonjour,

Dans power Query J'ai 2 colonnes de date  intitulées [Envoyé le (Date)"] et ["Complété le (Date)"]

et je voudrais identifier les lignes ou les 2 dates sont toutes les 2  inferieur au 31 mai 2022 .

J'ai essayé cette formule dans une colonne conditionnelle mais cela ne marche pas 

if and ["Envoyé le (Date)"]<="31/05/2022";["Complété le (Date)"]<="31/05/2022";1;0

j'utilise power query car l'origine du fichier est un fichier texte.

Pouvez-vous s'il vous plait m'aider.

Merci bonne soirée 

Keshia


Windows / Chrome 103.0.0.0


Windows / Chrome 103.0.0.0

A voir également:

1 réponse

jee pee Messages postés 39804 Date d'inscription mercredi 2 mai 2007 Statut Modérateur Dernière intervention 29 mai 2024 9 207
Modifié le 11 juil. 2022 à 23:04

Bonjour,

Je n'ai jamais utilisé PowerQuery, mais dans la syntaxe n'y a t-il pas des parenthèses ?

if (and (["Envoyé le (Date)"]<="31/05/2022";["Complété le (Date)"]<="31/05/2022");1;0)

comme on aurait dans une formule excel

=SI(ET(A1=B1;A1=C1);1;0)

1
keshia21 Messages postés 155 Date d'inscription jeudi 12 juillet 2018 Statut Membre Dernière intervention 14 mai 2024 2
11 juil. 2022 à 23:32

Bonsoir Jee Pee 

Merci pour votre réponse effectivement il manquait des parenthèses :) 

Encore merci pour ton aide

Bonne soirée

Keshia

0