Feuille Inventaire [Résolu]

Signaler
-
Messages postés
54311
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
29 juillet 2021
-
Bonjour,

J'ai un beau défi pour vous.
Je suis en train de monter un fichier inventaire d'outils et d'items que mes employés partagent. J'ai créer deux feuilles; une première où contient mon inventaire d'outils numérotés et une seconde où j'aimerais annoter qui qui part avec quel outils et en quel quantité.

J'essaie de trouver une formule qui va pouvoir calculer la quantité utilisé et la déduire directement dans mon inventaire.

Le problème que je rencontre est que si j'inscris dans la première ligne de ma première feuille la quantité de mon tournevis numéroté 3, il va déduire la quantité de mon premier outil dans ma feuille d'inventaire.

Je ne sais pas si c'est clair, mais merci pour réponse!

Configuration: Windows / Chrome 91.0.4472.106

4 réponses

Messages postés
26120
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
27 juillet 2021
5 998
Bonsoir
Difficile de vous répondre avec ça!
si possible, déposer un modèle avec quelques explications sur les attendus
par exemple ici:
https://mon-partage.fr
et revenez coller ici le lien créé sur le site
à vous lire
crdlmnt
Bonjour,

Voici ma liste test : https://mon-partage.fr/f/Zuq8nR4A/

J'ai mis des fruits et légumes pour avoir des données. J'ai besoin d'être capable de mettre la quantité que je prends (feuille Entrée-Sortie ; colonne C), et la valeur ce déduirait automatiquement (feuille Inventaire ; colonne F)

Merci!
Messages postés
54311
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
29 juillet 2021
16 289
Bonjour.

Dans la cellule Inventaire!D2 la formule est
=SOMME.SI('Entrée-Sortie'!$B$2:$B$20;C2;'Entrée-Sortie'!$C$2:$C$20)
Super!
Il y a t'il un moyen de faire en sorte que si je rajoute des lignes, la formule prend en compte les nouvelles données?
Messages postés
26120
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
27 juillet 2021
5 998 > flashgreen
Bonjour
=SOMME.SI('Entrée-Sortie'!$B:$B;C2;'Entrée-Sortie'!$C:$C)
prendra l'ensemble des colonnes
crdlmnt
>
Messages postés
26120
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
27 juillet 2021

Vous êtes de vrai magicien.

Merci beaucoup pour votre aide!
Messages postés
54311
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
29 juillet 2021
16 289
flashgreen ! ! !

Tu as fourni un tableau "Entrée-Sortie" de 20 lignes ; ma formule concerne donc ces 20 lignes ...
Tu as 3 possibilités :
  • 1) Remplacer 20 par 9999
  • 2) Ne pas ajouter de lignes après la ligne 20, mais les insérer avant la ligne 20
  • 3) Ces 2 procédures sont valables pour les personnes qui travaillent directement dans la feuille de calcul, sans insérer un tableau comme tu l'as fait. Pour toi c'est plus simple : tu utilises les champs (noms de colonnes),

ce qui te donne la formule
=SOMME.SI(Description;C2;Combien)
J'ai changé ma formule pour la dernière option! Merci

Je ne sais pas si c'est faisable, mais j'aimerais ajouter quand on insère la date in, la quantité (Combien) se supprime automatiquement de la même ligne seulement.
Messages postés
54311
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
29 juillet 2021
16 289
Là, cette fois-ci je n'ai pas de solution avec de simples formules ; il faudra absolument une macro !