BASE DE DONNEES - TCD - FORMULE

Signaler
Messages postés
8
Date d'inscription
jeudi 11 février 2021
Statut
Membre
Dernière intervention
9 juin 2021
-
Messages postés
702
Date d'inscription
jeudi 18 juillet 2019
Statut
Membre
Dernière intervention
17 juin 2021
-
Bonjour à vous,

Je suis confronté a une base de données que nous allons actualiser assez souvent.

En effet cette base de données contient " des âges calculés en jours " en Colonne " L ".

Les âges vont de 0 à un nombres indéterminés.

Mon but est de : regroupé le nombres de dossier par tranche d'âge ( Exemple : 0 - 15 / 16 - 29 ...) mais également par Territoire (Exemple : âge de 0-15 pour le centre de Le Mans)

J'ai donc utilisé la formule NB.SI.ENS comme par exemple ici :
=NB.SI.ENS(base!L2:L99999;">=15";base!A2:A99999;"B - TERRITOIRE NORMANDIE")
=> Colonne A - Les territoires.
=> Pour le territoire Normandie, et pour les - de 15 jours en prenant en compte les dossiers à " 0 jours "

Comment utiliser cette formule rapidement sans recréer une base de données de mon côté ?
Car mon but étant d'insérer ensuite un TCD par rapport à la base de données et mes formules.

TCD => Par Centre, selon l'âge et le pourcentage par rapport au total de dossiers.
((Je suis débutant dans les TCD))

J'espère avoir été clair afin que vous puissiez m'aider, si besoin possibilité de vous montrer ma base de données.

En vous remerciant par avance pour se casse tête.

3 réponses

Messages postés
16477
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
10 juin 2021
3 189
Bonjour
Pour tenter de t'aider efficacement

Mettre le classeur sans données confidentielles en pièce jointe sur 
https://mon-partage.fr
Dans lien de téléchargement
faire un clic droit- copier l’adresse du lien et le coller dans le message en cours sur ccm



Messages postés
8
Date d'inscription
jeudi 11 février 2021
Statut
Membre
Dernière intervention
9 juin 2021

Bonjour,

Merci pour votre aide, en effet je viens de créer un lien afin de visualiser plus facilement ce que j'aimerais mettre en place.

Lien : https://mon-partage.fr/f/0rftouWB/

Cordialement
Messages postés
702
Date d'inscription
jeudi 18 juillet 2019
Statut
Membre
Dernière intervention
17 juin 2021
53
Bonjour,

Ton explication n'est pas forcément très claire.
Un TCD seul peut très bien faire ce que tu veux sans utiliser les formules NB.SI.ENS. Si tu n'avais pas la tranche à 15 jours le regroupement des âges pourrait se faire facilement dans le TCD.
https://www.cjoint.com/c/KFjtkHlG7Vt
Sinon tu pourrais créer une colonne supplémentaire dans la Base pour déterminer la tranche et faire le TCD ensuite
https://www.cjoint.com/c/KFjtk3FZQyt
sinon, sans TCD il faut faire le tableau que tu a ébauché mais en étant cohérent sur les longueurs des plages et en prenant correctement le territoire. Tu gagnerais aussi en mettant ta Base sous forme de tableau.
https://www.cjoint.com/c/KFjtwVDrbWt

Cordialement