Formule avec SI

Signaler
Messages postés
14
Date d'inscription
lundi 11 avril 2016
Statut
Membre
Dernière intervention
7 juin 2021
-
Messages postés
54131
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 juin 2021
-
Bonjour,
Petit soucis avec une formule


Je voudrais que
B26=00:00 si C26, D26, E26 et D26 sont vides
B26=moyenne de C26 à F26 uniquement des cases avec un chiffre

Merci de votre aide

2 réponses

Messages postés
17380
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
22 juin 2021
4 648
Bonjour,

si j'ai bien compris

=SOMME(C26:F26)/(NB(C26:F26)-NB.SI(C26:F26;"=0"))

ou en plus court

=SOMME(C26:F26)/NBVAL(C26:F26)

A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
Messages postés
54131
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 juin 2021
16 117

Bonjour à vous deux.

Ma proposition :
en C26 =SI(C25<$H$23;0;C25-$H$23)
et en B26 =MOYENNE.SI(C26:F26;">0")