Si conditions dans liste alors "Copier" sinon ... [Résolu]

Signaler
Messages postés
19
Date d'inscription
samedi 29 mai 2021
Statut
Membre
Dernière intervention
12 juin 2021
-
Messages postés
26064
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 juin 2021
-
Bonjour,

J'ai une colonne de Biens (text) en A1, j'aimerais en fonction d'une liste (text), afficher en colonne B1 la valeur correspondante de la liste.
En résumer, si A2 contient valeur de la zone de liste, en B2 alors copier valeur de la liste sinon "AUTRES"

Je vous remercie par avance car là je bloque

2 réponses

Messages postés
26064
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 juin 2021
5 955
Bonjour
pas très clair, on tente ça, à adapter:
avec une zone de liste en Y:Z (code en Y, valeur en Z
code listés en A
en B1, à tirer sur la hauteur
=SIERREUR(RECHERCHEV(A1;Y:Z;2;0);"autre")
crdlmnt
Messages postés
19
Date d'inscription
samedi 29 mai 2021
Statut
Membre
Dernière intervention
12 juin 2021

Bonjour et Merci,

Voici en image ce que je recherche exactement :
Messages postés
26064
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 juin 2021
5 955 >
Messages postés
19
Date d'inscription
samedi 29 mai 2021
Statut
Membre
Dernière intervention
12 juin 2021

C'est assez vague avec une image, je vous propose cette formule en B2

en attendant testez
=SI(SOMMEPROD((NB.SI( A2;"*"&$H$2:$H$15&"*"))*LIGNE($A$1:$A$14))=0;"autre";INDEX($H$2:$H$15;SOMMEPROD((NB.SI( A2;"*"&$H$2:$H$15&"*"))*LIGNE($A$1:$A$14)))
notes:
  • le champ H2:H15 ne doit contenir ni cellule vide, ni doublon de texte même partiel comme par exemple ABC et ABCD puisque ABCD contient ABC (ça ne semble pas être le cas dans votre liste)
  • Attention aux signes " * $ aux bons endroits
  • L'item LIGNE()doit commencer en A1 et contenir le même nombre de lignes que la liste en H dans l'item NB.SI

et si ça ne fonctionne pas, déposez votre modèle Excel ici par exemple:
https://mon-partage.fr
et revenez coller le lien créé sur ce site
crdlmnt
Messages postés
19
Date d'inscription
samedi 29 mai 2021
Statut
Membre
Dernière intervention
12 juin 2021

Merci Vaucluse,

Grand respect car cela fonctionne du feu de bleu.
Je vais essayer de la comprendre et de l'adapter à mon fichier complet.

Encore merci
Messages postés
26064
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 juin 2021
5 955
Pas de quoi
je passe le sujet en résolu
bonne route
Crdlmnt