AMule [Résolu]

Signaler
-
Messages postés
29878
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
9 juin 2021
-
Bonjour,



Configuration: Linux / Firefox 88.0


Je ne parviens pas à installer aMule. Il y a quelques mois un simple sudo apt-get install aMule avait suffi, de mémoire.
J'ai essayé via Synaptic, en ligne de commande, ainsi que je ne sais combien de méthodes plus ou moins catholiques, rien ne fonctionne.
Les packages ne sont pas trouvés, ou alors non signés, ou alors la procédure ne marche pas du tout.

D'où ma question : aMule est-il un logiciel qui est encore maintenu ???
Si ce n'est pas le cas, existe-t-il un équivalent compatible eD2k valable ?
(jen'aime pas du tout les logiciels type bitTorrent)

Je n'ose même pas demander une procédure valable pour aMule, cela me paraît mission impossible (ou alors il faut que j'arrête linux et que je retourne sous Windows, je m'en sortais finalement mieux)

Merci par avance

8 réponses

Messages postés
29878
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
9 juin 2021
7 120
Bonjour,

Tout d'abord, je rappelle que le téléchargement pair à pair ne doit concerner que des œuvres libres de droits. Je vais donc supposer que c'est le cas :-)

1) Assure-toi que ton gestionnaire de paquets à jour :

sudo apt update


... ainsi que ton système

sudo apt upgrade


Assure-toi que la mise à jour se fait sans erreur, sinon reporte-nous les messages d'erreur.

2) Ensuite, vérifie qu'
apt
trouve le paquet
amule


apt search amule


3)a) Si tu le trouves, il ne reste plus qu'à l'installer :

sudo apt install amule


(reporte-nous les erreurs éventuelles).

3)b) Sinon, c'est probablement que les dépôts configurés dans
/etc/apt/sources.list
sont incomplets. Dans ce cas, reporte-nous leur contenu. Tu peux aussi contrôler l'existence dudit paquet en cherchant sur le site de ta distribution linux. Pour ubuntu, on voit sur cette page la liste des distributions pour laquelle le paquet
amule
est disponible. Si le paquet n'existe pas pour ta version d'ubuntun tu peux aussi envisager d'utiliser un autre client (voir cette page et cette page).

Bonne chance
Messages postés
2087
Date d'inscription
jeudi 16 septembre 2004
Statut
Membre
Dernière intervention
30 mai 2021
246
Salut,
amule est dans le dépôt universe d'ubuntu.
Il faut donc activer ce dépôt via les paramètres Logiciels et Mise à Jour ou en éditant
/etc/apt/sources.list


;-) Flachy Joe ;-)
"Qui ne se plante jamais n'a aucune chance de pousser !" Graf anonyme
Comment lancer les paramètres Logiciels et Mise à jour ? N'est-ce possible qu'avec Ubuntu et non avec kubuntu ?
Cf https://dane.ac-lyon.fr/spip/IMG/scenari/ubuntu/co/app_miseAjour_sur_linux.html
Messages postés
2087
Date d'inscription
jeudi 16 septembre 2004
Statut
Membre
Dernière intervention
30 mai 2021
246
Pas de chance : il n'est pas dans les dépôts d'ubuntu 20.04, il a été supprimé entre la 18.04 et la 20.10.
Il y a peut être moyen d'installer le paquet venant de la 20.10 mais il faut bidouiller.

source : https://packages.ubuntu.com/search?searchon=names&keywords=amule

;-) Flachy Joe ;-)
"Qui ne se plante jamais n'a aucune chance de pousser !" Graf anonyme
Messages postés
29878
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
9 juin 2021
7 120
Bonjour,

Paquet
amule


Je rejoins Flachy Joe, comme le montre cette page,
amule
n'existe pas pour la version
focal
.

Trois solutions possibles (par difficulté croissante) :

1) Tu utilises un autre logiciel qu'
amule
, disponible dans ta version d'ubuntu, voir cette page. La plupart des logiciels évoqués devraient directement être disponible via
apt
. (Note au passage que
synaptic
et
discover
sont deux interfaces graphiques qui se greffent par dessus
apt
et ne permettent pas d'accéder à plus ou moins de paquets).

2) Tu migres vers une version plus récente d'ubuntu qui offre le paquet
amule
(e.g.
groovy
ou
hirsute
) en te basant sur ce tutoriel. Je te recommande avant d'entamer une migration de sauver les documents auxquels tu tiens sur un disque externe ou une clé USB, au cas où tu devrais réinstaller ubuntu. À noter que tôt ou tard il faudra migrer vers une version plus récente d'ubuntu, quand la tienne ne sera plus maintenue (voir le tableau reporté sur cette page pour plus de détails).

3) Tu restes en
focal
, mais tu ajoutes également les dépôts d'une version plus récente qui fournit
amule
, et tu spécifies à l'aide de
/etc/apt/preferences
que les paquets doivent être prioritairement pris en
focal
et sinon en
hirsute
. Cela permet de migrer un minimum de paquets.

Dis-nous quelle solution te convient le mieux.

Paquets signés

Par rapport aux paquets signés : les paquets debian (fichiers
.deb
) manipulés par
apt
sont toujours signés.
apt
maintient un trousseau de clés GnuPG (voir commande
apt-key
) qui permet de distinguer les signatures de confiance des autres. Quand
apt
installe un paquet signé par une clé de confiance, aucun avertissement n'est indiqué. Sinon, tu as les messages d'avertissement que tu reportes.

Pour faire disparaître ces avertissements, tu es supposé enregistrer la clé du dépôt (normalement, indiquée par le mainteneur de ce dépôt) à l'aide de la commande
apt-key
. Ici c'est le dépôt codelite qui râle, et une petite recherche google nous mène directement à la page indiquant comment ajouter ces clés.

Archives
.tgz


Parfois certains logiciels sont redistribués au travers d'archives et ou de paquets.
  • Les principaux formats d'archives sont :
    tar
    ,
    .tar.gz
    aka
    .tgz
    ,
    .tar.bz2
    aka
    .tbz2
    , etc).
  • Les principaux formats de paquets sont
    .deb
    pour les distributions basées sur debian (ubuntu, mint...) et
    .rpm
    pour les distributions basées sur redhat (fedora, mandriva...). Donc dans ton cas, seuls les
    .deb
    sont pertinents. Il existe des combines pour installer des
    .rpm
    sous des distributions basées sur debian mais ça n'est souvent pas nécessaire et donc une mauvaise approche.


Un paquet est une archive "enrichie", qui apporte des fonctionnalités souhaitables :
  • Signature : un paquet est signé, ce qui veut dire que tu ne risques pas d'installer un logiciel malveillant (ou plus exactement, si tu tentes de le faire, ton gestionnaire de paquets te dira que ce paquet n'est pas signé par une source de confiance, conformément aux clés enregistrées par
    apt-key
    dans ton cas).
  • Dépendances : un paquet indique de quoi il dépend, ce qui évite d'installer en plusieurs exemplaires une même librairie (et donc de gagner de la place). Comme les dépendances spécifient les numéros de versions valides, cela permet de garantir que les librairies utilisées par le logiciel permettent de le faire fonctionner correctement
  • Scripts d'installation : certaines commandes sont déclenchées à l'installation/désinstallation du paquet pour s'assurer que tout ce qui doit être fait soit fait (et dans le bon ordre). Cela simplifie grandement la vie.
  • Maintenance : comme un paquet est installé par ton gestionnaire de paquet (
    apt
    dans ton cas), ce dernier peut mettre à jour ce logiciel en même temps que le reste du système (car mettre à jour un système signifie simplement mettre à jour les paquets installés).


Conseil 1 : quand tu as le choix, préfère un
.deb
à une archive (e.g.
.tgz
). Enfin, veille à installer des paquets
.deb
conformes à te distribution linux. Typiquement, installer des paquets ubuntu sous debian est une mauvaise idée.

Conseil 2 : assure-toi d'installer des paquets conforme à ta release d'ubuntu (pour le moment,
focal
) et qui ne proviennent pas d'autres release (par exemple
hirsute
). En effet, il y a de fortes chances que les dépendances du paquet
hirsute
ne puisse être satisfaite avec les paquets offerts par les dépôts
focal
. Pour contourner ce genre de problème il faudrait soit passer intégralement en hirsute (méthode 2 dans la section précédente), soit hybrider focal et hirsute (méthode 3 dans la section précédente).

Bonne chance
Dès le
sudo apt update
, j'obtiens :

$ sudo apt update
[sudo] Mot de passe de titruffe :
Atteint :1 http://fr.archive.ubuntu.com/ubuntu/ focal InRelease
Réception de :2 http://fr.archive.ubuntu.com/ubuntu/ focal-updates InRelease [114 kB]
Atteint :3 http://ppa.launchpad.net/thierry-f/fork-michael-gruz/ubuntu/ focal InRelease
Réception de :4 http://fr.archive.ubuntu.com/ubuntu/ focal-backports InRelease [101 kB]
Atteint :5 https://repo.steampowered.com/steam/ stable InRelease
Atteint :8 https://repo.skype.com/deb/ stable InRelease
Réception de :9 http://security.ubuntu.com/ubuntu/ focal-security InRelease [114 kB]
Réception de :6 https://repos.codelite.org/wx3.0.5/ubuntu/ focal InRelease [2 111 B]
Réception de :7 https://repos.codelite.org/wx3.0.5/debian/ buster InRelease [2 036 B]
Réception de :10 http://security.ubuntu.com/ubuntu/ focal-security/main amd64 DEP-11 Metadata [24,4 kB]
Réception de :11 http://security.ubuntu.com/ubuntu/ focal-security/universe amd64 DEP-11 Metadata [58,3 kB]
Réception de :12 http://security.ubuntu.com/ubuntu/ focal-security/multiverse amd64 DEP-11 Metadata [2 464 B]
Err :6 https://repos.codelite.org/wx3.0.5/ubuntu/ focal InRelease
Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 6856E1DB1AC82609
Err :7 https://repos.codelite.org/wx3.0.5/debian/ buster InRelease
Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 6856E1DB1AC82609

Lecture des listes de paquets... Fait
W: Erreur de GPG : https://repos.codelite.org/wx3.0.5/ubuntu/ focal InRelease : Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 6856E1DB1AC82609
E: Le dépôt https://repos.codelite.org/wx3.0.5/ubuntu/ focal InRelease n'est pas signé.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
W: Erreur de GPG : https://repos.codelite.org/wx3.0.5/debian/ buster InRelease : Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 6856E1DB1AC82609
E: Le dépôt https://repos.codelite.org/wx3.0.5/debian/ buster InRelease n'est pas signé.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.


Nulle part je n'arrive à trouver des paquets signés. j'ai essayé des options pour passer outre, sans succès.
J'ai téléchargé des
.deb
, des
tar.gz
de la part de sources différentes, rien à faire. D'où mon interrogation sur le fait qu'
amule
existe encore.
Il y a 6 mois, un simple
sudo apt install amule
avait suffit. Je n'avais pas pu l'utiliser à l'époque car je ne trouvais pas de firewall adapté à cet usage (problème résolu depuis)

Mon but est de télécharger des émissions/documentaires passées à la TV mais que j'ai manqués; j'espère rester dans la légalité. Et si ce n'est pas le cas eh bien le problème sera résolu je n'ai pas l'intention d'aller à l'encontre d'Hadopi.

Je ne trouve pas non plus
amule
(sauf des extensions) dans
discover
ou
synaptic
.
Salut,
Je pense avoir installé le dépôt universe et d'ailleurs à présent amule figure dans la liste.
Mais quand j'essaie de l'installer:

amule:

Le paquet
amule
n'est pas disponible bien qu'il soit listé dans la base de données.
Les explications possibles sont que le paquet est listé dans les dépendances sans jamais avoir été publié, qu'il est devenu obsolète ou qu'il n'est pas disponible sur les dépôts définis dans le fichier
/etc/apt/sources.list
.

Voici mon fichier
/etc/apt/sources.list
:

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://fr.archive.ubuntu.com/ubuntu/ focal main restricted
# deb-src http://fr.archive.ubuntu.com/ubuntu/ focal main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://fr.archive.ubuntu.com/ubuntu/ focal-updates main restricted
# deb-src http://fr.archive.ubuntu.com/ubuntu/ focal-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://fr.archive.ubuntu.com/ubuntu/ focal universe
# deb-src http://fr.archive.ubuntu.com/ubuntu/ focal universe
deb http://fr.archive.ubuntu.com/ubuntu/ focal-updates universe
# deb-src http://fr.archive.ubuntu.com/ubuntu/ focal-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://fr.archive.ubuntu.com/ubuntu/ focal multiverse
# deb-src http://fr.archive.ubuntu.com/ubuntu/ focal multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ focal-updates multiverse
# deb-src http://fr.archive.ubuntu.com/ubuntu/ focal-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://fr.archive.ubuntu.com/ubuntu/ focal-backports main restricted universe multiverse
# deb-src http://fr.archive.ubuntu.com/ubuntu/ focal-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu focal partner
# deb-src http://archive.canonical.com/ubuntu focal partner

deb http://security.ubuntu.com/ubuntu focal-security main restricted
# deb-src http://security.ubuntu.com/ubuntu focal-security main restricted
deb http://security.ubuntu.com/ubuntu focal-security universe
# deb-src http://security.ubuntu.com/ubuntu focal-security universe
deb http://security.ubuntu.com/ubuntu focal-security multiverse
# deb-src http://security.ubuntu.com/ubuntu focal-security multiverse

# This system was installed using small removable media
# (e.g. netinst, live or single CD). The matching "deb cdrom"
# entries were disabled at the end of the installation process.
# For information about how to configure apt package sources,
# see the sources.list(5) manual.
# deb https://deb.opera.com/opera-stable/ stable non-free #Opera Browser (final releases)
# deb-src https://deb.opera.com/opera-stable/ stable non-free #Opera Browser (final releases)
deb http://repos.codelite.org/wx3.0.5/ubuntu/ focal universe
deb http://repos.codelite.org/wx3.0.5/debian/ buster libs
deb https://repos.codelite.org/wx3.0.5/ubuntu focal InRelease
deb http://repos.codelite.org/wx3.0.5/debian buster InRelease


# deb-src http://repos.codelite.org/wx3.0.5/ubuntu/ focal universe


Aucune idée de ce que je dois faire de ce fichier que je ne modifierai sans raison valable, étant incapable de connaître les conséquences.
Même cela je n'y arrive pas : https://www.numetopia.fr/sauvegarder-votre-systeme-linux-avec-timeshift/
Comme toujours je n'ai que des messages d'erreur. Je ne les comprends pas du tout pas plus que je ne comprends les 36000 façons de faire
Je me perds dans les versions, je ne trouve aucune source de fichiers et je me bats depuis presque des jours, sans AUCUN résultat.

Je ne pige rien non plus à https://packages.ubuntu.com/groovy/amd64/amule/filelist
Je pense avoir tenté au moins 12 tutos, y compris vos conseils.
Messages postés
29878
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
9 juin 2021
7 120 > titruffe
Bonjour,

Je te renvoie à mon messsage #6 :
  • Pour le moment, tu utilises des dépôts
    focal
    qui ne fournissent pas
    amule
    . Il est donc normal que tu ne puisses pas installer
    amule 
    ; pour régler le problème il faudrait migrer (au moins partiellement) vers une autre version d'ubuntu qui fournit ce paquet (e.g.
    hirsute
    )
  • Les messages d'erreurs que tu observes (erreur de clé GPG) se règlent comme indiqué dans ce message.
  • Tu dis avoir appliqué plusieurs tutoriels et nos recommandations. Par rapport à mon messsage #6, quelle solution parmi les 3 as-tu choisi ? (ton
    /etc/apt/sources.list
    laisse penser : aucune des deux dernières).
  • As-tu considéré des alternatives à
    amule
    ?


Bonne chance
>
Messages postés
29878
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
9 juin 2021

Je ne comprends pas trop cette histoire de dépôt.
J'ai essayé f'installler hirsute et groovy.
Je comprends les messages sur les clés mais je suis étonné de leur fréquence.
Cela veut dire que selon les dépôts on ne peut pas choisir ses paquets ?
Effectivement le sources.list je ne maîtrise pas alors je préfère éviter.
Reste donc une alternative à amule. Comme je veux de l'eD2k etdu KAD, le choix est limité. Je n'ai pas réussi à installer imule ou encore quazaa. Quand je clique sur l'un de ces liens, j'obtiens une autre liste d'applications...

J'ai kunbuntu car je tiens à l'environnement KDE.Je n'ai pas réussi non plus à installer la 20.10 ni aucun upgrade système (synaptic, discover, timeshift, muon)
Messages postés
29878
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
9 juin 2021
7 120 > titruffe
Bonjour,

J'ai essayé f'installler hirsute et groovy.

Peux-tu préciser ? Normalement tu ne peux installer que l'une ou l'autre, et cela dépend uniquement de la release indiquée dans
/etc/apt/sources.list
. Or dans ce que tu nous a reporté, tu es en
focal
.

Je comprends les messages sur les clés mais je suis étonné de leur fréquence. Cela veut dire que selon les dépôts on ne peut pas choisir ses paquets ?

Non tu n'y est pas. La notion de clé/signature permet de marquer qui a produit un paquet. C'est le même principe que sous : quand tu installes un logiciel, il te prévient si celui-ci n'a pas été produit par un tiers de confiance. Sous linux, ce mécanisme est réalisé à l'aide de ces fameuses signatures (plus précisément, à l'aide des clés GPG que les développeurs ont utilisé pour signer les paquets qu'ils fournissent).

Pour rappel, les paquets sont le moyen standard d'installer des logiciels sous linux. Comme un paquet qui n'est pas signé par un tiers de confiance est potentiellement frauduleux, ton gestionnaire de paquets t'avertit. De plus, installer un paquet sous linux se fait avec des droits root. Cela signifie que dans l'absolu, n'importe quelle opération peut être déclenchée lors de l'installation d'un paquet. Accorder sa confiance à un tiers n'est donc pas quelque chose d'anodin.

Le système de signatures permet à
apt
de distinguer les tiers de confiance des autres. Par défaut, les seuls tiers de confiances sont les mainteneurs de ta distribution linux. D'autres clés peuvent être ajoutées, soit manuellement à l'aide d'
apt-key
, soit en installant certains paquets (dont le nom se termine par convention par
-keyring
). Ça reste une opération exceptionnelle.

Quoi qu'il en soit, si ton gestionnaire de paquets est confronté à un paquet signé par un tiers qui n'est pas de confiance, il t'affichera un avertissement. Pour que cet avertissement disparaisse, il faut ajouter cette signature correspond aux tiers de confiance. C'est le rôle de la commande '
apt-key
.

Dans ton cas, le tiers en question est codelite (et ceci concerne donc uniquement les paquets que ce dépôt fournit). Si tu fais confiance à codelite, ajouter leur signature en tapant (comme expliqué dans la documentation) :

sudo apt-key adv --fetch-keys https://repos.codelite.org/CodeLite.asc


Effectivement le sources.list je ne maîtrise pas alors je préfère éviter.

C'est pourtant lui qu'il faudra corriger si tu adoptes les solutions (2) ou (3) de mon message #6. De plus tu seras tôt ou tard amené à le faire quand ta version d'ubuntu deviendra obsolète. Bref, c'est inévitable, c'est juste une question de temps.

Les seules autres solutions sont se tourner vers un autre logiciel (solution (1)) ou recompiler à la main amule, ce qui est bien plus compliqué que les solutions (2) et (3).

J'ai kubuntu car je tiens à l'environnement KDE.Je n'ai pas réussi non plus à installer la 20.10 ni aucun upgrade système (synaptic, discover, timeshift, muon)

C'est très bien KDE (du moment que le PC est raisonnablement récent), c'est ce que j'utilise aussi. Ici tu parles de la version 20.10, donc groovy (voir ce tableau). Cela revient à adopter la solution (2), migrer vers une version plus récente d'ubuntu (puisque tu passerais de
focal
à
groovy
).

Je ne sais pas exactement comment tu procèdes et ubuntu proposes des assistants pour faire une migration.

Concrètement, faire migration consite à :
1) Remplacer les occurrences de la release courante (
focal
dans ton cas) par la nouvelle (e.g.
groovy
) en corrigeant
/etc/apt/sources.list
(e.g. via la commande
sudo nano /etc/apt/sources.list
, ctrl x pour quitter) et les éventuels fichiers contenus dans
/etc/apt/sources.list.d
;
2) Récupérer la liste des mises à jour avec la commande
sudo apt update
ou via ta logithèque ;
3) Mettre à jour l'ensemble des paquets installés, avec la commande
sudo apt upgrade
ou via ta logithèque.

Note que c'est à l'étape 3 que tu peux avoir des problèmes. En général, une migration engendre d'importants changements, et tu peux avoir des paquets qui entrent en conflit. Souvent l'approche la plus simple consiste à les virer, le temps de résoudre le conflit, puis une fois que la migration est faite, les réinstaller.

Comme une migration peut parfois être un peu laborieux, certains adoptent une approche beaucoup plus radicale, en réinstallant (k)ubuntu dans une version plus récente par dessus l'ancienne (en veillant à réutiliser les partitions existantes, mais sans formater
/home
).

Quelle que soit la méthode retenue, je te recommande de sauver les documents auxquels tu tiens sur un disque externe ou une clé USB, car on n'est jamais à l'abri d'une fausse manipulation.

Bonne chance

EDIT :
gorilla
->
groovy
J'ai juste remplacé les
focal
par
gorilla
et j'obtiens ceci :

Ign :1 http://fr.archive.ubuntu.com/ubuntu/ gorilla InRelease
Ign :2 http://fr.archive.ubuntu.com/ubuntu/ gorilla-updates InRelease
Ign :3 http://fr.archive.ubuntu.com/ubuntu/ gorilla-backports InRelease
Err :4 http://fr.archive.ubuntu.com/ubuntu/ gorilla Release
404 Not Found [IP : 2001:860:f70a::2 80]
Err :5 http://fr.archive.ubuntu.com/ubuntu/ gorilla-updates Release
404 Not Found [IP : 2001:860:f70a::2 80]
Ign :6 http://ppa.launchpad.net/teejee2008/ppa/ubuntu/ gorilla InRelease
Err :7 http://fr.archive.ubuntu.com/ubuntu/ gorilla-backports Release
404 Not Found [IP : 2001:860:f70a::2 80]
Ign :8 http://ppa.launchpad.net/thierry-f/fork-michael-gruz/ubuntu/ gorilla InRelease
Atteint :10 https://repo.skype.com/deb/ stable InRelease
Err :11 http://ppa.launchpad.net/teejee2008/ppa/ubuntu/ gorilla Release
404 Not Found [IP : 2001:67c:1560:8008::19 80]
Atteint :13 https://repo.steampowered.com/steam/ stable InRelease
Err :14 http://ppa.launchpad.net/thierry-f/fork-michael-gruz/ubuntu/ gorilla Release
404 Not Found [IP : 2001:67c:1560:8008::19 80]
Ign :15 http://security.ubuntu.com/ubuntu/ gorilla-security InRelease
Atteint :16 https://repos.codelite.org/ubuntu/ groovy InRelease
Ign :9 https://repos.codelite.org/wx3.0.5/ubuntu/ gorilla InRelease
Err :17 http://security.ubuntu.com/ubuntu/ gorilla-security Release
404 Not Found [IP : 2001:67c:1562::18 80]
Atteint :12 https://repos.codelite.org/wx3.0.5/debian/ buster InRelease
Err :18 https://repos.codelite.org/wx3.0.5/ubuntu/ gorilla Release
404 Not Found [IP : 79.143.189.67 443]

Lecture des listes de paquets... Fait
E: Le dépôt http://fr.archive.ubuntu.com/ubuntu/ gorilla Release n'a pas de fichier Release.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
E: Le dépôt http://fr.archive.ubuntu.com/ubuntu/ gorilla-updates Release n'a pas de fichier Release.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
E: Le dépôt http://fr.archive.ubuntu.com/ubuntu/ gorilla-backports Release n'a pas de fichier Release.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
E: Le dépôt http://ppa.launchpad.net/teejee2008/ppa/ubuntu/ gorilla Release n'a pas de fichier Release.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
E: Le dépôt http://ppa.launchpad.net/thierry-f/fork-michael-gruz/ubuntu/ gorilla Release n'a pas de fichier Release.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
E: Le dépôt http://security.ubuntu.com/ubuntu/ gorilla-security Release n'a pas de fichier Release.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
E: Le dépôt https://repos.codelite.org/wx3.0.5/ubuntu/ gorilla Release n'a pas de fichier Release.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
N: Le fichier configuré « universe/binary-i386/Packages » ne sera pas pris en compte car le dépôt « https://repos.codelite.org/ubuntu/ groovy InRelease » ne prend pas en charge l'architecture « i386 »
N: Le fichier configuré « libs/binary-i386/Packages » ne sera pas pris en compte car le dépôt « https://repos.codelite.org/wx3.0.5/debian/ buster InRelease » ne prend pas en charge l'architecture « i386 »
W: Le fichier configuré « InRelease/binary-amd64/Packages » ne sera pas pris en compte car le dépôt « https://repos.codelite.org/wx3.0.5/debian/ buster InRelease » ne dispose pas de la source « InRelease » (erreur de saisie dans sources.list ?)
W: Le fichier configuré « InRelease/binary-i386/Packages » ne sera pas pris en compte car le dépôt « https://repos.codelite.org/wx3.0.5/debian/ buster InRelease » ne dispose pas de la source « InRelease » (erreur de saisie dans sources.list ?)
W: Le fichier configuré « InRelease/i18n/Translation-en » ne sera pas pris en compte car le dépôt « https://repos.codelite.org/wx3.0.5/debian/ buster InRelease » ne dispose pas de la source « InRelease » (erreur de saisie dans sources.list ?)
W: Le fichier configuré « InRelease/i18n/Translation-fr_FR » ne sera pas pris en compte car le dépôt « https://repos.codelite.org/wx3.0.5/debian/ buster InRelease » ne dispose pas de la source « InRelease » (erreur de saisie dans sources.list ?)
W: Le fichier configuré « InRelease/i18n/Translation-fr » ne sera pas pris en compte car le dépôt « https://repos.codelite.org/wx3.0.5/debian/ buster InRelease » ne dispose pas de la source « InRelease » (erreur de saisie dans sources.list ?)
W: Le fichier configuré « InRelease/dep11/Components-amd64.yml » ne sera pas pris en compte car le dépôt « https://repos.codelite.org/wx3.0.5/debian/ buster InRelease » ne dispose pas de la source « InRelease » (erreur de saisie dans sources.list ?)
W: Le fichier configuré « InRelease/dep11/icons-48x48.tar » ne sera pas pris en compte car le dépôt « https://repos.codelite.org/wx3.0.5/debian/ buster InRelease » ne dispose pas de la source « InRelease » (erreur de saisie dans sources.list ?)
W: Le fichier configuré « InRelease/dep11/icons-64x64.tar » ne sera pas pris en compte car le dépôt « https://repos.codelite.org/wx3.0.5/debian/ buster InRelease » ne dispose pas de la source « InRelease » (erreur de saisie dans sources.list ?)
W: Le fichier configuré « InRelease/dep11/***@*** » ne sera pas pris en compte car le dépôt « https://repos.codelite.org/wx3.0.5/debian/ buster InRelease » ne dispose pas de la source « InRelease » (erreur de saisie dans sources.list ?)
W: Le fichier configuré « InRelease/dep11/icons-128x128.tar » ne sera pas pris en compte car le dépôt « https://repos.codelite.org/wx3.0.5/debian/ buster InRelease » ne dispose pas de la source « InRelease » (erreur de saisie dans sources.list ?)
W: Le fichier configuré « InRelease/cnf/Commands-amd64 » ne sera pas pris en compte car le dépôt « https://repos.codelite.org/wx3.0.5/debian/ buster InRelease » ne dispose pas de la source « InRelease » (erreur de saisie dans sources.list ?)
Messages postés
29878
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
9 juin 2021
7 120
Bonjour,

J'ai fait une erreur, apparemment mot magique est
groovy
, pas
gorilla
.

Méthode 1 (méthode debian)

Pour commencer, restaure ton fichier tel qu'il était avant, teste-le, sauvegarde le ailleurs.

Ensuite, remplace son contenu par :

deb http://fr.archive.ubuntu.com/ubuntu/ groovy main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ groovy-security main restricted universe multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ groovy-updates main restricted universe multiverse


Puis lance :

sudo apt update


Ensuite finalise la mise à jour, soit via ta logithèque, soit en ligne de commandes :

sudo apt upgrade


Vu que le support de
groovy
se termine en juillet (voir ce lien), tu peux dans la foulée migrer ensuite vers
hirsute
, sur le même principe.

On remettra plus tard proprement les autres dépôts si tu en as toujours le besoin. Pour codelite il suffira de te reporter au lien que je t'ai déjà donné. Pour les ppa je te déconseille d'y avoir recours en général sauf si tu es sûr de toi.

Méthode 2 (avec
do-release-upgrade
)


Comme expliqué ici, tu peux remplacer toute cette procédure grâce à la commande
do-release-upgrade
(spécifique à ubuntu et que je ne connaissais pas)

do-release-upgrade --check-dist-upgrade-only --devel-release
do-release-upgrade --devel-release


(ajouter
sudo
devant ces deux commandes si besoin).

Bonne chance
Excuse-moi je n'avais pas vu la dernière ligne de ton message.
Avec groovy cela marche nickel, j'ai pu sans problème installer amule; merci beaucoup pour ta patience avec moi !
J'aime apprendre, mais j'ai l'impression que je me décourage trop vite en ce moment. Apprendre linux est bien plus passionnant que Windows, il faut juste beaucoup de temps. Si tu connais un site (un wiki par exemple, même en anglais) pour me permettre de réapprendre les bases ce serait cool.
Je regrette aussi que les tutos sont sinon pas datés (certains datent de 2005 !) tandis que d'autres ne sont pas à jour. Je crois toujours que linux évolue un peu trop vite pour moi, je dois surtout m'y adapter.
Ceci dit quand je parle d'impatience je suis dur avec moi tellement je passe du temps à résoudre les problèmes.
Mais heureusement parfois il y a des personnes bienveillantes qui donnent de leur temps sur ce genre de forum.

Toute ma reconnaissance donc envers toi !
Messages postés
29878
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
9 juin 2021
7 120
Excuse-moi je n'avais pas vu la dernière ligne de ton message.

C'est possible que tu l'aies consulté pendant que je le modifiais, donc ne t'en fais pas :-)

Avec groovy cela marche nickel, j'ai pu sans problème installer amule; merci beaucoup pour ta patience avec moi !
J'aime apprendre, mais j'ai l'impression que je me décourage trop vite en ce moment. Apprendre linux est bien plus passionnant que Windows, il faut juste beaucoup de temps. Si tu connais un site (un wiki par exemple, même en anglais) pour me permettre de réapprendre les bases ce serait cool.


Je pense que deux choses sont importantes dans l'histoire. D'abord tu as résolu ton problème, c'était le but. Ensuite, et plus important, tu as dû apprendre plein de choses : tu comprends maintenant sans doute mieux les causes des problèmes auxquels tu as fait face, pourquoi j'ai proposé ces solutions, et pourquoi elles répondaient au problème.

Dans cette discusion, ce qu'il faut retenir à mon avis c'est :
  • installer / mettre à jour / supprimer des logiciels revient à gérer des paquets (via
    apt
    sous ubuntu) ;
  • le site https://packages.ubuntu.com/ te permet de voir quels paquets sont disponibles pour quelle version d'ubuntu
  • les paquets disponibles résultent directement des dépôts configurés dans
    /etc/apt/sources.list
    , ce qui inclue :
    • l'adresse des miroirs
    • les dépôts activés (notamment
      universe
      et
      multiverse
      )
    • la version (release) d'ubuntu que tu utilises (dans ton cas,
      groovy
      depuis peu)
  • les paquets doivent être signés par des tiers de confiance pour ne pas déclencher d'avertissement ;
  • on peut ajouter des dépôts (genre skype, teams), mais je déconseille fortement l'ajout de ppa à moins d'être sûr de ce qu'on fait.
  • on peut ajouter un tiers de confiance avec
    apt-key
    ;


La plupart de ces éléments sont documentés (plus ou moins bien, mais c'est toujours mieux que rien) dans la documentation ubuntu. Après il faut savoir chercher un peu sur internet, tu verras que ce sont toujours un peu les même sites qui reviennent. La raison pour laquelle je m'implique sur ce forum est que beaucoup de ressources sont en anglais, et ça peut parfois être handicapant pour les personnes qui ne maîtrisent pas cette langue.

Je regrette aussi que les tutos sont sinon pas datés (certains datent de 2005 !) tandis que d'autres ne sont pas à jour. Je crois toujours que linux évolue un peu trop vite pour moi, je dois surtout m'y adapter.

Beaucoup restent vrais. Après c'est un effort collectif de les maintenir à jour. Chacun en fonction de ses connaissances, de ses convictions et de son temps, peut s'impliquer plus ou moins pour maintenir les wiki, répondre sur les forums, développer des logiciels libres, s'impliquer dans des associations. Pour le moment tu dis découvrir, mais si cet univers t'intéresse, tu n'auras aucune difficulté à trouver des moyens de t'impliquer à ton tour.

Ceci dit quand je parle d'impatience je suis dur avec moi tellement je passe du temps à résoudre les problèmes.

Oui, je trouve aussi :-) Je pense même que cet épisode doit te donner confiance en toi et te montrer que le courage paye.

Mais heureusement parfois il y a des personnes bienveillantes qui donnent de leur temps sur ce genre de forum.

Oui, au delà de nos convictions, c'est justement ce genre de retour chaleureux qui donnent envie de continuer à s'implique ;-)

Bonne continuation !