Problème SI DATE alors OUI

Signaler
Messages postés
3
Date d'inscription
mardi 4 mai 2021
Statut
Membre
Dernière intervention
5 mai 2021
-
Messages postés
53811
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
5 mai 2021
-
Bonjour,

Voici mon problème suivant :
En cellule D2 si une date est indiquée alors en cellule E2 (dont l'en tête E1 s'intitule dossier à communiquer ) alors indiquer oui. Je précise que ma colonne D2 est en format date.

Voici ce que j'ai essayé

=SI(ESTVIDE(D2);"non";"oui")
=SI(D2>00/00/00);"oui";"non")

Je ne site pas toutes les formules essayées... voilà bientôt deux heures que je suis dessus, j'ai effectué d'autres recherches mais je ne trouve pas la bonne formule. Sauriez vous m'aidez svp?

Merci,

Cordialement,

Sam

6 réponses

Messages postés
31801
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
5 mai 2021
7 630
Bonjour,

=SI(ESTVIDE(D2);"non";"oui")
est une formule qui doit fonctionner.

tu devrais nous donner ton fichier pour voir ce qui ne va pas
Messages postés
3
Date d'inscription
mardi 4 mai 2021
Statut
Membre
Dernière intervention
5 mai 2021

Jee pee et Raymond merci pour vos réponses,

J'ai donc ouvert mon fichier et ça n'a pas fonctionné avec cette formule que j'avais déjà utilisée, comment puis je envoyer un fichier par ce forum ?
Messages postés
53811
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
5 mai 2021
15 817
Est-ce que E2 peut contenir autre chose qu'une date : un nombre, un texte, un espace, une formule ?
Messages postés
605
Date d'inscription
mercredi 5 octobre 2016
Statut
Membre
Dernière intervention
5 mai 2021
50
Bonjour à tous,
une propo : =SI(D2<>"";"oui";"non")
Messages postés
31801
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
5 mai 2021
7 630
Pour nous donner un fichier, tu le déposes sur un site comme cjoint.fr, et tu mets le lien obtenu dans ta réponse sur le forum

tu n'as pas répondu à la question de Raymond
Messages postés
3
Date d'inscription
mardi 4 mai 2021
Statut
Membre
Dernière intervention
5 mai 2021

Re Bonjour,

Donc la formule de jee pee fonctionne bien, en fait j'ai l'impression qu'il y a des problèmes d'actualisation des données, c'est à dire que là je l'ai réouvert et la formule de jee pee fonctionne très bien....

Pour répondre à
- Fabien : j'ai déjà essayé cette formule et peux la réessayer merci en tout cas
- Raymond : la cellule E2 ne contiendrait que la réponse oui si dans la cellule D2 il y a une date à renseigner ou non si dans la cellule D2 il n'y a pas de date soit cellule vide quoi.

Un grand merci pour votre réactivité
Messages postés
605
Date d'inscription
mercredi 5 octobre 2016
Statut
Membre
Dernière intervention
5 mai 2021
50
Je me suis permis de proposer cette formule parce que la fonction ESTVIDE ne fonctionne QUE si la cellule est réellement vide : une formule pour afficher la date avec un =SI(condition;"";AUJOURDHUI()) (par exemple) rendrait la cellule non vide malgré que le résultat du SI soit "".
Au cas où, vérifie dans les options de ton classeur que le mode de calcul soit en automatique. Ton problème d'actualisation peut peut-être venir de ça
Messages postés
53811
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
5 mai 2021
15 817
Bonjour samjanv35

"si dans la cellule D2 il n'y a pas de date soit cellule vide quoi "
Eh bien NON, justement ! Ta cellule D2 peut en effet :
  • contenir une date (nombre avec un format spécifique),
  • contenir un texte vide comme "",
  • contenir une formule qui affiche comme résultat soit une date, soit un texte vide,
  • ne rien contenir du tout, donc être physiquement vide.

D'où ma question du 4 mai ... et d'où l'explication fournie par Fabien à 16:20

Concernant ton "blocage" d'actualisation des données, clique sur la touche [ f9 ] quand ça t'arrive, ou vérifie que l'outil FORMULE/Options de calcul est bien sur "Automatique".