Fonction si à deux condition

Résolu/Fermé
Jennib370 Messages postés 53 Date d'inscription mardi 27 décembre 2011 Statut Membre Dernière intervention 31 mars 2022 - 15 avril 2021 à 17:26
yg_be Messages postés 20717 Date d'inscription lundi 9 juin 2008 Statut Contributeur Dernière intervention 26 novembre 2022 - 22 juin 2021 à 21:27
Bonjour,
J'ai regardé plusieurs vidéos et explications et je n'arrive toujours pas à faire fonctionner la formule. Je ne sais pas du tout ce qui ne marche pas.

=SI(ET(T4="s";U4="1");"1";"")

J'ai commencer par faire celle -là et même elle ne marche pas =ET(T6="s";U6="1")

Merci à l'avance!
Configuration: Windows / Chrome 89.0.4389.128

2 réponses

Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 284
15 avril 2021 à 17:32
Bonjour
si U est une valeur numérique et si vous voulez un résultat en numérique, retirez les guillemets qui encadrent les deux 1 de votre formule
crdlmnt
2
Jennib370 Messages postés 53 Date d'inscription mardi 27 décembre 2011 Statut Membre Dernière intervention 31 mars 2022 1
15 avril 2021 à 19:38
Maintenant j'essaie de faire le contraire pour avoir un résultat contraire et ça ne fonctionne pas.
J'imagine que c'est le <> qui n'est pas bon?

=SI(ET(T3<>"s";U3=1);1;"")
0
Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 284 > Jennib370 Messages postés 53 Date d'inscription mardi 27 décembre 2011 Statut Membre Dernière intervention 31 mars 2022
15 avril 2021 à 20:52
Non, ça devrait fonctionner. Vérifiez que le s en T3 est bien seul (sans blanc par exemple) est que vous avez bien une valeur numérique en U3 (le 1 en U3 si vous formatez la cellule en format / alignement / standard, doit s'afficher à droite dans la cellule)
et si ça ne va pas avec ça, déposez un modèle Excel de vos données pour que l'on voir ce qu'il se passe ici:
https://mon-partage.fr
et revenez coller le lien créé sur le site.
Il y a moyen de contourner ces difficultés si elles sont là, par exemple avec:
=ET(NB.SI(T3;"*s*")=0;U3*1=1);1;0)
à demain!
crdlmnt
0
Jennib370 Messages postés 53 Date d'inscription mardi 27 décembre 2011 Statut Membre Dernière intervention 31 mars 2022 1
15 avril 2021 à 17:35
Waaaaaaaa merci!
Si simple, mais il faut le savoir! :)
0
yg_be Messages postés 20717 Date d'inscription lundi 9 juin 2008 Statut Contributeur Dernière intervention 26 novembre 2022 1 260
22 juin 2021 à 21:27
peux-tu alors marquer comme résolu?
0