Calculateur nombre d’heures [Résolu]

Signaler
-
 Laurence1616 -
Bonjour, Je veux monter un fichier Excel dans lequel mon nombre d’heure par semaine va se cumuler.

Voici les contraintes:
Chaque semaine le maximum d’heures payées est 30h, si plus que 30h la différence se cumule dans les heures en banque si moins que 30h on va prendre la différence ou le maximum de la différence dans mes heures en banque et ainsi les diminuer.

Je n’arrive pas à trouver des formules pour arriver à un résultat parfait, j’arrive avec des cellules en erreur!
Ex: lorsque je fais 25h, je pourrais aller chercher 5h dans les heures en banques, mais exemple qu’il reste seulement 3h en banque quelle formule je pourrais utiliser pour que excel vienne seulement prendre le maximum des heures en banques disponibles soit 3h?

Un grooooos merci !

2 réponses

Messages postés
1545
Date d'inscription
samedi 12 septembre 2020
Statut
Membre
Dernière intervention
10 avril 2021
128
Salut,

Dans la cellule A1 tu inscris 30 (le nombre d'heures hebdo)

Dans la colonne A, tu mettras les heures travaillées hebdomadaires. Dans la colonne B les heures en banque.

Dans A2, tu ne mets rien, dans B2 tu inscris 0 (ça va servir de départ pour les heures en banque).

Tu commences ta semaine en A3. Dans B3 tu inscris la formule :

=SI(A3-$A$1+B3<0;0;A3-$A$1+B3)


Dans cette formule, ça remet la banque à 0 si tu puises dans toute la banque.
Messages postés
3172
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
9 avril 2021
888
Bonjour

Salut dachiasse

Petite rectification de cette formule car la référence circulaire (B3 pour B3) donne tout le temps 0 quand on incrémente vers le bas même si les heures semaine dépassent 30

=SI(A3-$A$1+B2<0;0;A3-$A$1+B2)

Cordialement
Messages postés
1545
Date d'inscription
samedi 12 septembre 2020
Statut
Membre
Dernière intervention
10 avril 2021
128
Salut,

Oui Luc, tu as raison.
Un gros gros gros merci !!! Vous avez réglé mon problème :)