Test logique sous excel [Résolu]

Signaler
-
 ArnO -
Bonjour, j'ai un problème sous excel que je n'arrive pas à résoudre complétement. Je souhaiterai inclure une fonctions logique dans la colonne A corrigé à mon tableau (3 colonnes, 8 lignes) suivant :


A XX1 A corrigé

0 -

0.5 -

1.0 -

1.5 + 0

2.0 + 0.5

3.0 + 1.5

5.0 + 3.5


si XX1="-" ne rien faire

si XX1= le premier "+"; mettre 0 dans colonne A corrigé

sinon, pour toutes les lignes suivantes A corrigé = nombre de la colonne A moins le premier A ou X1 = "+"

c'est la partie en gras que je n'arrive pas à faire


En espérant qu'une personne pourra m'aider.

Bonne journée

ArnO

j'ai fait un tableau excel mais je n'arrive pas à le poster

3 réponses

Messages postés
12989
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
10 avril 2021
2 170
Bonjour Amo

Avec tes valeurs en plage A2:A8, les - ou + en plage B2:B8, en C2 mettre la formule :
=SI(B2="+";A2-INDEX(A$2:A2;EQUIV("+";B$2:B2;0));"")
et étirer vers le bas

EQUIV("+";B$2:B2;0) renvoie le rang du premier + trouvé
INDEX(A$2:A2;EQUIV("+";B$2:B2;0)) renvoie la valeur en A de ce rang (donc1,5 dans ton exemple)

Cdlmnt
Via
Bonjour Via55,
Merci pour cette réponse hyper complète et qui fonctionne super bien. .. et hyper rapide je ne connaissais pas toutes ses fonctions.
Bien cordialement
ArnauD
Messages postés
15063
Date d'inscription
lundi 9 juin 2008
Statut
Contributeur
Dernière intervention
10 avril 2021
827
bonjour,
moi je rajouterais deux colonnes, avec, sur chaque ligne,
dans une colonne, une indication si c'est on est au dessus du premier "+", ou pas
dans l'autre colonne, la valeur du premier plus, si on est en dessous du premier plus
Bonjour yg_be, je vais essayer de le faire. merci pour la précision.

bonne journée

arnauD