Si case vide alors vide avant une formule

Signaler
-
Messages postés
2394
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
8 avril 2021
-
Bonjour,



J'ai une formule sur A5 qui est des Si imbriqués sur les cellules A1:A4). Mais parfois, les celles A1-> A4 sont vides, et alors je ne veux pas de résultat en A5, je voudrais qu'elle reste vide. Donc je cherche à intercaler une fonction si case vide (A1:A4) alors A5 doit être vide avant la formule de la case A5
Pouvez-vous m'aider ?
merci d'avance
Sandra

3 réponses

Messages postés
16429
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
8 avril 2021
3 160
Bonjour
les celles A1-> A4 sont vides

flou!

En supposant que A1:A4 contiennent que des nombres

sont TOUTES vides ?
=SI(Nb(A1:A4)=0;"";la formule)
ou

AU MOINS une cellule] vide ?
=SI(Nb(A1:A4)>4;"";la formule)
Bonjour Michel,

Merci d'avoir répondu. Je complète mon message...
A1-> A4 : elles sont vides si elles ne contiennent pas de lettres (lettres possibles A, B, C, D)

Ma formule imbriquée sur A5 est la suivante : =SI(OU(ET(CF151= "A";CI151="D");ET(CG151="B";CH151="C"));SI(OU(CG151= "B";CH151="C");"2";"0");"1")

J'ai essayé avec votre formule =SI(NB(ES158:EV158)=0;"";SI(OU(ET(ET158= "B";EV158="D");ET(ES158="A";EU158="C"));SI(OU(ES158= "A";EU158="C");"2";"0");"1"))

mais ça ne marche pas. J'ai certainement pas tout compris ...

Désolée
Messages postés
16429
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
8 avril 2021
3 160
Re
j'avais précisé
En supposant que A1:A4 contiennent que des nombres


Ta demande actuelle n'a rien à voir avec ta première demande

Je regarde mais....
Messages postés
2394
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
8 avril 2021
1 067
Pas tout compris
une proposition
=SI(SOMMEPROD(A1:A4="A")+SOMMEPROD(A1:A4="B")+SOMMEPROD(A1:A4="C")+SOMMEPROD(A1:A4="D")>0;"il y a A ou B ou C ou D";"calcul")