Remplacer la réponse par 1 si résultat est égale à 0

Signaler
Messages postés
1
Date d'inscription
samedi 27 mars 2021
Statut
Membre
Dernière intervention
27 mars 2021
-
Messages postés
24016
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
18 avril 2021
-
Bonjour,

Bonjour
Comment est-ce que je peux avoir la réponse de la formule sera à 1 si réponse de la formule est égale à 0 ?

par exemple si :
=ARRONDI.SUP(SI(B2="A";A2*2;SI(OU(B2="B";B2="C");A2*3;SI(OU(B2="D";B2="E";B2="F");A2*4;0)));0)
est égale à 0
remplacer par 1

Configuration: Windows / Chrome 89.0.4389.90

3 réponses

Messages postés
53669
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
20 avril 2021
15 698
=SI( ARRONDI.SUP(SI(B2="A";A2*2;SI(OU(B2="B";B2="C");A2*3;SI(OU(B2="D";B2="E";B2="F");A2*4;0)));0) =0;1;ARRONDI.SUP(SI(B2="A";A2*2;SI(OU(B2="B";B2="C");A2*3;SI(OU(B2="D";B2="E";B2="F");A2*4;0)));0) )
Messages postés
25968
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 avril 2021
5 879
Bonjour
à priori et sauf erreur la formule ne renvoie 0 que si A2 est =0 ou si aucune condition n'est remplie
il devrait donc suffire d'écrire
=SI(A2=0;1;ARRONDI.SUP(SI(B2="A";A2*2;SI(OU(B2="B";B2="C");A2*3;SI(OU(B2="D";B2="E";B2="F");A2*4;0)));0))
et si vous voulez aussi que les conditions renvoie 0 1 si non remplies, remplacez vos ;0 de la fin (en gras ici) par ;1
crdlmnt
Messages postés
24016
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
18 avril 2021
6 736
Bonjour,

si tu ne peux avoir de lettre > "F" tu peux aussi simplifier ainsi :
=SI(A2=0;1;A2*CHOISIR(CODE(B2)-64;2;3;3;4;4;4))

(j'ai pris la 1ère hypothèse de vaucluse, sinon adapter)
eric