Formule SI et OU ? [Résolu]

Signaler
Messages postés
11
Date d'inscription
mardi 23 mars 2021
Statut
Membre
Dernière intervention
9 avril 2021
-
Messages postés
11
Date d'inscription
mardi 23 mars 2021
Statut
Membre
Dernière intervention
9 avril 2021
-
Bonjour à tous,

Je cherche une formule qui dirait :

si A1 ou A2 ou A3 est saisi (donc non égal à 0)

alors A4 et A5 et A6 sont = 0

sinon "Erreur n1"

A1 = 1000
A2 = 800
A3 = 200
A4=0
A5=0
A6=0



Je regarde des tutos ici et là mais je n'arrive pas à savoir comment mettre le ET dans la formule... j'ai systématiquement des err... :(

Je vous remercie d'avance pour l'aide que vous pourrez m'apporter.

7 réponses

Messages postés
12989
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
10 avril 2021
2 170
Bonjour Panda

Il n'y a pas de ET mais que des OU dans ta formule

Même formule à entrer en A4, en A5 et en A6:
=SI(OU(A1<>"";A2<>"";A3<>"");0;"Erreur n1")

Cdlmnt
Via


Messages postés
2545
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
9 avril 2021
1 488
Bonjour,

Essayer avec ceci, à écrire dans chacune des cases A4,A5,A6
=Si(OU(A1="";A2="";A3="");"Erreur n°1";0)
Messages postés
11
Date d'inscription
mardi 23 mars 2021
Statut
Membre
Dernière intervention
9 avril 2021

Bonjour Via55,

Merci beaucoup pour ta réponse !

Cela ne marche pas car je me suis mal exprimée... désolée !

Les colonnes de A1 à A6 ne doivent pas contenir de formules mais soit des montants soit 0. C'est dans B1 à B6 que je souhaite mettre la formule (ce sera la même de B1 à B6).

Je vais reformuler plus justement :

si A1 ou A2 ou A3 est saisi (donc non égal à 0)

alors A4 et A5 et A6 sont = 0

si ces 2 conditions ne sont pas remplies alors "Erreur n1"

Exemple : si A1 est saisi et A4 et A5 et A6 sont saisis donc je dois avoir mon Erreur 1.

Merci d'avance !
Messages postés
11
Date d'inscription
mardi 23 mars 2021
Statut
Membre
Dernière intervention
9 avril 2021

Merci beaucoup Diablo, j'ai reformulé car je n'avais pas été suffisamment précise.
Messages postés
12989
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
10 avril 2021
2 170
Re

Alors si j'ai bien compris lorsque l'une au moins des cellules A1 à A3 est remplie et somme des cellules A4 à A6 = 0 alors c'est OK sinon Erreur
ce qui peut se traduire par :
=SI(ET(OU(A1<>"";A2<>"";A3<>"");SOMME(A4:A6)=0);"OK";"Erreur")


Messages postés
3172
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
9 avril 2021
888
Salutations à tous

Je ne sais pas si j'ai tout compris mais je me lance.

Les trois premières cellules contiennent une valeur et les trois suivantes sont à 0 ; donc on met 0 sinon erreur

=SI(ET($A$1<>0;$A$2<>0;$A$3<>0;$A$4=0;$A$5=0;$A$6=0);0;"Erreur")


Cordialement
Messages postés
11
Date d'inscription
mardi 23 mars 2021
Statut
Membre
Dernière intervention
9 avril 2021

WOUAW les 2 formules fonctionnent super bien !

Merci BEAUCOUP !!!