Si/ou/index/equiv

Résolu/Fermé
zabou - 24 févr. 2021 à 20:36
 zabou - 25 févr. 2021 à 08:57
Bonjour,

Pourriez-vous corriger cette formule ?

=si(ou(b4="ao";b4="op");index(b3:b16;equiv((b14+7);b3:b16);"faux"))

si b4 contient ao ou b4 contient op alors chercher dans la liste b3:b16 la valeur de b14+7 sinon indiquer faux

Le résultat indique "valeur"

Je suis pas sur que cela soit possible !!!

Merci de votre aide.

Configuration: Windows / Chrome 88.0.4324.190

4 réponses

M-12
Messages postés
1228
Date d'inscription
lundi 22 septembre 2008
Statut
Membre
Dernière intervention
16 août 2022
268
24 févr. 2021 à 20:39
Bonsoir,
Un p’tit classeur avec 10/15 données anonymisées serait mieux pour régler le soucis

Allez dans https://www.cjoint.com/
Cliquez sur "PARCOURIR" pour sélectionner le classeur
Clic le bouton "CREER LE LIEN"
Clic droit quand le lien est créé "COPIER LE LIEN"
Sur le post Clic droit "Coller".

ou dans https://mon-partage.fr/
1
eriiic
Messages postés
24431
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
17 août 2022
7 108
Modifié le 24 févr. 2021 à 23:45
Bonjour,

pas de " " à FAUX si c'est un booléen et non du texte.
=SI(OU(B4="ao sans visite";B4="op");INDEX(Liste!B3:B17;EQUIV((B13+7);Liste!B3:B17);???))

Par contre est-ce que ta formule est correcte et que tu obtiens la valeur attendue est une autre histoire.
Le 3ème paramètre attendu pour Index() est un n° de colonne, pas un booléen ni un texte. J'ai mis ???
J'ai l'impression que tu as mal placé ta ) et que c'est le 3ème paramètre Type pour Equiv() que tu voulais mettre. Je doute que ce soit 0 (équivalent de FAUX) que tu aies besoin
Comme tu n'expliques rien de ce que tu veux...

Si c'est la date précédent B13 ça sera :
=SI(OU(B4="ao sans visite";B4="op");INDEX(Liste!B3:B17;EQUIV((B13+7);Liste!B3:B17;1)))

et si tu voulais mettre"faux" si la date n'est pas nécessaire (?) :
=SI(OU(B4="ao sans visite";B4="op");INDEX(Liste!B3:B17;EQUIV((B13+7);Liste!B3:B17;1));"faux")

ou
...;FAUX)
???
eric

En essayant continuellement, on finit par réussir. 
Donc plus ça rate, plus on a de chances que ça marche.(les Shadoks)
En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
1
https://mon-partage.fr/f/IrPootF9/

La cellule qui me pose souci est la b15 de l'onglet planning
0
Bonjour,

Je vous remercie pour votre aide. Comme je l'explique dans mon premier message je voulais qu'Excel indique FAUX si la condition n'était pas respectée. J'ai en effet mis la parenthèse au mauvais endroit. Merci beaucoup
0