Démarrage aléatoire [Résolu]

Signaler
Messages postés
8
Date d'inscription
mardi 19 janvier 2021
Statut
Membre
Dernière intervention
16 février 2021
-
Messages postés
8
Date d'inscription
mardi 19 janvier 2021
Statut
Membre
Dernière intervention
16 février 2021
-
Bonjour,

Mon portable est un "vieux" Lenovo W520 et l'OS est une Debian GNU/Linux 9 (stretch) 64 bits.
Depuis quelque jours, j'ai un problème de démarrage :

- une fois sur trois, il n'y a pas de démarrage du tout et l'ordi reste bloqué après avoir écrit une seule ligne à l'écran "/dev/sda1 : clean".
- une fois sur trois il il bloque à "/bin/sh : 1: /bin/systelctl: Input/output error" après avoir signalé que "Failed to start Raise network interfaces", "Failed to start Create Volatile Files and Directories", "Failed to start Network Time Synchronization" et "Failed to start Update UTMP about System Boot/ Shutdown"
- une fois sur trois il démarre proprement.

Du coup, ce soir j'ai décidé de ne plus l'éteindre pour ne pas courir le risque de définitivement ne plus pouvoir le démarrer !
Je viens de passer plusieurs heures à tenter de trouver une explication en lisant des guides et parcourant des forums mais sans succès.
J'ai édité "debug", "kern.log", "messages", "syslog" et "user.log" mais les lignes de ces fichiers sont pour moi comme une langue étrangère que je maîtrise pas car je ne suis qu'un utilisateur lambda, (presque) totalement inculte en informatique.

Merci de votre aide,
Raymond

7 réponses

Bonjour,
Quel est l'état du disque dur ?
Utilise l'utilitaire gnome-disk-utility pour accéder aux données smart.
Messages postés
8
Date d'inscription
mardi 19 janvier 2021
Statut
Membre
Dernière intervention
16 février 2021

Bonjour jns55,
Merci de t'intéresser à ce problème.

Voici ce que me dit gnome-disk utility :
Modèle : HITACHI HTS727550A9E364 (JF3ZD0H0)
Taille : 500 GB (500 107 862 016 octets)
Partitionnement : Master Boot Record
Estimation : Le disque est sain (37 ℃ / 99 ℉)

Volumes
Taille : 30 GB — 18 GB libre (40,4% occupé)
Périphérique : /dev/sda1
Type de partition : Linux (Amorçable)
Contenu : Ext4 (version 1.0) — Monté sur Racine du système de fichiers

Autre chose : dans var/log je ne vois pas de journal de démarrage. Sur le wiki, je vois que "/var/log/boot.log = Les informations enregistrées lors du démarrage du système. Ce fichier n'est pas activé par défaut." Est-il possible de forcer Debian a créer ce journal ?

Cordialement,
Raymond
Ce sont les données smart du disque qu'il faut examiner de manière à voir si le disque est sain.
https://doc.ubuntu-fr.org/_media/disks/gnome-disks-smart-2.png?w=500&tok=13baa8

Voir ici :
https://doc.ubuntu-fr.org/gnome-disk-utility#superviserreparer_les_disques_et_les_partitions
paragraphe 2.16.1
Messages postés
8
Date d'inscription
mardi 19 janvier 2021
Statut
Membre
Dernière intervention
16 février 2021

OK, c'est vu et l'auto-test est en cours. Il reste encore 70%.
En attendant qu'il soit achevé, je fais une sauvegarde de /homme, car tout à l'heure mon portable n'a pas voulu se "réveiller" quand je l'ai ouvert après plusieurs heures d'inactivité. Devant son écran noir persistant, j'ai été obligé de l'éteindre "sauvagement". Il est resté un long moment (au moins deux, peut être trois minutes) bloqué sur "/dev/sda1 : clean", avant de se lancer. Ouf...
Messages postés
8
Date d'inscription
mardi 19 janvier 2021
Statut
Membre
Dernière intervention
16 février 2021

Bonsoir,

Voici le résultat de l'autotest :
1 Taux d'erreur de lecture --> 0 / 100 / 62 / 100 / Prédiction de panne / En ligne / OK
2 Performance de débit --> ND / 100 / 40 / 100 / Prédiction de panne / Hors ligne / OK
3 Temps de démarrage --> 2 millisecondes / 183 / 33 / 183 / Prédiction de panne / En ligne / OK
4 Nombre de démarrages/arrêts --> 11 721 / 93 / 0 / 93 / Dépassement de durée de vie / En ligne / OK
5 Nombre de secteurs réalloués --> 0 secteur / 100 / 5 / 100 / Prédiction de panne / En ligne / OK
7 Taux d'erreur d'accès --> 0 / 100 / 67 / 100 / Prédiction de panne / En ligne / OK
8 Performance de temps d'accès --> N/D / 100 / 40 / 100 / Prédiction de panne / Hors ligne / OK
9 Heures de fonctionnement --> 4 années, 2 mois, 29 jours / 15 / 0 / 15 / Dépassement de durée de vie / En ligne / OK
10 Essais de mise en rotation --> 0 / 100 / 60 / 100 / Prédiction de panne / En ligne / OK
12 Nombre d'allumages --> 2 781 / 99 / 0 / 99 / Dépassement de durée de vie / En ligne / OK
191 Taux d'erreur G-sense --> 0 / 100 / 0 / 100 / Dépassement de durée de vie / En ligne / OK
192 Nombre de retraits et d'extinstions --> 24 051 817 / 100 / 0 / 100 / Dépassement de durée de vie / En ligne / OK
193 Nombre de chargements/déchargements --> 2 752 168 / 1 / 0 / 1 / Dépassement de durée de vie / En ligne / OK
194 Température --> 39°C/102°F / 153 / 0 / 153 / Dépassement de durée de vie / En ligne / OK
196 Nombre de réallocations --> 0 / 100 / 0 / 100 / Dépassement de durée de vie / En ligne / OK
197 Nombre de secteurs en attente --> 0 secteur / 100 / 0 / 100 / Dépassement de durée de vie / En ligne / OK
198 Nombre de secteurs incorrigibles --> 0 secteur / 100 / 0 / 100 / Dépassement de durée de vie / En ligne / OK
199 Taux d'erreur CRC UDMA --> 0 / 200 / 0 / 200 / Dépassement de durée de vie / En ligne / OK
223 Nombre d'essais de chargement/déchargement --> 0 / 100 / 0 / 100 / Dépassement de durée de vie / En ligne / OK

Je découvre que mon "vieux" Lenovo a vraiment beaucoup travaillé et devrait prendre sa retraite (comme moi ;-). J'espère qu'il ne me lâchera pas avant que je le remplace. Pour autant, il ne semble pas défaillant, le problème serait-il logiciel ?

Cordialement,
Raymond
Je pense que si c'était un problème logiciel ça te le ferait à tous les coups...
J'ai tout de même des doutes sur l'état de ton disque dur (ou des partitions du disque) même si les données smart sont normales...
Tu n'as pas un autre disque dur sous la main même à connecter en usb sur lequel tu pourrais faire une installation pour voir si le démarrage bloque également ?
Messages postés
8
Date d'inscription
mardi 19 janvier 2021
Statut
Membre
Dernière intervention
16 février 2021

OK, je vais m'acheter un second DD externe. Mon premier est plein depuis la sauvegarde d'hier au soir.
Bien évidemment, en fin d'installation, je demande de placer Grub sur le premier secteur de ce DD n'est-ce-pas ? Et je modifie ensuite le bios pour que le démarrage se fasse sur lui et non sur le DD du Lenovo ?

Par ailleurs, je renouvelle ma question relative à boot.log : est-il possible de forcer sa création ?

Bon dimanche,
Raymond
Boot.log :
https://wiki.debian.org/fr/bootlogd

Bien évidemment, en fin d'installation, je demande de placer Grub sur le premier secteur de ce DD n'est-ce-pas ?
Si le pc boote en mode non-uefi (anciens pc jusqu'à Windows7) la réponse est oui, grub sera installé dans le mbr du disque.
Si le pc boote en uefi (pc récents depuis Windows 8), ça risque d'être plus compliqué car c'est pas sûr que l'installateur acceptera : il installe généralement grub dans la première partition efi qu'il trouve, donc sur le disque interne. Dans ce cas, il est préférable d'extraire le disque dur interne et de le remplacer avant l'installation, c'est pas bien compliqué. Tu n'es pas obligé de refermer le pc pour l'installation.
Messages postés
8
Date d'inscription
mardi 19 janvier 2021
Statut
Membre
Dernière intervention
16 février 2021

Houla ça devient compliqué pour moi.
Bon je regarde demain comment le PC boot.

Je ne veux pas le faire ce soir car j'ai eu trop de mal à le démarrer : plusieurs tentative dont deux en recovery. La première a échoué sur
[DEPEND] >Dependency Failed for Update UTMP about System Runlevel changes
/bin/sh: 1: /sbin/sulogin : Input/output error
/bin/sh: 1: /bin/systemctl: Input/output error

La seconde a fonctionné et j'ai lu par ailleurs qu'après une procédure recovery on pouvait trouver des informations avec la commande journalctl -xb . Si cela te semble utile, je peux te transmettre la sortie. Et je peux te transmettre aussi le journal du démarrage car je l'ai en fait. J'aurais du lire plus attentivement mes sources, la sortie n'est pas le fichier boot (qui est vide) mais le fichier daemon-log.

La galère qui a débuté il y a quelques jours paraît prendre de l'ampleur. Je crois que le plus sage est d'acheter un nouveau PC. Ce qui ne m'empêchera pas de tester ta suggestion : j'aurai d'autant moins de réticence à ouvrir mon Lenovo.

Cordialement,
Raymond
Lorsque tu démarres sur un live-usb (Ubuntu ou Debian live), le démarrage est-il normal ?
Si c'est le cas, le souci est au niveau du disque dur.
Messages postés
8
Date d'inscription
mardi 19 janvier 2021
Statut
Membre
Dernière intervention
16 février 2021

Bonsoir,

Ton hypothèse est probablement juste : le disque dur doit être à l'origine de mon souci.
Comme tu le suggérais, j'ai essayé un démarrage avec une debian live sur une clé usb. Résultat positif.
Par ailleurs, après avoir sauvegardé mon /homme, j'ai remplacé ma debian 9 par la debian 10 pour confirmer qu'il ne s'agit pas d'un problème logiciel. Résultat : le démarrage demeure aléatoire. Y compris avec le mode rescue qui, certaine fois, plante lui aussi.

Je te remercie de tes conseils et je clos ce fil.
Cordialement,
Raymond